summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-05-01 12:23:14 +0000
committerMamoru Komachi <usata@gentoo.org>2004-05-01 12:23:14 +0000
commit3aa0801b0f3d8e5745bfe6dce72d9b4b9c2bb35f (patch)
tree7cde6fe25e9e0ed1032911b974f5bffa35cb3446 /app-emacs/cmail/cmail-2.62.ebuild
parentMark 2.8.5 stable on x86. (Manifest recommit) (diff)
downloadgentoo-2-3aa0801b0f3d8e5745bfe6dce72d9b4b9c2bb35f.tar.gz
gentoo-2-3aa0801b0f3d8e5745bfe6dce72d9b4b9c2bb35f.tar.bz2
gentoo-2-3aa0801b0f3d8e5745bfe6dce72d9b4b9c2bb35f.zip
Initial import. Ebuild submitted by MATSUU Takuto <matsuu@gentoo.org> at GentooJP ebuild Project.
Diffstat (limited to 'app-emacs/cmail/cmail-2.62.ebuild')
-rw-r--r--app-emacs/cmail/cmail-2.62.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-emacs/cmail/cmail-2.62.ebuild b/app-emacs/cmail/cmail-2.62.ebuild
new file mode 100644
index 000000000000..dfadcf251784
--- /dev/null
+++ b/app-emacs/cmail/cmail-2.62.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/cmail/cmail-2.62.ebuild,v 1.1 2004/05/01 12:23:14 usata Exp $
+
+inherit elisp
+
+DESCRIPTION="A simple mail management system for Emacs"
+HOMEPAGE="http://cmail.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/2191/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/emacs"
+RDEPEND="${DEPEND}
+ app-emacs/apel
+ virtual/flim
+ virtual/semi"
+
+S=${WORKDIR}/${P}
+
+SITEFILE="70cmail-gentoo.el"
+
+src_compile() {
+ make || die
+}
+
+src_install() {
+ make \
+ LISPDIR=${D}/${SITELISP} \
+ INFODIR=${D}/usr/share/info \
+ install || die
+
+ elisp-site-file-install ${FILESDIR}/${SITEFILE} || die
+
+ dodoc ChangeLog INTRO* README* RELNOTES*
+ dodoc doc/FAQ doc/README* doc/cmail-r2c* doc/glossary
+ dodoc sample*
+}