summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-10-24 20:57:39 +0000
committerUlrich Müller <ulm@gentoo.org>2007-10-24 20:57:39 +0000
commit1494a3d4b767831e4737a3eb45a6dc4a588b2d8a (patch)
tree5743b9763338d5702ed426214ed6e46ae9c80af3 /app-emacs/csharp-mode
parentamd64 stable, bug 196767 (diff)
downloadgentoo-2-1494a3d4b767831e4737a3eb45a6dc4a588b2d8a.tar.gz
gentoo-2-1494a3d4b767831e4737a3eb45a6dc4a588b2d8a.tar.bz2
gentoo-2-1494a3d4b767831e4737a3eb45a6dc4a588b2d8a.zip
Version bump and remove old.
(Portage version: 2.1.3.16)
Diffstat (limited to 'app-emacs/csharp-mode')
-rw-r--r--app-emacs/csharp-mode/ChangeLog8
-rw-r--r--app-emacs/csharp-mode/csharp-mode-0.5.0.ebuild19
-rw-r--r--app-emacs/csharp-mode/csharp-mode-0.7.0.ebuild35
-rw-r--r--app-emacs/csharp-mode/files/digest-csharp-mode-0.5.03
-rw-r--r--app-emacs/csharp-mode/files/digest-csharp-mode-0.7.03
5 files changed, 45 insertions, 23 deletions
diff --git a/app-emacs/csharp-mode/ChangeLog b/app-emacs/csharp-mode/ChangeLog
index d005279da2c3..cf47dd13a042 100644
--- a/app-emacs/csharp-mode/ChangeLog
+++ b/app-emacs/csharp-mode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/csharp-mode
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/csharp-mode/ChangeLog,v 1.3 2007/07/02 06:34:42 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/csharp-mode/ChangeLog,v 1.4 2007/10/24 20:57:38 ulm Exp $
+
+*csharp-mode-0.7.0 (24 Oct 2007)
+
+ 24 Oct 2007; Ulrich Mueller <ulm@gentoo.org> -csharp-mode-0.5.0.ebuild,
+ +csharp-mode-0.7.0.ebuild:
+ Version bump and remove old.
*csharp-mode-0.6.0-r1 (02 Jul 2007)
diff --git a/app-emacs/csharp-mode/csharp-mode-0.5.0.ebuild b/app-emacs/csharp-mode/csharp-mode-0.5.0.ebuild
deleted file mode 100644
index 474d35619b39..000000000000
--- a/app-emacs/csharp-mode/csharp-mode-0.5.0.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/csharp-mode/csharp-mode-0.5.0.ebuild,v 1.3 2007/04/26 16:06:32 ulm Exp $
-
-inherit elisp
-
-DESCRIPTION="A derived Emacs mode implementing most of the C# rules"
-HOMEPAGE="http://mfgames.com/linux/csharp-mode"
-SRC_URI="http://mfgames.com/linux/releases/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-DEPEND="|| ( app-editors/emacs-cvs app-emacs/cc-mode )"
-
-SIMPLE_ELISP=t
-SITEFILE=80${PN}-gentoo.el
diff --git a/app-emacs/csharp-mode/csharp-mode-0.7.0.ebuild b/app-emacs/csharp-mode/csharp-mode-0.7.0.ebuild
new file mode 100644
index 000000000000..87bd65d969a1
--- /dev/null
+++ b/app-emacs/csharp-mode/csharp-mode-0.7.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/csharp-mode/csharp-mode-0.7.0.ebuild,v 1.1 2007/10/24 20:57:38 ulm Exp $
+
+inherit elisp versionator
+
+DESCRIPTION="A derived Emacs mode implementing most of the C# rules"
+HOMEPAGE="http://mfgames.com/linux/csharp-mode"
+SRC_URI="http://mfgames.com/linux/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+NEED_CCMODE=5.30
+
+DEPEND="|| ( >=app-emacs/cc-mode-${NEED_CCMODE} >=virtual/emacs-22 )"
+RDEPEND="${DEPEND}"
+
+SIMPLE_ELISP=t
+SITEFILE=80${PN}-gentoo.el
+
+pkg_setup () {
+ local HAVE_CCMODE
+ HAVE_CCMODE=$(emacs -batch -q \
+ --eval "(and (require 'cc-mode nil t) (princ c-version))")
+ if [ -z "${HAVE_CCMODE}" ] \
+ || ! version_is_at_least "${NEED_CCMODE}" "${HAVE_CCMODE}"; then
+ eerror "This package needs at least cc-mode version ${NEED_CCMODE}."
+ eerror "You should either install package app-emacs/cc-mode,"
+ eerror "or use \"eselect emacs\" to select an Emacs version >= 22."
+ die "cc-mode version ${HAVE_CCMODE} is too low."
+ fi
+}
diff --git a/app-emacs/csharp-mode/files/digest-csharp-mode-0.5.0 b/app-emacs/csharp-mode/files/digest-csharp-mode-0.5.0
deleted file mode 100644
index 92d9a8b62e82..000000000000
--- a/app-emacs/csharp-mode/files/digest-csharp-mode-0.5.0
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 e58afd4a1d708ac227ab52b1420ef2f3 csharp-mode-0.5.0.tar.bz2 5439
-RMD160 8d3a6a8ef85fdda514919b2f53b50436a558e887 csharp-mode-0.5.0.tar.bz2 5439
-SHA256 0fcec187188cd9d349a1fc1962cf9b9e257d770ca267d5b657bdf7553b910dd6 csharp-mode-0.5.0.tar.bz2 5439
diff --git a/app-emacs/csharp-mode/files/digest-csharp-mode-0.7.0 b/app-emacs/csharp-mode/files/digest-csharp-mode-0.7.0
new file mode 100644
index 000000000000..963b01da7f00
--- /dev/null
+++ b/app-emacs/csharp-mode/files/digest-csharp-mode-0.7.0
@@ -0,0 +1,3 @@
+MD5 ae006694e2eac94d92952d0071cbb22c csharp-mode-0.7.0.tar.bz2 6254
+RMD160 8ad1e95a461d7f1369a5a4395fe6119508a41979 csharp-mode-0.7.0.tar.bz2 6254
+SHA256 e72a17972283691c33080aaa60d8060576d2951f1e374da223cf76468bd2eeec csharp-mode-0.7.0.tar.bz2 6254