summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-02-20 18:11:41 +0000
committerUlrich Müller <ulm@gentoo.org>2009-02-20 18:11:41 +0000
commitce5bbc8e891f3ca6133e68d3ae4bd187f32fd26b (patch)
tree69b7158a9867447936c547417bfe72577a6210aa /app-emacs/distel
parentarm/s390/sh stable wrt #223879 (diff)
downloadgentoo-2-ce5bbc8e891f3ca6133e68d3ae4bd187f32fd26b.tar.gz
gentoo-2-ce5bbc8e891f3ca6133e68d3ae4bd187f32fd26b.tar.bz2
gentoo-2-ce5bbc8e891f3ca6133e68d3ae4bd187f32fd26b.zip
Version bump and fix path for ebin files, bug 259695.
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'app-emacs/distel')
-rw-r--r--app-emacs/distel/ChangeLog12
-rw-r--r--app-emacs/distel/distel-4.03.ebuild45
-rw-r--r--app-emacs/distel/files/50distel-gentoo.el1
-rw-r--r--app-emacs/distel/files/distel-4.03-fix-ebin-path.patch29
4 files changed, 85 insertions, 2 deletions
diff --git a/app-emacs/distel/ChangeLog b/app-emacs/distel/ChangeLog
index aeb51210129b..9e6f47ff76f4 100644
--- a/app-emacs/distel/ChangeLog
+++ b/app-emacs/distel/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emacs/distel
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/distel/ChangeLog,v 1.3 2008/08/28 07:33:30 ulm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/distel/ChangeLog,v 1.4 2009/02/20 18:11:41 ulm Exp $
+
+*distel-4.03 (20 Feb 2009)
+
+ 20 Feb 2009; Ulrich Mueller <ulm@gentoo.org>
+ +files/distel-4.03-fix-ebin-path.patch, files/50distel-gentoo.el,
+ +distel-4.03.ebuild:
+ Version bump and fix path for ebin files, bug 259695. Thanks to
+ Sergey Sinkovskiy <glorybox.away@gmail.com>.
28 Aug 2008; Ulrich Mueller <ulm@gentoo.org> distel-3.2_p20071103.ebuild:
Use elisp-compile instead of elisp-comp, bug 235442.
diff --git a/app-emacs/distel/distel-4.03.ebuild b/app-emacs/distel/distel-4.03.ebuild
new file mode 100644
index 000000000000..7709ff3c9631
--- /dev/null
+++ b/app-emacs/distel/distel-4.03.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/distel/distel-4.03.ebuild,v 1.1 2009/02/20 18:11:41 ulm Exp $
+
+EAPI=2
+
+inherit elisp eutils
+
+DESCRIPTION="Distributed Emacs Lisp for Erlang"
+HOMEPAGE="http://fresh.homeunix.net/~luke/distel/"
+SRC_URI="http://distel.googlecode.com/files/${P}.tgz"
+
+# "New BSD License" according to http://code.google.com/p/distel/
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=">=dev-lang/erlang-11.2.5[emacs]"
+RDEPEND="${DEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-fix-ebin-path.patch"
+}
+
+src_compile() {
+ emake base info || die "emake failed"
+ cd elisp
+ elisp-compile *.el || die "elisp-compile failed"
+}
+
+src_install() {
+ emake prefix="${D}"/usr \
+ ELISP_DIR="${D}${SITELISP}/${PN}" install \
+ || die "emake install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ doinfo doc/distel.info || die "doinfo failed"
+ dohtml doc/distel/*.html || die "dohtml failed"
+ dodoc AUTHORS ChangeLog NEWS README* || die "dodoc failed"
+ if use doc; then
+ dodoc doc/gorrie02distel.pdf || die "dodoc failed"
+ fi
+}
diff --git a/app-emacs/distel/files/50distel-gentoo.el b/app-emacs/distel/files/50distel-gentoo.el
index 934a7620732f..14c8beeee70c 100644
--- a/app-emacs/distel/files/50distel-gentoo.el
+++ b/app-emacs/distel/files/50distel-gentoo.el
@@ -4,3 +4,4 @@
(add-to-list 'load-path "@SITELISP@")
(autoload 'distel-erlang-mode-hook "distel" nil t)
(add-hook 'erlang-mode-hook 'distel-erlang-mode-hook)
+(setq distel-ebin-directory "/usr/share/distel/ebin")
diff --git a/app-emacs/distel/files/distel-4.03-fix-ebin-path.patch b/app-emacs/distel/files/distel-4.03-fix-ebin-path.patch
new file mode 100644
index 000000000000..21f6b7caefa8
--- /dev/null
+++ b/app-emacs/distel/files/distel-4.03-fix-ebin-path.patch
@@ -0,0 +1,29 @@
+http://bugs.gentoo.org/259695
+
+--- distel-4.03-orig/elisp/erl-service.el 2008-06-25 19:05:09.000000000 +0200
++++ distel-4.03/elisp/erl-service.el 2009-02-20 19:01:31.000000000 +0100
+@@ -172,15 +172,18 @@
+ (&erl-load-backend node))
+ (_ t))))))
+
++(defvar distel-ebin-directory
++ (let ((elisp-directory
++ (file-name-directory (or (locate-library "distel") load-file-name))))
++ (concat elisp-directory "../ebin"))
++ "Directory where beam files are located.")
++
+ (defun &erl-load-backend (node)
+- (let* ((elisp-directory
+- (file-name-directory (or (locate-library "distel") load-file-name)))
+- (ebin-directory (concat elisp-directory "../ebin"))
+- (modules '()))
+- (dolist (file (directory-files ebin-directory))
++ (let ((modules '()))
++ (dolist (file (directory-files distel-ebin-directory))
+ (when (string-match "^\\(.*\\)\\.beam$" file)
+ (let ((module (intern (match-string 1 file)))
+- (filename (concat ebin-directory "/" file)))
++ (filename (concat distel-ebin-directory "/" file)))
+ (push (list module filename) modules))))
+ (if (null modules)
+ (erl-warn-backend-problem "don't have beam files")