summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-07-10 13:02:05 +0000
committerUlrich Müller <ulm@gentoo.org>2010-07-10 13:02:05 +0000
commit83a537fe602770e65156659e15b8e7bdcf40466e (patch)
tree8ddf96ea998d43ec1b04e373885a5184d0fcd3b1 /app-emacs/haskell-mode/haskell-mode-2.8.0.ebuild
parentstable amd64, bug 323385 (diff)
downloadgentoo-2-83a537fe602770e65156659e15b8e7bdcf40466e.tar.gz
gentoo-2-83a537fe602770e65156659e15b8e7bdcf40466e.tar.bz2
gentoo-2-83a537fe602770e65156659e15b8e7bdcf40466e.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-emacs/haskell-mode/haskell-mode-2.8.0.ebuild')
-rw-r--r--app-emacs/haskell-mode/haskell-mode-2.8.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/haskell-mode/haskell-mode-2.8.0.ebuild b/app-emacs/haskell-mode/haskell-mode-2.8.0.ebuild
new file mode 100644
index 000000000000..15da52aa9b92
--- /dev/null
+++ b/app-emacs/haskell-mode/haskell-mode-2.8.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/haskell-mode/haskell-mode-2.8.0.ebuild,v 1.1 2010/07/10 13:02:05 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Mode for editing (and running) Haskell programs in Emacs"
+HOMEPAGE="http://projects.haskell.org/haskellmode-emacs/
+ http://www.haskell.org/haskellwiki/Haskell_mode_for_Emacs"
+SRC_URI="http://projects.haskell.org/haskellmode-emacs/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DOCS="ChangeLog NEWS README *.hs"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-make-autoload-file haskell-site-file.el || die
+ elisp-compile *.el || die
+}
+
+pkg_postinst() {
+ elisp-site-regen
+
+ elog "If you update from before version 2.5 you must reconfigure,"
+ elog "or indentation will not work."
+ elog "Read the README file in /usr/share/doc/${PF}."
+}