summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-03-28 18:41:17 +0000
committerUlrich Müller <ulm@gentoo.org>2009-03-28 18:41:17 +0000
commit6661efcd82dae2f55c8dcbaac7f6e2b51f24e1e3 (patch)
tree258154e3eec2c259489fe2efdbe8d8057c041ffe /app-emacs/jde
parentAdd patch from upstream, fixes bug 259891. Remove old. (diff)
downloadgentoo-2-6661efcd82dae2f55c8dcbaac7f6e2b51f24e1e3.tar.gz
gentoo-2-6661efcd82dae2f55c8dcbaac7f6e2b51f24e1e3.tar.bz2
gentoo-2-6661efcd82dae2f55c8dcbaac7f6e2b51f24e1e3.zip
Version bump, snapshot of upstream subversion repository. Bug 259933.
(Portage version: 2.2_rc27/cvs/Linux i686)
Diffstat (limited to 'app-emacs/jde')
-rw-r--r--app-emacs/jde/ChangeLog14
-rw-r--r--app-emacs/jde/files/70jde-gentoo-2.3.6_pre20081208.el12
-rw-r--r--app-emacs/jde/files/jde-2.3.6_pre20081208-classpath-gentoo.patch69
-rw-r--r--app-emacs/jde/files/jde-2.3.6_pre20081208-fix-paths-gentoo.patch211
-rw-r--r--app-emacs/jde/jde-2.3.6_pre20081208.ebuild70
5 files changed, 375 insertions, 1 deletions
diff --git a/app-emacs/jde/ChangeLog b/app-emacs/jde/ChangeLog
index a09c77570e68..c406ccfa759e 100644
--- a/app-emacs/jde/ChangeLog
+++ b/app-emacs/jde/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for app-emacs/jde
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/jde/ChangeLog,v 1.32 2009/03/21 08:16:44 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/jde/ChangeLog,v 1.33 2009/03/28 18:41:17 ulm Exp $
+
+*jde-2.3.6_pre20081208 (28 Mar 2009)
+
+ 28 Mar 2009; Ulrich Mueller <ulm@gentoo.org>
+ +files/jde-2.3.6_pre20081208-classpath-gentoo.patch,
+ +files/jde-2.3.6_pre20081208-fix-paths-gentoo.patch,
+ +files/70jde-gentoo-2.3.6_pre20081208.el, +jde-2.3.6_pre20081208.ebuild:
+ Version bump, from Emacs overlay. Snapshot of upstream subversion
+ repository. Updated ebuild from Johan Andersson <re_jeep@hotmail.com>,
+ with changes by Alistair Bush <ali_bush@gentoo.org> and myself; bug 259933.
+ Install all Java files in proper locations outside of SITELISP. Make paths
+ configurable. Initialise classpath using java-config.
*jde-2.3.5.1-r2 (21 Mar 2009)
diff --git a/app-emacs/jde/files/70jde-gentoo-2.3.6_pre20081208.el b/app-emacs/jde/files/70jde-gentoo-2.3.6_pre20081208.el
new file mode 100644
index 000000000000..b18e3c5c6911
--- /dev/null
+++ b/app-emacs/jde/files/70jde-gentoo-2.3.6_pre20081208.el
@@ -0,0 +1,12 @@
+
+;;; jde site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(require 'jde-autoload)
+
+(setq jde-java-directory "/usr/share/jde")
+(setq jde-bsh-jar-file "@BSH_JAR@")
+(setq jde-checkstyle-jar-file "@CHECKSTYLE_JAR@")
+(setq jde-checkstyle-style "/usr/share/checkstyle/checks/sun_checks.xml")
+(setq jde-html-directory "/usr/share/doc/@PF@/html")
+(setq bsh-html-directory "/usr/share/doc/@PF@/html")
diff --git a/app-emacs/jde/files/jde-2.3.6_pre20081208-classpath-gentoo.patch b/app-emacs/jde/files/jde-2.3.6_pre20081208-classpath-gentoo.patch
new file mode 100644
index 000000000000..697d3a5440f1
--- /dev/null
+++ b/app-emacs/jde/files/jde-2.3.6_pre20081208-classpath-gentoo.patch
@@ -0,0 +1,69 @@
+Initialise classpath for beanshell and checkstyle using java-config.
+Gentoo specific patch.
+
+--- jde-orig/lisp/beanshell.el 2009-03-25 11:12:01.000000000 +0100
++++ jde/lisp/beanshell.el 2009-03-25 14:35:02.000000000 +0100
+@@ -785,6 +785,14 @@
+ "BeanShell intended to be used independently of any other
+ Emacs package.")
+
++(defun bsh-get-gentoo-classpath ()
++ (or bsh-classpath
++ (with-temp-buffer
++ (call-process "java-config" nil t nil "-d" "-p" "bsh")
++ (skip-chars-backward "\n")
++ (setq bsh-classpath
++ (split-string (buffer-substring (point-min) (point)) ":+")))))
++
+ (defmethod initialize-instance ((this bsh-standalone-bsh) &rest fields)
+ "Constructor for the standard bsh BeanShell instance."
+ (call-next-method)
+@@ -821,7 +829,7 @@
+ bsh-vm)
+ (executable-find (if (eq system-type 'windows-nt) "javaw" "java"))))
+
+- (oset this cp bsh-classpath)
++ (oset this cp (bsh-get-gentoo-classpath))
+
+ (oset this startup-dir bsh-startup-directory))
+
+--- jde-orig/lisp/jde-checkstyle.el 2009-03-25 11:12:01.000000000 +0100
++++ jde/lisp/jde-checkstyle.el 2009-03-25 14:35:41.000000000 +0100
+@@ -299,6 +299,14 @@
+ (format "-D%s=%s" (car prop) (cdr prop)))
+ jde-checkstyle-expanded-properties))
+
++(defun jde-checkstyle-get-gentoo-classpath ()
++ (or jde-checkstyle-classpath
++ (with-temp-buffer
++ (call-process "java-config" nil t nil "-d" "-p" "checkstyle")
++ (skip-chars-backward "\n")
++ (setq jde-checkstyle-classpath
++ (split-string (buffer-substring (point-min) (point)) ":+")))))
++
+ (defmethod jde-checkstyle-exec ((this jde-checkstyle-checker))
+
+ (jde-checkstyle-create-checker-buffer this)
+@@ -321,9 +329,8 @@
+ (jde-checkstyle-get-property-args this))
+ (oref this :interactive-args)
+ (list "-classpath"
+- (if jde-checkstyle-classpath
+- (jde-build-classpath jde-checkstyle-classpath)
+- (jde-normalize-path jde-checkstyle-jar-file)))
++ (jde-build-classpath
++ (jde-checkstyle-get-gentoo-classpath)))
+ (list jde-checkstyle-class)
+ (list "-c"
+ (if jde-checkstyle-style
+--- jde-orig/lisp/jde.el 2009-03-25 11:12:01.000000000 +0100
++++ jde/lisp/jde.el 2009-03-25 14:35:22.000000000 +0100
+@@ -2545,7 +2545,7 @@
+ (jde-get-tools-jar)
+ (if ant-home (expand-file-name "lib" ant-home)))
+ (jde-pi-get-bsh-classpath)
+- bsh-classpath
++ (bsh-get-gentoo-classpath)
+ (jde-expand-classpath (jde-get-global-classpath)))))))
+
+ ;; Create the BeanShell wrapper object.
diff --git a/app-emacs/jde/files/jde-2.3.6_pre20081208-fix-paths-gentoo.patch b/app-emacs/jde/files/jde-2.3.6_pre20081208-fix-paths-gentoo.patch
new file mode 100644
index 000000000000..3c0b9e891c3a
--- /dev/null
+++ b/app-emacs/jde/files/jde-2.3.6_pre20081208-fix-paths-gentoo.patch
@@ -0,0 +1,211 @@
+Make paths of directories and jar files configurable.
+
+Part of this patch was taken from Debian and heavily modified, see:
+http://patch-tracking.debian.net/patch/series/view/jde/2.3.5.1-5/0005-Set-the-location-of-needed-files-for-beanshell.el-an.patch
+
+--- jde-orig/lisp/beanshell.el 2007-12-29 04:21:28.000000000 +0100
++++ jde/lisp/beanshell.el 2009-03-20 22:00:01.000000000 +0100
+@@ -890,14 +890,18 @@
+
+ (add-to-list 'auto-mode-alist '("\\.bsh\\'" . bsh-script-mode))
+
++(defcustom bsh-html-directory (bsh-find-bsh-data-directory)
++ "Directory of the beanshell HTML documentation."
++ :group 'bsh
++ :type 'directory)
++
+ ;;;###autoload
+ (defun bsh-script-help ()
+ "Display BeanShell User's Guide."
+ (interactive)
+- (let* ((bsh-dir (bsh-find-bsh-data-directory))
+- (bsh-help
+- (if bsh-dir
+- (expand-file-name "bsh-ug.html" bsh-dir))))
++ (let ((bsh-help
++ (if bsh-html-directory
++ (expand-file-name "bsh-ug.html" bsh-html-directory))))
+ (if (and
+ bsh-help
+ (file-exists-p bsh-help))
+--- jde-orig/lisp/jde-bug.el 2007-12-29 04:21:28.000000000 +0100
++++ jde/lisp/jde-bug.el 2009-03-20 19:32:17.000000000 +0100
+@@ -2437,10 +2437,10 @@
+ (defun jde-bug-help ()
+ "Displays the JDEbug User's Guide."
+ (interactive)
+- (let* ((jde-dir (jde-find-jde-doc-directory))
+- (jdebug-help
+- (if jde-dir
+- (expand-file-name "doc/html/jdebug-ug/jdebug-ug.html" jde-dir))))
++ (let ((jdebug-help
++ (if jde-html-directory
++ (expand-file-name "jdebug-ug/jdebug-ug.html"
++ jde-html-directory))))
+ (if (and
+ jdebug-help
+ (file-exists-p jdebug-help))
+--- jde-orig/lisp/jde-checkstyle.el 2007-12-29 04:21:28.000000000 +0100
++++ jde/lisp/jde-checkstyle.el 2009-03-20 21:56:44.000000000 +0100
+@@ -316,10 +316,6 @@
+ (vm-path (oref (jde-run-get-vm) :path))
+ (source-file
+ (concat (file-name-nondirectory buffer-file-name)))
+- (jde-java-directory
+- (concat
+- (jde-find-jde-data-directory)
+- "java/"))
+ (args (append
+ (unless jde-checkstyle-expanded-properties-file
+ (jde-checkstyle-get-property-args this))
+@@ -327,13 +323,13 @@
+ (list "-classpath"
+ (if jde-checkstyle-classpath
+ (jde-build-classpath jde-checkstyle-classpath)
+- (jde-normalize-path
+- (expand-file-name "lib/checkstyle-all.jar" jde-java-directory))))
++ (jde-normalize-path jde-checkstyle-jar-file)))
+ (list jde-checkstyle-class)
+ (list "-c"
+ (if jde-checkstyle-style
+ (jde-normalize-path jde-checkstyle-style)
+- (concat (jde-find-jde-data-directory) "java/lib/sun_checks.xml")))
++ (expand-file-name "lib/sun_checks.xml"
++ jde-java-directory)))
+ (if jde-checkstyle-expanded-properties-file
+ (list "-p" (jde-normalize-path jde-checkstyle-expanded-properties-file)))
+ (if jde-checkstyle-module-package-names-file
+--- jde-orig/lisp/jde-dbs.el 2007-12-29 04:21:28.000000000 +0100
++++ jde/lisp/jde-dbs.el 2009-03-20 21:57:58.000000000 +0100
+@@ -899,9 +899,6 @@
+ (jde-normalize-path 'jde-run-working-directory)
+ source-directory))
+ (vm (oref (jde-run-get-vm) :path))
+- (jde-java-directory
+- (expand-file-name "java"
+- (jde-find-jde-data-directory)))
+ (vm-args
+ (let (args)
+ (setq args
+--- jde-orig/lisp/jde.el 2008-12-08 01:51:15.000000000 +0100
++++ jde/lisp/jde.el 2009-03-20 21:40:13.000000000 +0100
+@@ -1731,14 +1731,19 @@
+ jde.el."
+ (jde-find-jde-data-directory))
+
++(defcustom jde-html-directory
++ (expand-file-name "doc/html" (jde-find-jde-doc-directory))
++ "Directory of the JDE HTML documentation."
++ :group 'jde-project
++ :type 'directory)
++
+ ;;;###autoload
+ (defun jde-show-help ()
+ "Displays the JDE User's Guide in a browser."
+ (interactive)
+- (let* ((jde-dir (jde-find-jde-doc-directory))
+- (jde-help
+- (if jde-dir
+- (expand-file-name "doc/html/jde-ug/jde-ug.html" jde-dir))))
++ (let ((jde-help
++ (if jde-html-directory
++ (expand-file-name "jde-ug/jde-ug.html" jde-html-directory))))
+ (if (and
+ jde-help
+ (file-exists-p jde-help))
+@@ -2445,21 +2450,58 @@
+ "The single instance of the JDEE's BeanShell."))
+ "Class of JDEE BeanShells. There is only one per Emacs session.")
+
++(defcustom jde-java-directory
++ (expand-file-name "java" (jde-find-jde-data-directory))
++ "Top-level directory of JDE Java files."
++ :group 'jde-project
++ :type 'directory)
++
++(defcustom jde-bsh-commands-directory
++ (expand-file-name "bsh-commands" jde-java-directory)
++ "Directory of beanshell commands."
++ :group 'bsh
++ :type 'directory)
++
++(defcustom jde-classes-directory
++ (expand-file-name "classes" jde-java-directory)
++ "Directory of JDE classes."
++ :group 'jde-project
++ :type 'directory)
++
++(defcustom jde-checkstyle-jar-file
++ (expand-file-name "lib/checkstyle-all.jar" jde-java-directory)
++ "Path of the checkstyle-jar file."
++ :group 'jde-project
++ :type 'file)
++
++(defcustom jde-regexp-jar-file
++ (expand-file-name "lib/jakarta-regexp.jar" jde-java-directory)
++ "Path of the regexp-jar file."
++ :group 'jde-project
++ :type 'file)
++
++(defcustom jde-jde-jar-file
++ (expand-file-name "lib/jde.jar" jde-java-directory)
++ "Path of the jde-jar file."
++ :group 'jde-project
++ :type 'file)
++
++(defcustom jde-bsh-jar-file
++ (expand-file-name "lib/bsh.jar" jde-java-directory)
++ "Path of the bsh-jar file."
++ :group 'jde-project
++ :type 'file)
++
+ (defmethod initialize-instance ((this jde-bsh) &rest fields)
+ "Constructor for the JDEE BeanShell instance."
+ (call-next-method)
+- (let* ((jde-java-directory
+- (concat
+- (jde-find-jde-data-directory)
+- "java/")))
+-
+- (oset this bsh-cmd-dir (expand-file-name "bsh-commands" jde-java-directory))
+- (oset this checkstyle-jar (expand-file-name "lib/checkstyle-all.jar" jde-java-directory))
+- (oset this regexp-jar (expand-file-name "lib/jakarta-regexp.jar" jde-java-directory))
+- (oset this jde-classes-dir (expand-file-name "classes" jde-java-directory))
+- (oset this jde-jar (expand-file-name "lib/jde.jar" jde-java-directory))
+- (oset this jar (expand-file-name "lib/bsh.jar" jde-java-directory))
+- (oset-default 'jde-bsh the-bsh this)))
++ (oset this bsh-cmd-dir jde-bsh-commands-directory)
++ (oset this checkstyle-jar jde-checkstyle-jar-file)
++ (oset this regexp-jar jde-regexp-jar-file)
++ (oset this jde-classes-dir jde-classes-directory)
++ (oset this jde-jar jde-jde-jar-file)
++ (oset this jar jde-bsh-jar-file)
++ (oset-default 'jde-bsh the-bsh this))
+
+ (defmethod bsh-create-buffer ((this jde-bsh))
+ "Creates the JDEE's beanshell buffer."
+@@ -2503,6 +2545,7 @@
+ (jde-get-tools-jar)
+ (if ant-home (expand-file-name "lib" ant-home)))
+ (jde-pi-get-bsh-classpath)
++ bsh-classpath
+ (jde-expand-classpath (jde-get-global-classpath)))))))
+
+ ;; Create the BeanShell wrapper object.
+--- jde-orig/lisp/jde-jdb.el 2007-12-29 04:21:28.000000000 +0100
++++ jde/lisp/jde-jdb.el 2009-03-20 19:33:33.000000000 +0100
+@@ -1463,10 +1463,10 @@
+
+ (defun jde-jdb-help ()
+ (interactive)
+- (let* ((jde-dir (jde-find-jde-doc-directory))
+- (jdb-ug-path
+- (if jde-dir
+- (expand-file-name "doc/html/jdb-ug/jdb-ug-frame.html" jde-dir))))
++ (let ((jdb-ug-path
++ (if jde-html-directory
++ (expand-file-name "jdb-ug/jdb-ug-frame.html"
++ jde-html-directory))))
+ (if (and
+ jdb-ug-path
+ (file-exists-p jdb-ug-path))
diff --git a/app-emacs/jde/jde-2.3.6_pre20081208.ebuild b/app-emacs/jde/jde-2.3.6_pre20081208.ebuild
new file mode 100644
index 000000000000..3f983ded13b6
--- /dev/null
+++ b/app-emacs/jde/jde-2.3.6_pre20081208.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/jde/jde-2.3.6_pre20081208.ebuild,v 1.1 2009/03/28 18:41:17 ulm Exp $
+
+EAPI=2
+WANT_ANT_TASKS="ant-nodeps"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2 elisp eutils
+
+DESCRIPTION="Java Development Environment for Emacs"
+HOMEPAGE="http://jdee.sourceforge.net/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.3
+ app-emacs/elib
+ >=app-emacs/cedet-1.0_beta3
+ dev-java/bsh
+ dev-java/junit:0
+ dev-util/checkstyle"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+SITEFILE="70${PN}-gentoo.el"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.3.5.1-import.patch"
+ epatch "${FILESDIR}/${P}-fix-paths-gentoo.patch"
+ epatch "${FILESDIR}/${P}-classpath-gentoo.patch"
+
+ local bshjar csjar
+ bshjar=$(java-pkg_getjar --build-only bsh bsh.jar) || die
+ csjar=$(java-pkg_getjar --build-only checkstyle checkstyle.jar) || die
+ sed -e "s:@BSH_JAR@:${bshjar}:;s:@CHECKSTYLE_JAR@:${csjar}:" \
+ -e "s:@PF@:${PF}:" "${FILESDIR}/${SITEFILE/.el/-${PV}.el}" \
+ >"${SITEFILE}" || die
+
+ cd java/lib || die
+ java-pkg_jar-from --build-only checkstyle checkstyle.jar checkstyle-all.jar
+ java-pkg_jar-from junit
+ java-pkg_jar-from bsh
+}
+
+src_compile() {
+ eant dist \
+ -Dcedet.dir="${SITELISP}/cedet" \
+ -Delib.dir="${SITELISP}/elib"
+}
+
+src_install() {
+ java-pkg_dojar dist/java/lib/jde.jar
+ insinto "${JAVA_PKG_SHAREPATH}"
+ doins -r java/bsh-commands || die
+
+ use source && java-pkg_dosrc java/src/*
+ use doc && java-pkg_dojavadoc dist/doc/java/api
+
+ elisp-install ${PN} dist/lisp/*.{el,elc} || die
+ elisp-site-file-install "${SITEFILE}" || die
+
+ dobin lisp/jtags || die
+
+ dohtml -r dist/doc/html/* || die
+ dodoc lisp/readme.txt lisp/ChangeLog lisp/ReleaseNotes.txt
+}