summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
commit08bd106430ca5599005323021f7635b2f1a1f72b (patch)
treed56e46390f1a7838a1a5eecfd8573e5eb47d0c98 /app-emacs/mailcrypt
parentmasked app-emacs/monk (incomplete for now) (diff)
downloadgentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.gz
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.bz2
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.zip
looks like an app-emacs/ import to me
Diffstat (limited to 'app-emacs/mailcrypt')
-rw-r--r--app-emacs/mailcrypt/ChangeLog11
-rw-r--r--app-emacs/mailcrypt/files/50mailcrypt-gentoo.el4
-rw-r--r--app-emacs/mailcrypt/files/digest-mailcrypt-3.5.71
-rw-r--r--app-emacs/mailcrypt/mailcrypt-3.5.7.ebuild44
4 files changed, 60 insertions, 0 deletions
diff --git a/app-emacs/mailcrypt/ChangeLog b/app-emacs/mailcrypt/ChangeLog
new file mode 100644
index 000000000000..665d68281540
--- /dev/null
+++ b/app-emacs/mailcrypt/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/mailcrypt
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/mailcrypt/ChangeLog,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+*mailcrypt-3.5.7 (31 Oct 2002)
+
+ 31 Oct 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ mailcrypt-3.5.7.ebuild, files/50mailcrypt-gentoo.el,
+ files/digest-mailcrypt-3.5.7 :
+
+ Initial import.
diff --git a/app-emacs/mailcrypt/files/50mailcrypt-gentoo.el b/app-emacs/mailcrypt/files/50mailcrypt-gentoo.el
new file mode 100644
index 000000000000..3205b33aa57f
--- /dev/null
+++ b/app-emacs/mailcrypt/files/50mailcrypt-gentoo.el
@@ -0,0 +1,4 @@
+
+;;; mailcrypt site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
diff --git a/app-emacs/mailcrypt/files/digest-mailcrypt-3.5.7 b/app-emacs/mailcrypt/files/digest-mailcrypt-3.5.7
new file mode 100644
index 000000000000..de87f2fb3f62
--- /dev/null
+++ b/app-emacs/mailcrypt/files/digest-mailcrypt-3.5.7
@@ -0,0 +1 @@
+MD5 e4684025d4c876baa6fa5371f9efd72a mailcrypt-3.5.7.tar.gz 194857
diff --git a/app-emacs/mailcrypt/mailcrypt-3.5.7.ebuild b/app-emacs/mailcrypt/mailcrypt-3.5.7.ebuild
new file mode 100644
index 000000000000..ce13d599c240
--- /dev/null
+++ b/app-emacs/mailcrypt/mailcrypt-3.5.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/mailcrypt/mailcrypt-3.5.7.ebuild,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Provides a simple interface to public key cryptography with PGP [and now GnuPG!]."
+HOMEPAGE="http://mailcrypt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mailcrypt/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs"
+RDEPEND="${DEPEND}
+ app-crypt/gnupg"
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ EMACS=emacs ./configure --prefix=/usr || die
+ make || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ infodir=${D}/usr/share/info install \
+ lispdir=${D}/${SITELISP}/${PN} || die
+ elisp-site-file-install ${FILESDIR}/50mailcrypt-gentoo.el
+ dodoc ANNOUNCE ChangeLog* INSTALL LCD-entry mailcrypt.dvi NEWS ONEWS README*
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo ""
+ einfo "See /usr/share/doc/${P}/INSTALL.gz for how to customize mailcrypt"
+ einfo ""
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}