summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-04-05 21:10:09 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-04-05 21:10:09 +0000
commit2eea660aeedfde06730e17005691d43761d786ad (patch)
treee64ca7c7bff7fa204f25937a8e2babad1f83f801 /app-emacs/nxml-gentoo-schemas
parentStable on alpha, bug #144623 (diff)
downloadgentoo-2-2eea660aeedfde06730e17005691d43761d786ad.tar.gz
gentoo-2-2eea660aeedfde06730e17005691d43761d786ad.tar.bz2
gentoo-2-2eea660aeedfde06730e17005691d43761d786ad.zip
Version bump, add more filetypes to the locating rules.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-emacs/nxml-gentoo-schemas')
-rw-r--r--app-emacs/nxml-gentoo-schemas/ChangeLog8
-rw-r--r--app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20080405.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/app-emacs/nxml-gentoo-schemas/ChangeLog b/app-emacs/nxml-gentoo-schemas/ChangeLog
index 3b4b45c56a19..57e271b1f604 100644
--- a/app-emacs/nxml-gentoo-schemas/ChangeLog
+++ b/app-emacs/nxml-gentoo-schemas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/nxml-gentoo-schemas
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/nxml-gentoo-schemas/ChangeLog,v 1.14 2008/03/01 14:13:54 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/nxml-gentoo-schemas/ChangeLog,v 1.15 2008/04/05 21:10:09 flameeyes Exp $
+
+*nxml-gentoo-schemas-20080405 (05 Apr 2008)
+
+ 05 Apr 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +nxml-gentoo-schemas-20080405.ebuild:
+ Version bump, add more filetypes to the locating rules.
01 Mar 2008; Ulrich Mueller <ulm@gentoo.org>
nxml-gentoo-schemas-20080301.ebuild:
diff --git a/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20080405.ebuild b/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20080405.ebuild
new file mode 100644
index 000000000000..942af352c0ec
--- /dev/null
+++ b/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20080405.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20080405.ebuild,v 1.1 2008/04/05 21:10:09 flameeyes Exp $
+
+inherit elisp
+
+DESCRIPTION="Extension for nxml-mode with Gentoo-specific schemas"
+HOMEPAGE="http://blog.flameeyes.eu/"
+SRC_URI="http://www.flameeyes.eu/files/${P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="|| ( >=app-emacs/nxml-mode-20041004-r3 >=virtual/emacs-23 )"
+
+SITEFILE=60${PN}-gentoo.el
+
+src_compile() { :; }
+
+src_install() {
+ insinto ${SITEETC}/${PN}
+ doins schemas.xml *.rnc || die "install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ dodoc DONATING
+}
+
+pkg_postinst () {
+ elisp-site-regen
+
+ if [ $(emacs -batch -q --eval "(princ (fboundp 'nxml-mode))") = nil ]; then
+ ewarn "This package needs nxml-mode. You should either install"
+ ewarn "app-emacs/nxml-mode, or use \"eselect emacs\" to select"
+ ewarn "an Emacs version >= 23."
+ fi
+}