summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-10-23 13:15:50 +0000
committerUlrich Müller <ulm@gentoo.org>2007-10-23 13:15:50 +0000
commite329d596756dd8803a367298cfc06f9a9bc161b1 (patch)
tree34e93ac1528d26b147575cf340c9c2d74b5ce099 /app-emacs/ocaml-mode
parentKeyworded ~sparc-fbsd (diff)
downloadgentoo-2-e329d596756dd8803a367298cfc06f9a9bc161b1.tar.gz
gentoo-2-e329d596756dd8803a367298cfc06f9a9bc161b1.tar.bz2
gentoo-2-e329d596756dd8803a367298cfc06f9a9bc161b1.zip
Make syntax highlighting work again.
(Portage version: 2.1.3.15)
Diffstat (limited to 'app-emacs/ocaml-mode')
-rw-r--r--app-emacs/ocaml-mode/ChangeLog5
-rw-r--r--app-emacs/ocaml-mode/files/50ocaml-mode-gentoo.el5
2 files changed, 8 insertions, 2 deletions
diff --git a/app-emacs/ocaml-mode/ChangeLog b/app-emacs/ocaml-mode/ChangeLog
index 2a872952e20e..2ce0c57e57c2 100644
--- a/app-emacs/ocaml-mode/ChangeLog
+++ b/app-emacs/ocaml-mode/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emacs/ocaml-mode
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/ocaml-mode/ChangeLog,v 1.17 2007/10/23 11:23:46 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ocaml-mode/ChangeLog,v 1.18 2007/10/23 13:15:49 ulm Exp $
+
+ 23 Oct 2007; Ulrich Mueller <ulm@gentoo.org> files/50ocaml-mode-gentoo.el:
+ Make syntax highlighting work again.
23 Oct 2007; Raúl Porcel <armin76@gentoo.org>
ocaml-mode-3.09.3-r1.ebuild, ocaml-mode-3.10.0.ebuild:
diff --git a/app-emacs/ocaml-mode/files/50ocaml-mode-gentoo.el b/app-emacs/ocaml-mode/files/50ocaml-mode-gentoo.el
index 8a13cd03addb..d1ed867e7eb6 100644
--- a/app-emacs/ocaml-mode/files/50ocaml-mode-gentoo.el
+++ b/app-emacs/ocaml-mode/files/50ocaml-mode-gentoo.el
@@ -5,4 +5,7 @@
(add-to-list 'auto-mode-alist '("\\.ml[iylp]?\\'" . caml-mode))
(autoload 'caml-mode "caml" "Major mode for editing Caml code." t)
(autoload 'run-caml "inf-caml" "Run an inferior Caml process." t)
-;;(require 'caml-font)
+(autoload 'inferior-caml-mode-font-hook "caml-font")
+
+(eval-after-load "caml" '(require 'caml-font))
+(add-hook 'inferior-caml-mode-hooks 'inferior-caml-mode-font-hook)