summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-03-06 07:27:51 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-03-06 07:27:51 +0000
commitfd075ce8bd87b2bb3eeff925ecdc77b01e8a9065 (patch)
tree2cd88f0eb6ad3cfabc6caa315dbf977af14893f0 /app-emacs/rnc-mode/rnc-mode-1.0_beta3.ebuild
parentInclude bbdb-wl.el in the installation; Resolves Bug #102920. (diff)
downloadgentoo-2-fd075ce8bd87b2bb3eeff925ecdc77b01e8a9065.tar.gz
gentoo-2-fd075ce8bd87b2bb3eeff925ecdc77b01e8a9065.tar.bz2
gentoo-2-fd075ce8bd87b2bb3eeff925ecdc77b01e8a9065.zip
Initial port. Ebuild contributed by Gunnar Wrobel <wrobel@gentoo.org> of Bug #104164 fame.
(Portage version: 2.1_pre5-r1)
Diffstat (limited to 'app-emacs/rnc-mode/rnc-mode-1.0_beta3.ebuild')
-rw-r--r--app-emacs/rnc-mode/rnc-mode-1.0_beta3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/rnc-mode/rnc-mode-1.0_beta3.ebuild b/app-emacs/rnc-mode/rnc-mode-1.0_beta3.ebuild
new file mode 100644
index 000000000000..cb1df454f554
--- /dev/null
+++ b/app-emacs/rnc-mode/rnc-mode-1.0_beta3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/rnc-mode/rnc-mode-1.0_beta3.ebuild,v 1.1 2006/03/06 07:27:51 mkennedy Exp $
+
+inherit elisp
+
+MY_PV=${PV/./_}
+MY_PV=${MY_PV/_beta/b}
+
+IUSE=""
+
+DESCRIPTION="An Emacs mode for editing Relax NG compact schema files."
+HOMEPAGE="http://www.pantor.com/"
+SRC_URI="http://www.pantor.com/RncMode-${MY_PV}.tgz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~sparc"
+
+DEPEND="virtual/emacs"
+
+SITEFILE=50rnc-mode-gentoo.el
+
+S=${WORKDIR}
+
+src_compile() {
+ elisp-comp *.el || die
+}
+
+src_install() {
+ elisp-install ${PN} *.{el,elc}
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}