summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2003-07-13 10:03:49 +0000
committerMamoru Komachi <usata@gentoo.org>2003-07-13 10:03:49 +0000
commitf17e37f9780c381e8f29db858d7d787ceabcbf59 (patch)
tree0004fab2d4bd0b9a7e89297f99a875963d7cb647 /app-emacs/semi/semi-1.14.5-r1.ebuild
parentFixed insecure temporary file creation (diff)
downloadgentoo-2-f17e37f9780c381e8f29db858d7d787ceabcbf59.tar.gz
gentoo-2-f17e37f9780c381e8f29db858d7d787ceabcbf59.tar.bz2
gentoo-2-f17e37f9780c381e8f29db858d7d787ceabcbf59.zip
Fixed insecure temporary file creation
Diffstat (limited to 'app-emacs/semi/semi-1.14.5-r1.ebuild')
-rw-r--r--app-emacs/semi/semi-1.14.5-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-emacs/semi/semi-1.14.5-r1.ebuild b/app-emacs/semi/semi-1.14.5-r1.ebuild
new file mode 100644
index 000000000000..8f385136fa2e
--- /dev/null
+++ b/app-emacs/semi/semi-1.14.5-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/semi/semi-1.14.5-r1.ebuild,v 1.1 2003/07/13 10:03:40 usata Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="a library to provide MIME feature for GNU Emacs -- SEMI"
+HOMEPAGE="http://cvs.m17n.org/elisp/SEMI/index.html.ja.iso-2022-jp"
+SRC_URI="ftp://ftp.m17n.org/pub/mule/semi/semi-1.14-for-flim-1.14/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~sparc ~ppc"
+
+DEPEND="virtual/emacs
+ >=app-emacs/apel-10.6
+ >=app-emacs/flim-1.14.5";
+# >=virtual/flim-1.14
+
+PROVIDE="virtual/${P}"
+S="${WORKDIR}/${P}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.diff
+}
+
+src_compile() {
+ make PREFIX=${D}/usr \
+ LISPDIR=${D}/${SITELISP} \
+ VERSION_SPECIFIC_LISPDIR=${D}/${SITELISP} || die
+}
+
+src_install() {
+ make PREFIX=${D}/usr \
+ LISPDIR=${D}/${SITELISP} \
+ VERSION_SPECIFIC_LISPDIR=${D}/${SITELISP} install || die
+
+ elisp-site-file-install ${FILESDIR}/65semi-gentoo.el
+
+ dodoc README* ChangeLog VERSION NEWS
+}
+
+pkg_postinst() {
+ elisp-site-regen
+
+ einfo "Please unmerge another versions or variants, if installed."
+ einfo "You need to rebuild packages depending on ${PN}."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}