summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-01-07 19:22:42 +0000
committerUlrich Müller <ulm@gentoo.org>2010-01-07 19:22:42 +0000
commit9eb38331680da7af266962ab35afb4b204ae5ef2 (patch)
tree2867686697493992be1872a9f67bfa47eb36243a /app-emacs/sokoban/sokoban-1.04_p20030614.ebuild
parentMarking balsa-2.4.1 ppc for bug 278718 (diff)
downloadgentoo-2-9eb38331680da7af266962ab35afb4b204ae5ef2.tar.gz
gentoo-2-9eb38331680da7af266962ab35afb4b204ae5ef2.tar.bz2
gentoo-2-9eb38331680da7af266962ab35afb4b204ae5ef2.zip
Initial import, from Emacs overlay. Ebuild contributed by me.
(Portage version: 2.2_rc61/cvs/Linux i686)
Diffstat (limited to 'app-emacs/sokoban/sokoban-1.04_p20030614.ebuild')
-rw-r--r--app-emacs/sokoban/sokoban-1.04_p20030614.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-emacs/sokoban/sokoban-1.04_p20030614.ebuild b/app-emacs/sokoban/sokoban-1.04_p20030614.ebuild
new file mode 100644
index 000000000000..5c5a68540de8
--- /dev/null
+++ b/app-emacs/sokoban/sokoban-1.04_p20030614.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/sokoban/sokoban-1.04_p20030614.ebuild,v 1.1 2010/01/07 19:22:42 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Implementation of Sokoban for Emacs"
+HOMEPAGE="http://www.xemacs.org/Develop/packages.html"
+# taken from: http://alioth.debian.org/scm/viewvc.php/XEmacs/packages/xemacs-packages/games/?root=xemacs
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp_src_install
+ insinto "${SITEETC}/${PN}"
+ doins sokoban.levels || die
+}