summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
commit08bd106430ca5599005323021f7635b2f1a1f72b (patch)
treed56e46390f1a7838a1a5eecfd8573e5eb47d0c98 /app-emacs/table
parentmasked app-emacs/monk (incomplete for now) (diff)
downloadgentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.gz
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.bz2
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.zip
looks like an app-emacs/ import to me
Diffstat (limited to 'app-emacs/table')
-rw-r--r--app-emacs/table/ChangeLog11
-rw-r--r--app-emacs/table/files/50table-gentoo.el7
-rw-r--r--app-emacs/table/files/digest-table-1.5.531
-rw-r--r--app-emacs/table/table-1.5.53.ebuild43
4 files changed, 62 insertions, 0 deletions
diff --git a/app-emacs/table/ChangeLog b/app-emacs/table/ChangeLog
new file mode 100644
index 000000000000..aa194d4b242f
--- /dev/null
+++ b/app-emacs/table/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/table
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/table/ChangeLog,v 1.1 2002/11/01 02:52:02 mkennedy Exp $
+
+*table-1.5.53 (31 Oct 2002)
+
+ 31 Oct 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ table-1.5.53.ebuild, files/50table-gentoo.el,
+ files/digest-table-1.5.53 :
+
+ Initial import.
diff --git a/app-emacs/table/files/50table-gentoo.el b/app-emacs/table/files/50table-gentoo.el
new file mode 100644
index 000000000000..d434bf9591e7
--- /dev/null
+++ b/app-emacs/table/files/50table-gentoo.el
@@ -0,0 +1,7 @@
+
+;;; table site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
+(require 'table)
+(add-hook 'text-mode-hook 'table-recognize)
+
diff --git a/app-emacs/table/files/digest-table-1.5.53 b/app-emacs/table/files/digest-table-1.5.53
new file mode 100644
index 000000000000..fb73fa7275a6
--- /dev/null
+++ b/app-emacs/table/files/digest-table-1.5.53
@@ -0,0 +1 @@
+MD5 3eb65189f76e27b46505a952cc37b6a0 table-1.5.53.el.gz 57600
diff --git a/app-emacs/table/table-1.5.53.ebuild b/app-emacs/table/table-1.5.53.ebuild
new file mode 100644
index 000000000000..4567dd2530a5
--- /dev/null
+++ b/app-emacs/table/table-1.5.53.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/table/table-1.5.53.ebuild,v 1.1 2002/11/01 02:52:02 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Table editor for Emacs"
+HOMEPAGE="http://table.sourceforge.net/"
+SRC_URI="mirror://sourceforge/table/${P}.el.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs"
+
+S="${WORKDIR}/"
+
+SITEFILE=50table-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} && mv ${P}.el ${PN}.el
+}
+
+src_compile() {
+ emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${SITELISP}/${PN}/table.el for the complete documentation."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}