summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-08-17 22:15:40 +0000
committerUlrich Müller <ulm@gentoo.org>2007-08-17 22:15:40 +0000
commit8c65c59f506c7441e2d9bf196198709ee637d3e0 (patch)
tree95d3317f7d78f46b70cdca3a66c2f9aa2420c5c8 /app-emacs/tramp/tramp-2.1.10.ebuild
parent2.1.2.12 bump. (diff)
downloadgentoo-2-8c65c59f506c7441e2d9bf196198709ee637d3e0.tar.gz
gentoo-2-8c65c59f506c7441e2d9bf196198709ee637d3e0.tar.bz2
gentoo-2-8c65c59f506c7441e2d9bf196198709ee637d3e0.zip
Version bump.
(Portage version: 2.1.3.6)
Diffstat (limited to 'app-emacs/tramp/tramp-2.1.10.ebuild')
-rw-r--r--app-emacs/tramp/tramp-2.1.10.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-emacs/tramp/tramp-2.1.10.ebuild b/app-emacs/tramp/tramp-2.1.10.ebuild
new file mode 100644
index 000000000000..ace951b4f555
--- /dev/null
+++ b/app-emacs/tramp/tramp-2.1.10.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/tramp/tramp-2.1.10.ebuild,v 1.1 2007/08/17 22:15:40 ulm Exp $
+
+inherit elisp eutils
+
+DESCRIPTION="Edit remote files like ange-ftp but with rlogin, telnet and/or ssh"
+HOMEPAGE="http://savannah.gnu.org/projects/tramp/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3 FDL-1.2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+SITEFILE=51${PN}-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}/${P}-fix-texinfo.patch"
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+ elisp-make-autoload-file lisp/${PN}-autoloads.el lisp \
+ || die "elisp-make-autoload-file failed"
+}
+
+src_install() {
+ dodir /usr/share/info
+ dodir /usr/share/emacs/etc
+ dodir /usr/share/emacs/site-lisp/tramp
+
+ einstall lispdir="${D}/usr/share/emacs/site-lisp/tramp" || die
+
+ mv "${D}/usr/share/info/tramp" "${D}/usr/share/info/tramp-info"
+
+ dohtml texi/*.html
+ if [ -f texi/tramp.dvi ]; then
+ insinto /usr/share/doc/${PF}
+ doins texi/tramp.dvi
+ fi
+
+ elisp-install ${PN} lisp/${PN}-autoloads.el
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ dodoc README ChangeLog CONTRIBUTORS || die "dodoc failed"
+}