summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-10-16 08:47:55 +0000
committerUlrich Müller <ulm@gentoo.org>2009-10-16 08:47:55 +0000
commit6cf90561a9f3bb10ace3a676d1632323d1614101 (patch)
tree430cfb76bba20deecbd0b2c49ace82be38dbf5ef /app-emacs/yatex
parentAdded keyword ~amd64. (diff)
downloadgentoo-2-6cf90561a9f3bb10ace3a676d1632323d1614101.tar.gz
gentoo-2-6cf90561a9f3bb10ace3a676d1632323d1614101.tar.bz2
gentoo-2-6cf90561a9f3bb10ace3a676d1632323d1614101.zip
Version bump.
(Portage version: 2.2_rc46/cvs/Linux i686)
Diffstat (limited to 'app-emacs/yatex')
-rw-r--r--app-emacs/yatex/ChangeLog9
-rw-r--r--app-emacs/yatex/yatex-1.74.ebuild53
2 files changed, 60 insertions, 2 deletions
diff --git a/app-emacs/yatex/ChangeLog b/app-emacs/yatex/ChangeLog
index 51c57320508f..acdf2531e147 100644
--- a/app-emacs/yatex/ChangeLog
+++ b/app-emacs/yatex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/yatex
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/yatex/ChangeLog,v 1.22 2008/07/30 14:58:07 ulm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/yatex/ChangeLog,v 1.23 2009/10/16 08:47:55 ulm Exp $
+
+*yatex-1.74 (16 Oct 2009)
+
+ 16 Oct 2009; Ulrich Mueller <ulm@gentoo.org> +yatex-1.74.ebuild:
+ Version bump.
*yatex-1.73 (30 Jul 2008)
diff --git a/app-emacs/yatex/yatex-1.74.ebuild b/app-emacs/yatex/yatex-1.74.ebuild
new file mode 100644
index 000000000000..fd8365c6ea1c
--- /dev/null
+++ b/app-emacs/yatex/yatex-1.74.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/yatex/yatex-1.74.ebuild,v 1.1 2009/10/16 08:47:55 ulm Exp $
+
+inherit elisp eutils
+
+DESCRIPTION="Yet Another TeX mode for Emacs"
+HOMEPAGE="http://www.yatex.org/"
+SRC_URI="http://www.yatex.org/${P/-/}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+LICENSE="as-is"
+IUSE="linguas_ja"
+
+S=${WORKDIR}/${P/-/}
+SITEFILE="50${PN}-gentoo.el"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.73-gentoo.patch"
+}
+
+src_compile() {
+ # byte-compilation fails (as of 1.74): yatexlib.el requires fonts
+ # that are only available under X
+
+ cd docs
+ mv yatexe yatex.info
+ mv yahtmle yahtml.info
+ if use linguas_ja; then
+ iconv -f ISO-2022-JP -t EUC-JP yatexj > yatex-ja.info
+ iconv -f ISO-2022-JP -t EUC-JP yahtmlj > yahtml-ja.info
+ fi
+}
+
+src_install() {
+ elisp-install ${PN} *.el || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+
+ insinto ${SITEETC}/${PN}
+ doins help/YATEXHLP.eng || die "doins failed"
+
+ doinfo docs/*.info || die "doinfo failed"
+ dodoc docs/*.eng || die "dodoc failed"
+
+ if use linguas_ja; then
+ doins help/YATEXHLP.jp || die "doins failed"
+ dodoc 00readme install docs/{htmlqa,qanda} docs/*.doc \
+ || die "dodoc failed"
+ fi
+}