summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-07-04 06:19:06 +0000
committerUlrich Müller <ulm@gentoo.org>2007-07-04 06:19:06 +0000
commit60e890a51ee66db24dc3cf7a5e393476dd404d5b (patch)
tree7b64827823d32a5da891765972c4ec416d3e7fe8 /app-emacs
parentfixed memory leak loading .so bug #182946 (diff)
downloadgentoo-2-60e890a51ee66db24dc3cf7a5e393476dd404d5b.tar.gz
gentoo-2-60e890a51ee66db24dc3cf7a5e393476dd404d5b.tar.bz2
gentoo-2-60e890a51ee66db24dc3cf7a5e393476dd404d5b.zip
Remove redundant functions. Use add-to-list in sitefile.
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/sawfish/ChangeLog6
-rw-r--r--app-emacs/sawfish/files/50sawfish-gentoo.el8
-rw-r--r--app-emacs/sawfish/sawfish-1.32.ebuild23
3 files changed, 16 insertions, 21 deletions
diff --git a/app-emacs/sawfish/ChangeLog b/app-emacs/sawfish/ChangeLog
index 429650157e45..2baf2a12f4e7 100644
--- a/app-emacs/sawfish/ChangeLog
+++ b/app-emacs/sawfish/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emacs/sawfish
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/sawfish/ChangeLog,v 1.8 2007/04/01 10:05:35 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/sawfish/ChangeLog,v 1.9 2007/07/04 06:19:06 ulm Exp $
+
+ 04 Jul 2007; Ulrich Mueller <ulm@gentoo.org> files/50sawfish-gentoo.el,
+ sawfish-1.32.ebuild:
+ Remove redundant functions. Use add-to-list in sitefile.
01 Apr 2007; Michael Hanselmann <hansmi@gentoo.org> sawfish-1.32.ebuild:
Stable on ppc.
diff --git a/app-emacs/sawfish/files/50sawfish-gentoo.el b/app-emacs/sawfish/files/50sawfish-gentoo.el
index 6ab1527407e7..bfcc80dddce6 100644
--- a/app-emacs/sawfish/files/50sawfish-gentoo.el
+++ b/app-emacs/sawfish/files/50sawfish-gentoo.el
@@ -1,10 +1,10 @@
-;;; elscreen site-lisp configuration
+;;; sawfish site-lisp configuration
(add-to-list 'load-path "@SITELISP@")
(autoload 'sawfish-mode "sawfish" "Autoload for sawfish-mode" t)
(autoload 'sawfish-interaction "sawfish" "Autoload for sawfish-interaction" t)
(autoload 'sawfish-console "sawfish" "Autoload for sawfish-console" t)
-(setq auto-mode-alist (cons '("\\.sawfishrc$" . sawfish-mode) auto-mode-alist)
- auto-mode-alist (cons '("\\.jl$" . sawfish-mode) auto-mode-alist)
- auto-mode-alist (cons '("\\.sawfish/rc$" . sawfish-mode) auto-mode-alist))
+(add-to-list 'auto-mode-alist '("\\.sawfishrc$" . sawfish-mode))
+(add-to-list 'auto-mode-alist '("\\.jl$" . sawfish-mode))
+(add-to-list 'auto-mode-alist '("\\.sawfish/rc$" . sawfish-mode))
diff --git a/app-emacs/sawfish/sawfish-1.32.ebuild b/app-emacs/sawfish/sawfish-1.32.ebuild
index 91704df7f1d7..aaea495b9020 100644
--- a/app-emacs/sawfish/sawfish-1.32.ebuild
+++ b/app-emacs/sawfish/sawfish-1.32.ebuild
@@ -1,34 +1,25 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/sawfish/sawfish-1.32.ebuild,v 1.4 2007/04/01 10:05:35 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/sawfish/sawfish-1.32.ebuild,v 1.5 2007/07/04 06:19:06 ulm Exp $
inherit elisp
-DESCRIPTION="Sawfish is an GNU Emacs mode for writing code for the Sawfish window manager with support for a REPL."
+DESCRIPTION="Sawfish is an GNU Emacs mode for writing code for the Sawfish window manager with support for a REPL"
HOMEPAGE="http://www.davep.org/emacs/"
SRC_URI="mirror://gentoo/sawfish-mode-${PV}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ppc x86"
IUSE=""
-DEPEND="virtual/emacs
- x11-wm/sawfish"
+DEPEND="x11-wm/sawfish"
-SITEFILE=50sawfish-gentoo.el
+SITEFILE=50${PN}-gentoo.el
-S=${WORKDIR}/sawfish-mode-${PV}
+S="${WORKDIR}/sawfish-mode-${PV}"
src_unpack() {
unpack ${A}
- mv ${S}/sawfish-mode.el ${S}/sawfish.el
-}
-
-src_compile() {
- elisp-comp *.el || die
-}
-
-src_install() {
- elisp-install ${PN} *.el *.elc
- elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ mv "${S}"/sawfish-mode.el "${S}"/sawfish.el
}