summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2003-03-31 04:50:09 +0000
committerMasatomo Nakano <nakano@gentoo.org>2003-03-31 04:50:09 +0000
commit64cdcff16c941646b7daff6cee9beebb9de6b4a9 (patch)
tree0b6e8dff9656caf47adc236f2fe47ceae5e12d09 /app-emacs
parentFixed SRC_URI (diff)
downloadgentoo-2-64cdcff16c941646b7daff6cee9beebb9de6b4a9.tar.gz
gentoo-2-64cdcff16c941646b7daff6cee9beebb9de6b4a9.tar.bz2
gentoo-2-64cdcff16c941646b7daff6cee9beebb9de6b4a9.zip
Version bump.
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/yc/ChangeLog8
-rw-r--r--app-emacs/yc/files/digest-yc-3.5.21
-rw-r--r--app-emacs/yc/yc-3.5.2.ebuild50
3 files changed, 58 insertions, 1 deletions
diff --git a/app-emacs/yc/ChangeLog b/app-emacs/yc/ChangeLog
index 80ae4c72f829..33d3bff773db 100644
--- a/app-emacs/yc/ChangeLog
+++ b/app-emacs/yc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/yc
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/yc/ChangeLog,v 1.4 2003/03/27 13:57:50 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/yc/ChangeLog,v 1.5 2003/03/31 04:50:09 nakano Exp $
+
+*yc-3.5.2 (31 Mar 2003)
+
+ 31 Mar 2003; Masatomo Nakano <nakano@gentoo.org> ChangeLog, yc-3.5.2.ebuild:
+
+ Version bump.
*yc-3.5.1 (27 Mar 2003)
diff --git a/app-emacs/yc/files/digest-yc-3.5.2 b/app-emacs/yc/files/digest-yc-3.5.2
new file mode 100644
index 000000000000..199c11061762
--- /dev/null
+++ b/app-emacs/yc/files/digest-yc-3.5.2
@@ -0,0 +1 @@
+MD5 7c8fd5d4c4d19f727bada3bd640daddf yc.el-3.5.2.gz 32379
diff --git a/app-emacs/yc/yc-3.5.2.ebuild b/app-emacs/yc/yc-3.5.2.ebuild
new file mode 100644
index 000000000000..1a6005a5b5b2
--- /dev/null
+++ b/app-emacs/yc/yc-3.5.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/yc/yc-3.5.2.ebuild,v 1.1 2003/03/31 04:50:09 nakano Exp $
+
+inherit elisp
+
+IUSE=""
+
+MY_P=yc.el-${PV}
+DESCRIPTION="YC - Yet another Canna client on Emacsen."
+HOMEPAGE="http://www.ceres.dti.ne.jp/~knak/yc.html"
+SRC_URI="http://www.ceres.dti.ne.jp/~knak/${MY_P}.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs
+ >=app-i18n/canna-3.5_beta2"
+
+S="${WORKDIR}/${P}"
+SITEFILE="50yc-gentoo.el"
+
+src_unpack() {
+ mkdir -p ${S}
+ gzip -dc ${DISTDIR}/${MY_P}.gz > ${S}/yc.el
+}
+
+src_compile() {
+ emacs -batch -eval '(byte-compile-file "yc.el")'
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+
+ dodoc ${FILESDIR}/sample*
+}
+
+pkg_postinst() {
+ einfo "Please modify as following in /etc/conf.d/canna."
+ einfo "\n\t CANNASERVER_OPTS=\"-inet\"\n"
+ einfo "And create /etc/hosts.canna."
+ einfo "(sample is /usr/share/doc/${P}/sample.hosts.canna.gz)"
+ einfo "And see /usr/share/doc/${P}/sample.dot.emacs.gz."
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}