summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-12-12 23:47:02 +0000
committerUlrich Müller <ulm@gentoo.org>2014-12-12 23:47:02 +0000
commite3a45bfe663e2f2dff635a3fcea9de9b70dcf5b3 (patch)
treeddd0c17d7b34326580c68c493032645a8d6bcee5 /app-emacs
parentRename net-zope/zope-interface to dev-python/zope-interface. (diff)
downloadgentoo-2-e3a45bfe663e2f2dff635a3fcea9de9b70dcf5b3.tar.gz
gentoo-2-e3a45bfe663e2f2dff635a3fcea9de9b70dcf5b3.tar.bz2
gentoo-2-e3a45bfe663e2f2dff635a3fcea9de9b70dcf5b3.zip
Fix runtime problem with Emacs 24.4, bug 532358.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/css-mode/ChangeLog8
-rw-r--r--app-emacs/css-mode/css-mode-0.11-r1.ebuild29
-rw-r--r--app-emacs/css-mode/files/css-mode-0.11-no-compat-kbd.patch24
3 files changed, 60 insertions, 1 deletions
diff --git a/app-emacs/css-mode/ChangeLog b/app-emacs/css-mode/ChangeLog
index 0de24afbd0b5..f7c72cf80cdf 100644
--- a/app-emacs/css-mode/ChangeLog
+++ b/app-emacs/css-mode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/css-mode
# Copyright 2000-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/css-mode/ChangeLog,v 1.11 2014/02/21 00:10:55 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/css-mode/ChangeLog,v 1.12 2014/12/12 23:47:02 ulm Exp $
+
+*css-mode-0.11-r1 (12 Dec 2014)
+
+ 12 Dec 2014; Ulrich Müller <ulm@gentoo.org> +css-mode-0.11-r1.ebuild,
+ +files/css-mode-0.11-no-compat-kbd.patch:
+ Fix runtime problem with Emacs 24.4, bug 532358.
21 Feb 2014; Ulrich Müller <ulm@gentoo.org> css-mode-0.11.ebuild:
Update ebuild to EAPI 5. Specify LICENSE more precisely.
diff --git a/app-emacs/css-mode/css-mode-0.11-r1.ebuild b/app-emacs/css-mode/css-mode-0.11-r1.ebuild
new file mode 100644
index 000000000000..e852c4f04426
--- /dev/null
+++ b/app-emacs/css-mode/css-mode-0.11-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/css-mode/css-mode-0.11-r1.ebuild,v 1.1 2014/12/12 23:47:02 ulm Exp $
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="A major mode for editing Cascading Style Sheets (CSS)"
+HOMEPAGE="http://www.garshol.priv.no/download/software/css-mode/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+
+ELISP_PATCHES="${P}-no-compat-kbd.patch"
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+ # Fix documentation
+ sed -i -e 's,HREF="/visuals/standard.css",HREF="standard.css",' doco.html
+}
+
+src_install() {
+ elisp_src_install
+ dohtml -A css doco.html standard.css
+}
diff --git a/app-emacs/css-mode/files/css-mode-0.11-no-compat-kbd.patch b/app-emacs/css-mode/files/css-mode-0.11-no-compat-kbd.patch
new file mode 100644
index 000000000000..858cb238bf3c
--- /dev/null
+++ b/app-emacs/css-mode/files/css-mode-0.11-no-compat-kbd.patch
@@ -0,0 +1,24 @@
+Function "apropos-macrop" apparently no longer exists in Emacs 24.4.
+Simply remove the code using it, since it was only needed for backwards
+compatibility with Emacs 19 (the "kbd" macro appeared in Emacs 20.1).
+https://bugs.gentoo.org/532358
+
+--- css-mode-0.11-orig/css-mode.el
++++ css-mode-0.11/css-mode.el
+@@ -166,16 +166,6 @@
+ (define-key cssm-mode-map (read-kbd-macro "}") 'cssm-insert-right-brace-and-indent)
+ (define-key cssm-mode-map (read-kbd-macro "M-TAB") 'cssm-complete-property))
+
+-;;; Cross-version compatibility layer
+-
+-(when (not (or (apropos-macrop 'kbd)
+- (fboundp 'kbd)))
+- (defmacro kbd (keys)
+- "Convert KEYS to the internal Emacs key representation.
+-KEYS should be a string constant in the format used for
+-saving keyboard macros (see `insert-kbd-macro')."
+- (read-kbd-macro keys)))
+-
+ ;;; Auto-indentation support
+
+ ; internal