summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-11-09 18:33:47 +0000
committerMamoru Komachi <usata@gentoo.org>2004-11-09 18:33:47 +0000
commite532fcc6ab93d4138a988a15842b6cb72397259d (patch)
treecdf55b2475aa8548b0f52a1243fc5ff62c10fbf8 /app-emacs
parentfirst version in portage. (Manifest recommit) (diff)
downloadgentoo-2-e532fcc6ab93d4138a988a15842b6cb72397259d.tar.gz
gentoo-2-e532fcc6ab93d4138a988a15842b6cb72397259d.tar.bz2
gentoo-2-e532fcc6ab93d4138a988a15842b6cb72397259d.zip
Initial import. Ebuild submitted by Nick Savchenko <rust@voliacable.com>; bug #69323.
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/pymacs/ChangeLog11
-rw-r--r--app-emacs/pymacs/Manifest3
-rw-r--r--app-emacs/pymacs/files/50pymacs-gentoo.el6
-rw-r--r--app-emacs/pymacs/files/digest-pymacs-0.221
-rw-r--r--app-emacs/pymacs/metadata.xml6
-rw-r--r--app-emacs/pymacs/pymacs-0.22.ebuild35
6 files changed, 62 insertions, 0 deletions
diff --git a/app-emacs/pymacs/ChangeLog b/app-emacs/pymacs/ChangeLog
new file mode 100644
index 000000000000..e7a90d2d5eb1
--- /dev/null
+++ b/app-emacs/pymacs/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/pymacs
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/pymacs/ChangeLog,v 1.1 2004/11/09 18:33:47 usata Exp $
+
+*pymacs-0.22 (10 Nov 2004)
+
+ 10 Nov 2004; Mamoru KOMACHI <usata@gentoo.org> +metadata.xml,
+ +files/50pymacs-gentoo.el, +pymacs-0.22.ebuild:
+ Initial import. Ebuild submitted by Nick Savchenko <rust@voliacable.com>;
+ bug #69323.
+
diff --git a/app-emacs/pymacs/Manifest b/app-emacs/pymacs/Manifest
new file mode 100644
index 000000000000..8fbfb73d0e1d
--- /dev/null
+++ b/app-emacs/pymacs/Manifest
@@ -0,0 +1,3 @@
+MD5 87397471d67e3dd37bfe4008fdb7fe6c pymacs-0.22.ebuild 804
+MD5 f7d73dd21b3da6c8dc519bcb4cbea18c files/digest-pymacs-0.22 63
+MD5 bda0b79a6ef909ba726d0f9a9a7e84c0 files/50pymacs-gentoo.el 191
diff --git a/app-emacs/pymacs/files/50pymacs-gentoo.el b/app-emacs/pymacs/files/50pymacs-gentoo.el
new file mode 100644
index 000000000000..155458b52ee4
--- /dev/null
+++ b/app-emacs/pymacs/files/50pymacs-gentoo.el
@@ -0,0 +1,6 @@
+
+;;; emacs site-lisp configuration for pymacs
+(autoload 'pymacs-load "pymacs" nil t)
+(autoload 'pymacs-eval "pymacs" nil t)
+(autoload 'pymacs-apply "pymacs")
+(autoload 'pymacs-call "pymacs")
diff --git a/app-emacs/pymacs/files/digest-pymacs-0.22 b/app-emacs/pymacs/files/digest-pymacs-0.22
new file mode 100644
index 000000000000..28e0f2c4465f
--- /dev/null
+++ b/app-emacs/pymacs/files/digest-pymacs-0.22
@@ -0,0 +1 @@
+MD5 73b7a641be100fd90a9be59ecf01fd98 Pymacs-0.22.tar.gz 363119
diff --git a/app-emacs/pymacs/metadata.xml b/app-emacs/pymacs/metadata.xml
new file mode 100644
index 000000000000..f65b0d259bdb
--- /dev/null
+++ b/app-emacs/pymacs/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<herd>python</herd>
+</pkgmetadata>
diff --git a/app-emacs/pymacs/pymacs-0.22.ebuild b/app-emacs/pymacs/pymacs-0.22.ebuild
new file mode 100644
index 000000000000..ac05cdc6352e
--- /dev/null
+++ b/app-emacs/pymacs/pymacs-0.22.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/pymacs/pymacs-0.22.ebuild,v 1.1 2004/11/09 18:33:47 usata Exp $
+
+inherit distutils elisp
+
+DESCRIPTION="Pymacs is a tool that allows both-side communication beetween Python and Emacs-lisp"
+HOMEPAGE="http://pymacs.progiciels-bpi.ca"
+SRC_URI="http://pymacs.progiciels-bpi.ca/archives/${P/pymacs/Pymacs}.tar.gz"
+
+DEPEND="virtual/emacs
+ virtual/python"
+LICENSE="as-is"
+IUSE="doc"
+SLOT="0"
+KEYWORDS="~x86"
+
+S=${WORKDIR}/Pymacs-${PV}
+
+src_compile() {
+ distutils_src_compile
+ elisp-compile pymacs.el
+}
+
+src_install() {
+ elisp-install ${PN} pymacs.el pymacs.elc
+ elisp-site-file-install ${FILESDIR}/50pymacs-gentoo.el
+ distutils_src_install
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ doins ./pymacs.pdf
+ fi
+ cd ${S}
+ dodoc PKG-INFO MANIFEST README THANKS TODO THANKS-rebox ChangeLog ChangeLog-rebox
+}