summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-09-01 15:00:03 +0000
committerMichael Weber <xmw@gentoo.org>2010-09-01 15:00:03 +0000
commit375b81a8e2a8190f5e1ab103940c09919d5362de (patch)
treefe486988893b1c5dd4247208fa0e0945278c5e9b /app-emulation/aranym/aranym-0.9.10.ebuild
parentdigest fix (diff)
downloadgentoo-2-375b81a8e2a8190f5e1ab103940c09919d5362de.tar.gz
gentoo-2-375b81a8e2a8190f5e1ab103940c09919d5362de.tar.bz2
gentoo-2-375b81a8e2a8190f5e1ab103940c09919d5362de.zip
Version bump, fix bug 332437 and bug 294859
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/aranym/aranym-0.9.10.ebuild')
-rw-r--r--app-emulation/aranym/aranym-0.9.10.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-emulation/aranym/aranym-0.9.10.ebuild b/app-emulation/aranym/aranym-0.9.10.ebuild
new file mode 100644
index 000000000000..21e91feba570
--- /dev/null
+++ b/app-emulation/aranym/aranym-0.9.10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/aranym-0.9.10.ebuild,v 1.1 2010/09/01 15:00:03 xmw Exp $
+
+EAPI=2
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Atari Running on Any Machine, a VM running Atari ST/TT/Falcon OS and TOS/GEM applications"
+HOMEPAGE="http://aranym.sourceforge.net/"
+SRC_URI="mirror://sourceforge/aranym/${P}.tar.gz
+ mirror://sourceforge/aranym/afros812.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="opengl"
+
+RDEPEND="media-libs/libsdl
+ games-emulation/emutos
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_configure() {
+ filter-flags -mpowerpc-gfxopt
+
+ local myconf=""
+ if [[ ${ARCH} == x86 ]]; then
+ myconf="${myconf} --enable-jit-compiler"
+ fi
+
+ econf $(use_enable opengl) ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_PROGRAM="install" install || die "installation failed"
+
+ insinto /usr/share/${PN}
+ doins -r "${WORKDIR}"/afros || die
+
+ dodoc "${D}"/usr/share/doc/${PN}/* || die
+ rm -r "${D}"/usr/share/doc/${PN} || die
+}
+
+pkg_postinst() {
+ elog "To run ARAnyM with AFROS type: aranym --config /usr/share/aranym/afros/config"
+}