summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerbie Hopkins <herbs@gentoo.org>2005-04-18 09:58:47 +0000
committerHerbie Hopkins <herbs@gentoo.org>2005-04-18 09:58:47 +0000
commitbe09fa13b518843e7c6db5647f9bea3c51dc150e (patch)
treec1fc73ca4a1e4554d3f20ac728b63d7bb51bb785 /app-emulation/emul-linux-x86-xlibs/emul-linux-x86-xlibs-2.1.ebuild
parentNew version - 2.1 (diff)
downloadgentoo-2-be09fa13b518843e7c6db5647f9bea3c51dc150e.tar.gz
gentoo-2-be09fa13b518843e7c6db5647f9bea3c51dc150e.tar.bz2
gentoo-2-be09fa13b518843e7c6db5647f9bea3c51dc150e.zip
New version - 2.1
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-emulation/emul-linux-x86-xlibs/emul-linux-x86-xlibs-2.1.ebuild')
-rw-r--r--app-emulation/emul-linux-x86-xlibs/emul-linux-x86-xlibs-2.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-emulation/emul-linux-x86-xlibs/emul-linux-x86-xlibs-2.1.ebuild b/app-emulation/emul-linux-x86-xlibs/emul-linux-x86-xlibs-2.1.ebuild
new file mode 100644
index 000000000000..2836c87e484c
--- /dev/null
+++ b/app-emulation/emul-linux-x86-xlibs/emul-linux-x86-xlibs-2.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-xlibs/emul-linux-x86-xlibs-2.1.ebuild,v 1.1 2005/04/18 09:58:47 herbs Exp $
+
+inherit multilib
+
+DESCRIPTION="X11R6 libraries for emulation of 32bit x86 on amd64"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/emul-linux-x86-xlibs-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="opengl"
+
+DEPEND="opengl? ( >=x11-base/opengl-update-2.1.1 )"
+
+RDEPEND="${DEPEND}
+ virtual/libc
+ >=x11-base/xorg-x11-6.8.0-r4
+ >=app-emulation/emul-linux-x86-baselibs-2.0"
+
+S=${WORKDIR}
+
+pkg_preinst() {
+ # Check for bad symlink before installing, bug 84441.
+ if [ -L /emul/linux/x86/usr/lib/X11 ]; then
+ rm -f /emul/linux/x86/usr/lib/X11
+ fi
+}
+
+src_install() {
+ cp -RPvf ${WORKDIR}/* ${D}/
+
+ local libdir="lib32"
+ if has_multilib_profile; then
+ libdir=$(get_abi_LIBDIR x86)
+ fi
+
+ dodir /usr/${libdir}/opengl
+ dosym /emul/linux/x86/usr/lib/opengl/xorg-x11 /usr/${libdir}/opengl/xorg-x11
+}
+
+pkg_postinst() {
+ #update GL symlinks
+ if use opengl && [[ ${ROOT} == "/" ]] ; then
+ /usr/sbin/opengl-update --use-old
+ fi
+}
+