summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2010-03-11 17:18:18 +0000
committerLance Albertson <ramereth@gentoo.org>2010-03-11 17:18:18 +0000
commitbc4900b2c42b9acdb50dc362921e4d7e37a3c517 (patch)
treed8b4fb861afa946e6df2164ae7fac32576498e02 /app-emulation/ganeti
parentInitial ebuild for ganeti-htools (diff)
downloadgentoo-2-bc4900b2c42b9acdb50dc362921e4d7e37a3c517.tar.gz
gentoo-2-bc4900b2c42b9acdb50dc362921e4d7e37a3c517.tar.bz2
gentoo-2-bc4900b2c42b9acdb50dc362921e4d7e37a3c517.zip
Ebuild cleanup
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/ganeti')
-rw-r--r--app-emulation/ganeti/ChangeLog6
-rw-r--r--app-emulation/ganeti/ganeti-1.2.1.ebuild54
-rw-r--r--app-emulation/ganeti/ganeti-2.0.5.ebuild66
-rw-r--r--app-emulation/ganeti/ganeti-2.1.0_rc3.ebuild73
-rw-r--r--app-emulation/ganeti/ganeti-2.1.0_rc4.ebuild74
5 files changed, 5 insertions, 268 deletions
diff --git a/app-emulation/ganeti/ChangeLog b/app-emulation/ganeti/ChangeLog
index 73a97b168739..402355d9631a 100644
--- a/app-emulation/ganeti/ChangeLog
+++ b/app-emulation/ganeti/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/ganeti
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ChangeLog,v 1.18 2010/03/07 20:56:03 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ChangeLog,v 1.19 2010/03/11 17:18:18 ramereth Exp $
+
+ 11 Mar 2010; Lance Albertson <ramereth@gentoo.org> -ganeti-1.2.1.ebuild,
+ -ganeti-2.0.5.ebuild, -ganeti-2.1.0_rc3.ebuild, -ganeti-2.1.0_rc4.ebuild:
+ Ebuild cleanup
*ganeti-2.1.0 (07 Mar 2010)
diff --git a/app-emulation/ganeti/ganeti-1.2.1.ebuild b/app-emulation/ganeti/ganeti-1.2.1.ebuild
deleted file mode 100644
index a0da610246c6..000000000000
--- a/app-emulation/ganeti/ganeti-1.2.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-1.2.1.ebuild,v 1.2 2009/01/03 18:06:11 angelos Exp $
-
-NEED_PYTHON=2.4
-
-inherit python autotools eutils
-
-MY_P=${P/_beta/b}
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="Ganeti is a virtual server management software tool built upon Xen"
-HOMEPAGE="http://code.google.com/p/ganeti/"
-SRC_URI="http://ganeti.googlecode.com/files/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-
-RDEPEND=">=app-emulation/xen-3.0
- dev-libs/openssl
- dev-python/pyopenssl
- dev-python/pyparsing
- dev-python/simplejson
- dev-python/twisted
- net-analyzer/arping
- net-misc/bridge-utils
- net-misc/openssh
- sys-apps/iproute2
- sys-cluster/drbd
- sys-fs/lvm2
- sys-fs/mdadm"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- eautoreconf
-}
-
-src_compile() {
- econf --localstatedir=/var --with-ssh-initscript=/etc/init.d/sshd
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- newinitd "${FILESDIR}/ganeti.initd" ganeti
-
- keepdir /var/{lib,log,run}/ganeti/
- keepdir /srv/ganeti/{os,export}/
-}
diff --git a/app-emulation/ganeti/ganeti-2.0.5.ebuild b/app-emulation/ganeti/ganeti-2.0.5.ebuild
deleted file mode 100644
index 5af58b8d46dd..000000000000
--- a/app-emulation/ganeti/ganeti-2.0.5.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-2.0.5.ebuild,v 1.1 2009/12/17 17:05:20 ramereth Exp $
-
-EAPI=2
-
-inherit eutils confutils bash-completion
-
-DESCRIPTION="Ganeti is a virtual server management software tool"
-HOMEPAGE="http://code.google.com/p/ganeti/"
-SRC_URI="http://ganeti.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="kvm xen drbd"
-
-DEPEND="xen? ( >=app-emulation/xen-3.0 )
- kvm? ( app-emulation/qemu-kvm )
- drbd? ( >=sys-cluster/drbd-8.0 )
- dev-libs/openssl
- dev-python/pyopenssl
- dev-python/pyparsing
- dev-python/simplejson
- net-analyzer/arping
- net-misc/bridge-utils
- net-misc/openssh
- net-misc/socat
- sys-apps/iproute2
- sys-fs/lvm2"
-RDEPEND="${DEPEND}"
-
-src_prepare () {
- epatch "${FILESDIR}/${PN}-2.0.3-gentoo-brctl-path.patch"
-}
-
-pkg_setup () {
- confutils_require_any kvm xen
-}
-
-src_configure () {
- econf --localstatedir=/var \
- --docdir=/usr/share/doc/${P} \
- --with-ssh-initscript=/etc/init.d/sshd \
- --with-export-dir=/var/lib/ganeti-storage/export \
- --with-os-search-path=/usr/share/ganeti/os \
- --with-file-storage-dir=/var/lib/ganeti-storage/file
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
- newinitd "${FILESDIR}"/ganeti2.initd ganeti
- dobashcompletion doc/examples/bash_completion ganeti
- dodoc DEVNOTES INSTALL NEWS README doc/*.rst doc/*.txt
- rm -rf "${D}"/usr/share/doc/ganeti
- docinto examples
- dodoc doc/examples/dumb-allocator doc/examples/ganeti.cron
-
- keepdir /var/{lib,log,run}/ganeti/
- keepdir /usr/share/ganeti/os/
- keepdir /var/lib/ganeti-storage/{export,file}/
-}
-
-pkg_postinst () {
- bash-completion_pkg_postinst
-}
diff --git a/app-emulation/ganeti/ganeti-2.1.0_rc3.ebuild b/app-emulation/ganeti/ganeti-2.1.0_rc3.ebuild
deleted file mode 100644
index 8374e0275a31..000000000000
--- a/app-emulation/ganeti/ganeti-2.1.0_rc3.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-2.1.0_rc3.ebuild,v 1.1 2010/01/15 17:50:51 ramereth Exp $
-
-EAPI=2
-
-inherit eutils confutils bash-completion
-
-MY_PV="${PV/_rc/~rc}"
-MY_P="${PN}-${MY_PV}"
-DESCRIPTION="Ganeti is a virtual server management software tool"
-HOMEPAGE="http://code.google.com/p/ganeti/"
-SRC_URI="http://ganeti.googlecode.com/files/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="kvm xen drbd"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND="xen? ( >=app-emulation/xen-3.0 )
- kvm? ( app-emulation/qemu-kvm )
- drbd? ( >=sys-cluster/drbd-8.0 )
- dev-libs/openssl
- dev-python/pyopenssl
- dev-python/pyparsing
- dev-python/pyinotify
- dev-python/simplejson
- net-analyzer/arping
- net-misc/bridge-utils
- net-misc/openssh
- net-misc/socat
- sys-apps/iproute2
- sys-fs/lvm2"
-RDEPEND="${DEPEND}"
-
-src_prepare () {
- epatch "${FILESDIR}/${PN}-2.1.0_rc1-fix-brctl-path-for-gentoo.patch"
-}
-
-pkg_setup () {
- confutils_require_any kvm xen
-}
-
-src_configure () {
- econf --localstatedir=/var \
- --docdir=/usr/share/doc/${P} \
- --with-ssh-initscript=/etc/init.d/sshd \
- --with-export-dir=/var/lib/ganeti-storage/export \
- --with-os-search-path=/usr/share/ganeti/os \
- --with-file-storage-dir=/var/lib/ganeti-storage/file
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
- newinitd "${FILESDIR}"/ganeti-2.1.initd ganeti
- dobashcompletion doc/examples/bash_completion ganeti
- dodoc INSTALL NEWS README doc/*.{rst,png}
- rm -rf "${D}"/usr/share/doc/ganeti
- docinto examples
- dodoc doc/examples/{dumb-allocator,ganeti.cron,gnt-config-backup}
- docinto examples/hooks
- dodoc doc/examples/hooks/{ipsec,ethers}
-
- keepdir /var/{lib,log,run}/ganeti/
- keepdir /usr/share/ganeti/os/
- keepdir /var/lib/ganeti-storage/{export,file}/
-}
-
-pkg_postinst () {
- bash-completion_pkg_postinst
-}
diff --git a/app-emulation/ganeti/ganeti-2.1.0_rc4.ebuild b/app-emulation/ganeti/ganeti-2.1.0_rc4.ebuild
deleted file mode 100644
index 1c42c50b2d6e..000000000000
--- a/app-emulation/ganeti/ganeti-2.1.0_rc4.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-2.1.0_rc4.ebuild,v 1.2 2010/02/08 22:38:59 ramereth Exp $
-
-EAPI=2
-
-inherit eutils confutils bash-completion
-
-MY_PV="${PV/_rc/~rc}"
-MY_P="${PN}-${MY_PV}"
-DESCRIPTION="Ganeti is a virtual server management software tool"
-HOMEPAGE="http://code.google.com/p/ganeti/"
-SRC_URI="http://ganeti.googlecode.com/files/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="kvm xen drbd"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND="xen? ( >=app-emulation/xen-3.0 )
- kvm? ( app-emulation/qemu-kvm )
- drbd? ( >=sys-cluster/drbd-8.0 )
- dev-libs/openssl
- dev-python/pyopenssl
- dev-python/pyparsing
- dev-python/pyinotify
- dev-python/simplejson
- net-analyzer/arping
- net-misc/bridge-utils
- net-misc/openssh
- net-misc/socat
- sys-apps/iproute2
- sys-fs/lvm2"
-RDEPEND="${DEPEND}"
-
-src_prepare () {
- epatch "${FILESDIR}/${PN}-2.1.0_rc1-fix-brctl-path-for-gentoo.patch"
-}
-
-pkg_setup () {
- confutils_require_any kvm xen
-}
-
-src_configure () {
- econf --localstatedir=/var \
- --docdir=/usr/share/doc/${P} \
- --with-ssh-initscript=/etc/init.d/sshd \
- --with-export-dir=/var/lib/ganeti-storage/export \
- --with-os-search-path=/usr/share/ganeti/os \
- --with-file-storage-dir=/var/lib/ganeti-storage/file
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
- newinitd "${FILESDIR}"/ganeti-2.1.initd ganeti
- newconfd "${FILESDIR}"/ganeti.confd ganeti
- dobashcompletion doc/examples/bash_completion ganeti
- dodoc INSTALL NEWS README doc/*.{rst,png}
- rm -rf "${D}"/usr/share/doc/ganeti
- docinto examples
- dodoc doc/examples/{dumb-allocator,ganeti.cron,gnt-config-backup}
- docinto examples/hooks
- dodoc doc/examples/hooks/{ipsec,ethers}
-
- keepdir /var/{lib,log,run}/ganeti/
- keepdir /usr/share/ganeti/os/
- keepdir /var/lib/ganeti-storage/{export,file}/
-}
-
-pkg_postinst () {
- bash-completion_pkg_postinst
-}