summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-08-14 00:51:28 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-08-14 00:51:28 +0000
commitecce0f533165d0c6512e2c74a6f9f503afe0a25d (patch)
tree9a6edd2fa3d0987f99abfa70bbf914c2b7eeba28 /app-emulation/libdsk/libdsk-1.1.5.ebuild
parentBug #102433, checking digest (diff)
downloadgentoo-2-ecce0f533165d0c6512e2c74a6f9f503afe0a25d.tar.gz
gentoo-2-ecce0f533165d0c6512e2c74a6f9f503afe0a25d.tar.bz2
gentoo-2-ecce0f533165d0c6512e2c74a6f9f503afe0a25d.zip
version bump
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-emulation/libdsk/libdsk-1.1.5.ebuild')
-rw-r--r--app-emulation/libdsk/libdsk-1.1.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-emulation/libdsk/libdsk-1.1.5.ebuild b/app-emulation/libdsk/libdsk-1.1.5.ebuild
new file mode 100644
index 000000000000..8928a918f36d
--- /dev/null
+++ b/app-emulation/libdsk/libdsk-1.1.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libdsk/libdsk-1.1.5.ebuild,v 1.1 2005/08/14 00:51:28 dragonheart Exp $
+
+DESCRIPTION="Disk emulation library"
+HOMEPAGE="http://www.seasip.demon.co.uk/Unix/LibDsk/"
+SRC_URI="http://www.seasip.demon.co.uk/Unix/LibDsk/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="java"
+KEYWORDS="~x86 ~ppc ~amd64"
+
+DEPEND="sys-libs/zlib
+ app-arch/bzip2
+ java? ( >=virtual/jdk-1.4 )"
+
+src_compile() {
+ econf \
+ --with-zlib \
+ --with-bzlib \
+ --enable-floppy \
+ $(use_with java jni) \
+ --with-java-prefix=${JAVA_HOME} \
+ || die
+ emake || die "libdsk make failed!"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+ dodoc ChangeLog README TODO doc/libdsk.*
+}