summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2012-08-13 01:13:38 +0000
committerDoug Goldstein <cardoe@gentoo.org>2012-08-13 01:13:38 +0000
commit575f0cf0db81598673fdd6f863f7001de50b62aa (patch)
tree12a93f1263fd81fa5c33e9d1bf5d7bf759f16adf /app-emulation/libvirt
parentUpdate LICENSE field to match all the files included. (diff)
downloadgentoo-2-575f0cf0db81598673fdd6f863f7001de50b62aa.tar.gz
gentoo-2-575f0cf0db81598673fdd6f863f7001de50b62aa.tar.bz2
gentoo-2-575f0cf0db81598673fdd6f863f7001de50b62aa.zip
Work around for people that used the masked ebuild and didn't get the qemu user added to the kvm group correctly. bug #430808
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/libvirt')
-rw-r--r--app-emulation/libvirt/ChangeLog6
-rw-r--r--app-emulation/libvirt/libvirt-0.9.13.ebuild10
2 files changed, 14 insertions, 2 deletions
diff --git a/app-emulation/libvirt/ChangeLog b/app-emulation/libvirt/ChangeLog
index 9d364106d18d..bbe5ad1c4672 100644
--- a/app-emulation/libvirt/ChangeLog
+++ b/app-emulation/libvirt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/libvirt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.201 2012/07/19 09:00:51 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.202 2012/08/13 01:13:38 cardoe Exp $
+
+ 13 Aug 2012; Doug Goldstein <cardoe@gentoo.org> libvirt-0.9.13.ebuild:
+ Work around for people that used the masked ebuild and didn't get the qemu
+ user added to the kvm group correctly. bug #430808
19 Jul 2012; Justin Lecher <jlec@gentoo.org>
+files/libvirt-0.9.13-libnl3.patch, libvirt-0.9.13.ebuild:
diff --git a/app-emulation/libvirt/libvirt-0.9.13.ebuild b/app-emulation/libvirt/libvirt-0.9.13.ebuild
index 552239f80a79..dd5ed2ca3113 100644
--- a/app-emulation/libvirt/libvirt-0.9.13.ebuild
+++ b/app-emulation/libvirt/libvirt-0.9.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-0.9.13.ebuild,v 1.5 2012/07/19 09:00:51 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-0.9.13.ebuild,v 1.6 2012/08/13 01:13:38 cardoe Exp $
EAPI=4
@@ -146,6 +146,14 @@ pkg_setup() {
enewgroup qemu 77
enewuser qemu 77 -1 -1 qemu kvm
+ # Some people used the masked ebuild which was not adding the qemu
+ # user to the kvm group originally. This results in VMs failing to
+ # start for some users. bug #430808
+ egetent group kvm | grep -q qemu
+ if [[ $? -ne 0 ]]; then
+ gpasswd -a qemu kvm
+ fi
+
CONFIG_CHECK=""
use lxc && CONFIG_CHECK+="${LXC_CONFIG_CHECK}"
use macvtap && CONFIG_CHECK+="${MACVTAP}"