summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-10-24 10:49:25 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-10-24 10:49:25 +0000
commit1a881c3686c0eacfb16a8052f61682b61cd679ce (patch)
treedcc3359a8ac16eda2c68f157cabd3cb4e3addf4c /app-emulation/lxc
parentcorrect manifest for removed ebuilds (diff)
downloadgentoo-2-1a881c3686c0eacfb16a8052f61682b61cd679ce.tar.gz
gentoo-2-1a881c3686c0eacfb16a8052f61682b61cd679ce.tar.bz2
gentoo-2-1a881c3686c0eacfb16a8052f61682b61cd679ce.zip
Initial import of lxc; based upon dev-zero's ebuild, modified by me. It diverges a bit from upstream, in the path used, to stay more Gentoo-styled. Init scripts will likely be added separately.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/lxc')
-rw-r--r--app-emulation/lxc/ChangeLog12
-rw-r--r--app-emulation/lxc/files/0.6.2-as-needed.patch19
-rw-r--r--app-emulation/lxc/lxc-0.6.3.ebuild57
-rw-r--r--app-emulation/lxc/metadata.xml11
4 files changed, 99 insertions, 0 deletions
diff --git a/app-emulation/lxc/ChangeLog b/app-emulation/lxc/ChangeLog
new file mode 100644
index 000000000000..1bd3f269e5af
--- /dev/null
+++ b/app-emulation/lxc/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for app-emulation/lxc
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/ChangeLog,v 1.1 2009/10/24 10:49:24 flameeyes Exp $
+
+*lxc-0.6.3 (24 Oct 2009)
+
+ 24 Oct 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ +files/0.6.2-as-needed.patch, +lxc-0.6.3.ebuild, +metadata.xml:
+ Initial import of lxc; based upon dev-zero's ebuild, modified by me. It
+ diverges a bit from upstream, in the path used, to stay more
+ Gentoo-styled. Init scripts will likely be added separately.
+
diff --git a/app-emulation/lxc/files/0.6.2-as-needed.patch b/app-emulation/lxc/files/0.6.2-as-needed.patch
new file mode 100644
index 000000000000..45e6c4cfa7c9
--- /dev/null
+++ b/app-emulation/lxc/files/0.6.2-as-needed.patch
@@ -0,0 +1,19 @@
+diff -Naur lxc-0.6.2.orig/src/lxc/Makefile.am lxc-0.6.2/src/lxc/Makefile.am
+--- lxc-0.6.2.orig/src/lxc/Makefile.am 2009-05-21 11:26:06.527984732 +0200
++++ lxc-0.6.2/src/lxc/Makefile.am 2009-05-21 11:30:21.774641310 +0200
+@@ -1,7 +1,6 @@
+ INCLUDES= -I$(top_srcdir)/src -DLXCPATH="\"@LXCPATH@\"" \
+ -DLXCBINDIR="\"$(bindir)\"" \
+ -DLXCLIBEXECDIR="\"$(libexecdir)\""
+-AM_LDFLAGS= -lutil
+ lib_LTLIBRARIES = liblxc.la
+ pkginclude_HEADERS = \
+ error.h \
+@@ -51,6 +50,7 @@
+ cr_plugin_columbia.c lxc_plugin.h
+
+ liblxc_la_LDFLAGS = -release @PACKAGE_VERSION@
++liblxc_la_LIBADD = -lutil
+
+ bin_SCRIPTS = \
+ lxc-ps \
diff --git a/app-emulation/lxc/lxc-0.6.3.ebuild b/app-emulation/lxc/lxc-0.6.3.ebuild
new file mode 100644
index 000000000000..6b883b626552
--- /dev/null
+++ b/app-emulation/lxc/lxc-0.6.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/lxc-0.6.3.ebuild,v 1.1 2009/10/24 10:49:24 flameeyes Exp $
+
+EAPI="2"
+
+inherit autotools eutils linux-info
+
+DESCRIPTION="Linux Resource Containers Userspace Tools"
+HOMEPAGE="http://lxc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="sys-libs/libcap"
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers
+ app-text/docbook-sgml-utils"
+
+# TODO:
+# - add checks for the various kernel features which have to be enabled
+
+CONFIG_CHECK="CGROUPS CGROUP_NS NAMESPACES UTS_NS IPC_NS USER_NS PID_NS NET_NS"
+
+src_prepare() {
+ epatch "${FILESDIR}/0.6.2-as-needed.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf --localstatedir=/var --bindir=/usr/sbin --disable-static
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog CONTRIBUTING MAINTAINERS NEWS README TODO doc/FAQ.txt || die
+
+ # The default files installed in /etc/lxc are just samples;
+ # install them as documentation instead.
+ mv "${D}"/etc/lxc "${D}"/usr/share/doc/${PF}/config-examples || die
+ keepdir /etc/lxc /var/lib/lxc
+
+ rm "${D}"/usr/sbin/lxc-{setcap,ls}
+
+ find "${D}" -name '*.la' -delete
+}
+
+pkg_postinst() {
+ ewarn "You may have to enable more than the kernel features this ebuild"
+ ewarn "already checked for, depending on what you want to use."
+ elog "If you want network you definetely have to enable the veth module"
+ elog "and possibly also the macvlan (depending on how you want to do it)."
+ elog "If you want the to be able to freeze containers you will also want"
+ elog "the cgroup freezer."
+}
diff --git a/app-emulation/lxc/metadata.xml b/app-emulation/lxc/metadata.xml
new file mode 100644
index 000000000000..868661456872
--- /dev/null
+++ b/app-emulation/lxc/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>dev-zero@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>