summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-24 07:53:19 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-24 07:53:19 +0000
commitd3bb5e7841a9349742457bde7d34f43b09d3121c (patch)
treeb8f90da79e34ea0be2b11b7e134c49780ef438d5 /app-emulation/plex86
parentdon't set DEPEND=RDEPEND (bug #45343); tidy (Manifest recommit) (diff)
downloadgentoo-2-d3bb5e7841a9349742457bde7d34f43b09d3121c.tar.gz
gentoo-2-d3bb5e7841a9349742457bde7d34f43b09d3121c.tar.bz2
gentoo-2-d3bb5e7841a9349742457bde7d34f43b09d3121c.zip
don't sed DEPEND=RDEPEND (bug #45343); use sed -i; use emake; error check
Diffstat (limited to 'app-emulation/plex86')
-rw-r--r--app-emulation/plex86/ChangeLog7
-rw-r--r--app-emulation/plex86/plex86-20021117.ebuild30
2 files changed, 21 insertions, 16 deletions
diff --git a/app-emulation/plex86/ChangeLog b/app-emulation/plex86/ChangeLog
index 7a4a3f9b4d74..9be08bc22f90 100644
--- a/app-emulation/plex86/ChangeLog
+++ b/app-emulation/plex86/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/plex86
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/plex86/ChangeLog,v 1.2 2003/02/12 04:02:05 vapier Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/plex86/ChangeLog,v 1.3 2004/03/24 07:53:18 mr_bones_ Exp $
+
+ 23 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> plex86-20021117.ebuild:
+ don't sed DEPEND=RDEPEND (bug #45343); use sed -i; use emake; error check
*plex86-20021117 (04 Jan 2003)
diff --git a/app-emulation/plex86/plex86-20021117.ebuild b/app-emulation/plex86/plex86-20021117.ebuild
index d1b12126b980..f1e6a0d5ae59 100644
--- a/app-emulation/plex86/plex86-20021117.ebuild
+++ b/app-emulation/plex86/plex86-20021117.ebuild
@@ -1,20 +1,21 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/plex86/plex86-20021117.ebuild,v 1.7 2004/02/20 06:08:34 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/plex86/plex86-20021117.ebuild,v 1.8 2004/03/24 07:53:19 mr_bones_ Exp $
DESCRIPTION="Plex86 is THE opensource free-software alternative for VMWare, VirtualPC, and other IA-32 on IA-32 \"Virtual PC products.\""
HOMEPAGE="http://savannah.gnu.org/projects/plex86/"
-LICENSE="LGPL-2.1"
SRC_URI="http://savannah.nongnu.org/download/plex86/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="x86"
IUSE="X sdl"
+
RDEPEND=">=sys-libs/ncurses-5.2-r7
- X? ( >=x11-base/xfree-4.2.0 )
+ X? ( virtual/x11 )
sdl? ( >=media-libs/libsdl-1.2.4 )"
-DEPEND="${RDEPEND}"
-DEPEND=""
-S="${WORKDIR}/${P}"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
src_compile() {
MY_CONF="--with-Linux --enable-cdrom --enable-split-hd --enable-pci --enable-vbe --enable-sb16=linux --enable-instrumentation"
@@ -29,23 +30,24 @@ src_compile() {
MY_CONF="${MY_CONF} --with-gui=${MY_GUI}"
# fix typo (bug submitted)
- mv user/plugins/bochs/iodev/eth_fbsd.cc user/plugins/bochs/iodev/eth_fbsd.cc_orig
- sed s/'inclide'/'include'/ user/plugins/bochs/iodev/eth_fbsd.cc_orig > user/plugins/bochs/iodev/eth_fbsd.cc
+ sed -i \
+ -e s/'inclide'/'include'/ user/plugins/bochs/iodev/eth_fbsd.cc \
+ || die "sed eth_fbsd.cc failed"
./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man ${MY_CONF} || die "./configure failed"
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man ${MY_CONF} || die "./configure failed"
- make || die
+ emake || die "emake failed"
}
src_install() {
#make DESTDIR=${D} install || die
# for now just this:
dodir /opt/${P}
- cp -r * ${D}/opt/${P}
+ cp -r * ${D}/opt/${P} || die "cp failed"
}
pkg_postinst() {