summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-24 19:54:55 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-24 19:54:55 +0000
commit24af3d38adfede94552e747c1aed0ae94464d057 (patch)
tree654b24f707979959d1c0c84d28f7b26050d326d9 /app-emulation/point2play
parentbump pyserial 2.0 to stable for py2.3 changes (#39259) (Manifest recommit) (diff)
downloadgentoo-2-24af3d38adfede94552e747c1aed0ae94464d057.tar.gz
gentoo-2-24af3d38adfede94552e747c1aed0ae94464d057.tar.bz2
gentoo-2-24af3d38adfede94552e747c1aed0ae94464d057.zip
ver bump #39170
Diffstat (limited to 'app-emulation/point2play')
-rw-r--r--app-emulation/point2play/ChangeLog7
-rw-r--r--app-emulation/point2play/files/1.2-python2.2.patch38
-rw-r--r--app-emulation/point2play/files/digest-point2play-1.21
-rw-r--r--app-emulation/point2play/point2play-1.2.ebuild34
4 files changed, 79 insertions, 1 deletions
diff --git a/app-emulation/point2play/ChangeLog b/app-emulation/point2play/ChangeLog
index 420cf2436b15..ee1a9c7e9743 100644
--- a/app-emulation/point2play/ChangeLog
+++ b/app-emulation/point2play/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/point2play
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/ChangeLog,v 1.4 2003/10/07 19:26:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/ChangeLog,v 1.5 2004/01/24 19:54:55 vapier Exp $
+
+*point2play-1.2 (24 Jan 2004)
+
+ 24 Jan 2004; Mike Frysinger <vapier@gentoo.org> :
+ Version bump #39170 by Curtis Campbell.
*point2play-1.1.1-r1 (07 Oct 2003)
diff --git a/app-emulation/point2play/files/1.2-python2.2.patch b/app-emulation/point2play/files/1.2-python2.2.patch
new file mode 100644
index 000000000000..fd24b7762af5
--- /dev/null
+++ b/app-emulation/point2play/files/1.2-python2.2.patch
@@ -0,0 +1,38 @@
+--- usr/lib/transgaming_point2play/tests/test_sound.py.orig 2003-09-16 14:04:31.000000000 -0400
++++ usr/lib/transgaming_point2play/tests/test_sound.py 2003-10-07 15:17:36.044822360 -0400
+@@ -12,14 +12,21 @@
+ import wave
+ import os, os.path
+
+-import ossaudiodev
+-
++disable_oss = 0;
++try:
++ import ossaudiodev
++except:
++ print "Python 2.3 not found. Disabling oss audio tests."
++ disable_oss = 1;
+
+ TESTS = (_("Test For Sound Support"), "tgtest_sound", False),
+
+ def tgtest_sound():
+ """runs a test to ensure that sound output is working"""
+
++ if disable_oss:
++ return ((_('Basic sound test'), _('Test is disabled.'), 'red'),)
++
+ try:
+ try:
+ P2PPATH=os.environ["P2PPATH"] + "/"
+@@ -56,6 +63,11 @@
+ return ((_('Basic sound test'), _('Completed successfully\nDid you hear the sound?'), 'green'),)
+
+ def tgtest_sound_description():
++ if disable_oss:
++ return _('This test has been disabled.\n') + \
++ _('Please see:\n') + \
++ _('http://bugs.gentoo.org/show_bug.cgi?id=30556\n') + \
++ _('for more information.')
+ return _('This test attempts to play a sound\n') + \
+ _('file at 44 khz. This test uses the\n') + \
+ _('same method as WineX to play sound\n') + \
diff --git a/app-emulation/point2play/files/digest-point2play-1.2 b/app-emulation/point2play/files/digest-point2play-1.2
new file mode 100644
index 000000000000..7602fe7d571e
--- /dev/null
+++ b/app-emulation/point2play/files/digest-point2play-1.2
@@ -0,0 +1 @@
+MD5 5ed08cbe32b084fec1f780b2828dbeab point2play-small-1.2.tgz 647628
diff --git a/app-emulation/point2play/point2play-1.2.ebuild b/app-emulation/point2play/point2play-1.2.ebuild
new file mode 100644
index 000000000000..76b97c63e166
--- /dev/null
+++ b/app-emulation/point2play/point2play-1.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/point2play-1.2.ebuild,v 1.1 2004/01/24 19:54:55 vapier Exp $
+
+MY_P=${PN}-small-${PV}
+DESCRIPTION="graphical frontend for WineX"
+HOMEPAGE="http://www.transgaming.com/"
+SRC_URI="${MY_P}.tgz"
+
+LICENSE="point2play"
+SLOT="3"
+KEYWORDS="x86"
+RESTRICT="fetch"
+
+RDEPEND="virtual/x11
+ >=dev-lang/python-2.0
+ >=dev-python/pygtk-1.99.16
+ >=x11-themes/gtk-engines-metal-2.2.0"
+
+pkg_nofetch() {
+ einfo "Please download the appropriate Point2Play archive (${MY_P}.tgz)"
+ einfo "from ${HOMEPAGE} (requires a Transgaming subscription)"
+ echo
+ einfo "The archive should then be placed into ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-python2.2.patch
+}
+
+src_install() {
+ mv ${WORKDIR}/usr ${D}
+}