summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-10-10 19:24:31 +0000
committerMike Frysinger <vapier@gentoo.org>2012-10-10 19:24:31 +0000
commit5961d5fac326fe8add9bb51c3b29b3f7bd0f88a9 (patch)
tree916b9d1f430ae27d1d37194c01e9ac27425d088d /app-emulation/qemu/qemu-9999.ebuild
parentHandle more USE=static/static-libs cases. (diff)
downloadgentoo-2-5961d5fac326fe8add9bb51c3b29b3f7bd0f88a9.tar.gz
gentoo-2-5961d5fac326fe8add9bb51c3b29b3f7bd0f88a9.tar.bz2
gentoo-2-5961d5fac326fe8add9bb51c3b29b3f7bd0f88a9.zip
Convert to USE=uuid since the -luuid interface is portable beyond linux.
(Portage version: 2.2.0_alpha131/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/qemu/qemu-9999.ebuild')
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index c039e493d843..5de78762d5bc 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-9999.ebuild,v 1.23 2012/10/10 19:20:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-9999.ebuild,v 1.24 2012/10/10 19:24:31 vapier Exp $
EAPI="4"
@@ -30,7 +30,7 @@ LICENSE="GPL-2 LGPL-2 BSD-2"
SLOT="0"
IUSE="+aio alsa bluetooth brltty +caps +curl debug doc fdt kernel_linux \
kernel_FreeBSD mixemu ncurses opengl pulseaudio python rbd sasl sdl \
-smartcard spice static systemtap tci tls usbredir vde +vhost-net \
+smartcard spice static systemtap tci tls usbredir +uuid vde +vhost-net \
virtfs xattr xen xfs"
COMMON_TARGETS="i386 x86_64 alpha arm cris m68k microblaze microblazeel mips mipsel or32 ppc ppc64 sh4 sh4eb sparc sparc64 s390x unicore32"
@@ -72,13 +72,13 @@ LIB_DEPEND=">=dev-libs/glib-2.0[static-libs(+)]
caps? ( sys-libs/libcap-ng[static-libs(+)] )
curl? ( >=net-misc/curl-7.15.4[static-libs(+)] )
fdt? ( >=sys-apps/dtc-1.2.0[static-libs(+)] )
- kernel_linux? ( >=sys-apps/util-linux-2.16.0[static-libs(+)] )
ncurses? ( sys-libs/ncurses[static-libs(+)] )
rbd? ( sys-cluster/ceph[static-libs(+)] )
sasl? ( dev-libs/cyrus-sasl[static-libs(+)] )
sdl? ( >=media-libs/libsdl-1.2.11[static-libs(+)] )
spice? ( >=app-emulation/spice-0.9.0[static-libs(+)] )
tls? ( net-libs/gnutls[static-libs(+)] )
+ uuid? ( >=sys-apps/util-linux-2.16.0[static-libs(+)] )
vde? ( net-misc/vde[static-libs(+)] )
xattr? ( sys-apps/attr[static-libs(+)] )
xfs? ( sys-fs/xfsprogs[static-libs(+)] )"
@@ -248,9 +248,6 @@ src_configure() {
use pulseaudio && audio_opts="pa,${audio_opts}"
use mixemu && conf_opts="${conf_opts} --enable-mixemu"
- # conditionally making UUID work on Linux only is wrong
- # but the Gentoo/FreeBSD guys need to figure out what
- # provides libuuid on their platform
# --enable-vnc-thread will go away in 1.2
# $(use_enable xen xen-pci-passthrough) for 1.2
# $(use_enable debug debug-mon) goes away for 1.2
@@ -278,7 +275,6 @@ src_configure() {
$(use_enable fdt) \
$(use_enable kernel_linux kvm) \
$(use_enable kernel_linux nptl) \
- $(use_enable kernel_linux uuid) \
$(use_enable ncurses curses) \
$(use_enable opengl) \
$(use_enable rbd) \
@@ -290,6 +286,7 @@ src_configure() {
$(use_enable tci tcg-interpreter) \
$(use_enable tls vnc-tls) \
$(use_enable usbredir usb-redir) \
+ $(use_enable uuid) \
$(use_enable vde) \
$(use_enable vhost-net) \
$(use_enable virtfs) \