summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2012-10-28 18:59:12 +0000
committerTiziano Müller <dev-zero@gentoo.org>2012-10-28 18:59:12 +0000
commitf81bfafba6326ac9e93b1ffdcf7cc90d410fe250 (patch)
treeb695f92d2ee90d22a6b765eabd974f2ad5e46071 /app-emulation/qemu
parentstable ppc64, bug #439390 (diff)
downloadgentoo-2-f81bfafba6326ac9e93b1ffdcf7cc90d410fe250.tar.gz
gentoo-2-f81bfafba6326ac9e93b1ffdcf7cc90d410fe250.tar.bz2
gentoo-2-f81bfafba6326ac9e93b1ffdcf7cc90d410fe250.zip
Fix some build issues (missing patch and wrong S), avoid collision with libcacard (bug #439990).
(Portage version: 2.1.11.20/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/qemu')
-rw-r--r--app-emulation/qemu/ChangeLog6
-rw-r--r--app-emulation/qemu/qemu-1.2.0.ebuild9
2 files changed, 12 insertions, 3 deletions
diff --git a/app-emulation/qemu/ChangeLog b/app-emulation/qemu/ChangeLog
index 9bd993bad296..32b54a191afb 100644
--- a/app-emulation/qemu/ChangeLog
+++ b/app-emulation/qemu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/qemu
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.134 2012/10/28 09:27:24 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.135 2012/10/28 18:59:12 dev-zero Exp $
+
+ 28 Oct 2012; Tiziano Müller <dev-zero@gentoo.org> qemu-1.2.0.ebuild:
+ Fix some build issues (missing patch and wrong S), avoid collision with
+ libcacard (bug #439990).
28 Oct 2012; Zac Medico <zmedico@gentoo.org> qemu-1.1.1-r1.ebuild,
qemu-1.1.2-r1.ebuild, qemu-1.1.2-r2.ebuild, qemu-1.2.0.ebuild,
diff --git a/app-emulation/qemu/qemu-1.2.0.ebuild b/app-emulation/qemu/qemu-1.2.0.ebuild
index 5283dbc8ab78..e8e0ca4b5a19 100644
--- a/app-emulation/qemu/qemu-1.2.0.ebuild
+++ b/app-emulation/qemu/qemu-1.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-1.2.0.ebuild,v 1.3 2012/10/28 09:27:24 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-1.2.0.ebuild,v 1.4 2012/10/28 18:59:12 dev-zero Exp $
EAPI="4"
@@ -139,6 +139,8 @@ QA_WX_LOAD="${QA_PRESTRIPPED}
usr/bin/qemu-armeb
usr/bin/qemu-sparc32plus"
+S="${WORKDIR}/${MY_P}"
+
pkg_pretend() {
if use kernel_linux && kernel_is lt 2 6 25; then
eerror "This version of KVM requres a host kernel of 2.6.25 or higher."
@@ -196,7 +198,7 @@ src_prepare() {
python_convert_shebangs -r 2 "${S}/scripts/kvm/kvm_stat"
- epatch "${FILESDIR}"/${P}-fix-mipsen.patch
+ epatch "${FILESDIR}"/${P}-cflags.patch
[[ -n ${BACKPORTS} ]] && \
EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
epatch
@@ -337,6 +339,9 @@ src_install() {
use python & dobin scripts/kvm/kvm_stat
+ # avoid collision with libcacard
+ use smartcard && mv "${ED}/usr/bin/vscclient" "${ED}/usr/bin/qemu-vscclient"
+
# Remove SeaBIOS since we're using the SeaBIOS packaged one
rm "${ED}/usr/share/qemu/bios.bin"
dosym ../seabios/bios.bin /usr/share/qemu/bios.bin