summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2012-10-28 20:15:51 +0000
committerDoug Goldstein <cardoe@gentoo.org>2012-10-28 20:15:51 +0000
commitfea9bd360ddb024d84dee2fbc128aa22c91d26a0 (patch)
tree832ebad01eca35d6ff3a3a854b4c3c1061d52215 /app-emulation/qemu
parentAdd support for on-the-fly bzip2 decompression. (diff)
downloadgentoo-2-fea9bd360ddb024d84dee2fbc128aa22c91d26a0.tar.gz
gentoo-2-fea9bd360ddb024d84dee2fbc128aa22c91d26a0.tar.bz2
gentoo-2-fea9bd360ddb024d84dee2fbc128aa22c91d26a0.zip
Ensure qemu-1.2.0 is blocked despite people's insistence
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/qemu')
-rw-r--r--app-emulation/qemu/qemu-1.2.0.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/app-emulation/qemu/qemu-1.2.0.ebuild b/app-emulation/qemu/qemu-1.2.0.ebuild
index e8e0ca4b5a19..9795bc265e5d 100644
--- a/app-emulation/qemu/qemu-1.2.0.ebuild
+++ b/app-emulation/qemu/qemu-1.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-1.2.0.ebuild,v 1.4 2012/10/28 18:59:12 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-1.2.0.ebuild,v 1.5 2012/10/28 20:15:51 cardoe Exp $
EAPI="4"
@@ -182,6 +182,11 @@ pkg_pretend() {
ewarn "on the mailing list about USE=static's place in Gentoo. As a"
ewarn "result what worked today may not work tomorrow."
fi
+
+ if [[ "${I_WAS_TOLD_NOT_TO_USE_THIS_BUT_DID_ANYWAY}" != "derp" ]]; then
+ eerror "This ebuild is masked and unkeyworded. WHY are you using it!?"
+ die "This ebuild is masked and unkeyworded. WHY are you using it!?"
+ fi
}
pkg_setup() {