summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-03-19 15:23:43 +0000
committerDavid Holm <dholm@gentoo.org>2004-03-19 15:23:43 +0000
commit3737747a611d4d414e06b223121328f367e6816e (patch)
treecf6ffdcbf50a1c78bf24adc53f529ab1ff3d33e7 /app-emulation/sheepshaver
parentmoving features to top-level (diff)
downloadgentoo-2-3737747a611d4d414e06b223121328f367e6816e.tar.gz
gentoo-2-3737747a611d4d414e06b223121328f367e6816e.tar.bz2
gentoo-2-3737747a611d4d414e06b223121328f367e6816e.zip
Initial import of SheepShaver
Diffstat (limited to 'app-emulation/sheepshaver')
-rw-r--r--app-emulation/sheepshaver/ChangeLog10
-rw-r--r--app-emulation/sheepshaver/Manifest4
-rw-r--r--app-emulation/sheepshaver/files/digest-sheepshaver-200403191
-rw-r--r--app-emulation/sheepshaver/metadata.xml10
-rw-r--r--app-emulation/sheepshaver/sheepshaver-20040319.ebuild33
5 files changed, 58 insertions, 0 deletions
diff --git a/app-emulation/sheepshaver/ChangeLog b/app-emulation/sheepshaver/ChangeLog
new file mode 100644
index 000000000000..2c4d5b990931
--- /dev/null
+++ b/app-emulation/sheepshaver/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-emulation/sheepshaver
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/sheepshaver/ChangeLog,v 1.1 2004/03/19 15:23:43 dholm Exp $
+
+*sheepshaver-20040319 (19 Mar 2004)
+
+ 19 Mar 2004; David Holm <dholm@gentoo.org> metadata.xml,
+ sheepshaver-20040319.ebuild:
+ Initial import.
+
diff --git a/app-emulation/sheepshaver/Manifest b/app-emulation/sheepshaver/Manifest
new file mode 100644
index 000000000000..d9e7ffb771ad
--- /dev/null
+++ b/app-emulation/sheepshaver/Manifest
@@ -0,0 +1,4 @@
+MD5 e21b49523bc7320e6a054def90146fa6 sheepshaver-20040319.ebuild 740
+MD5 d6c67932b1690484ae0b153f549ba7d0 metadata.xml 792
+MD5 27c6f22b8f5d3ccde4994d75c3a83d30 ChangeLog 280
+MD5 84f85472d4df884151c8b8ddbb4d6337 files/digest-sheepshaver-20040319 73
diff --git a/app-emulation/sheepshaver/files/digest-sheepshaver-20040319 b/app-emulation/sheepshaver/files/digest-sheepshaver-20040319
new file mode 100644
index 000000000000..02e2d93291bf
--- /dev/null
+++ b/app-emulation/sheepshaver/files/digest-sheepshaver-20040319
@@ -0,0 +1 @@
+MD5 6765637c9a30d0bfeecf20a29bc072f8 sheepshaver-20040319.tar.bz2 951550
diff --git a/app-emulation/sheepshaver/metadata.xml b/app-emulation/sheepshaver/metadata.xml
new file mode 100644
index 000000000000..aa5441e1390b
--- /dev/null
+++ b/app-emulation/sheepshaver/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>dholm@gentoo.org</email>
+ <name>David Holm</name>
+</maintainer>
+<longdescription>SheepShaver is a MacOS run-time environment for BeOS and Linux that allows you to run classic MacOS applications inside the BeOS/Linux multitasking environment. This means that both BeOS/Linux and MacOS applications can run at the same time (usually in a window on the BeOS/Linux desktop) and data can be exchanged between them. If you are using a PowerPC-based system, applications will run at native speed (i.e. with no emulation involved). There is also a built-in PowerPC emulator for non-PowerPC systems.</longdescription>
+</pkgmetadata>
diff --git a/app-emulation/sheepshaver/sheepshaver-20040319.ebuild b/app-emulation/sheepshaver/sheepshaver-20040319.ebuild
new file mode 100644
index 000000000000..c3832d4f4c37
--- /dev/null
+++ b/app-emulation/sheepshaver/sheepshaver-20040319.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/sheepshaver/sheepshaver-20040319.ebuild,v 1.1 2004/03/19 15:23:43 dholm Exp $
+
+S="${WORKDIR}/${P}/SheepShaver"
+DESCRIPTION="A MacOS run-time environment that allows you to run classic MacOS applications"
+HOMEPAGE="http://www.uni-mainz.de/~bauec002/SheepShaver.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc"
+IUSE="gtk esd"
+
+DEPEND="gtk? ( x11-libs/gtk+ )
+ esd? ( media-sound/esound )"
+
+src_compile() {
+ make links || die "Failed making links"
+
+ cd src/Unix
+ aclocal; autoheader; autoconf
+
+ econf || die "configure failed"
+ emake || die "compilation failed"
+}
+
+src_install() {
+ dohtml doc/Linux/*
+
+ cd src/Unix
+ einstall || die "Installation failed"
+}