summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2006-07-17 05:58:39 +0000
committerHarald van Dijk <truedfx@gentoo.org>2006-07-17 05:58:39 +0000
commit465e07d3934711f9fbb5e7b91900393f451febb6 (patch)
tree4ada613ddedfd5eab49ee2299c34b6a9f0bce1bf /app-emulation/spectemu
parentupdate HOMEPAGE/SRC_URI #140304 by David Durrleman (diff)
downloadgentoo-2-465e07d3934711f9fbb5e7b91900393f451febb6.tar.gz
gentoo-2-465e07d3934711f9fbb5e7b91900393f451febb6.tar.bz2
gentoo-2-465e07d3934711f9fbb5e7b91900393f451febb6.zip
QA fixes (#140680)
(Portage version: 2.1.1_pre2-r8)
Diffstat (limited to 'app-emulation/spectemu')
-rw-r--r--app-emulation/spectemu/ChangeLog6
-rw-r--r--app-emulation/spectemu/files/digest-spectemu-0.99.32
-rw-r--r--app-emulation/spectemu/files/spectemu-0.99.3-qa.patch23
-rw-r--r--app-emulation/spectemu/spectemu-0.99.3.ebuild27
4 files changed, 45 insertions, 13 deletions
diff --git a/app-emulation/spectemu/ChangeLog b/app-emulation/spectemu/ChangeLog
index 5c757602355b..7161f793d94c 100644
--- a/app-emulation/spectemu/ChangeLog
+++ b/app-emulation/spectemu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/spectemu
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spectemu/ChangeLog,v 1.15 2006/01/24 23:55:49 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spectemu/ChangeLog,v 1.16 2006/07/17 05:58:39 truedfx Exp $
+
+ 17 Jul 2006; Harald van Dijk <truedfx@gentoo.org>
+ +files/spectemu-0.99.3-qa.patch, spectemu-0.99.3.ebuild:
+ QA fixes (#140680)
24 Jan 2006; Marcelo Goes <vanquirius@gentoo.org> spectemu-0.99.3.ebuild:
Make modular X friendly.
diff --git a/app-emulation/spectemu/files/digest-spectemu-0.99.3 b/app-emulation/spectemu/files/digest-spectemu-0.99.3
index f236e6c2e193..15c728ffe3fd 100644
--- a/app-emulation/spectemu/files/digest-spectemu-0.99.3
+++ b/app-emulation/spectemu/files/digest-spectemu-0.99.3
@@ -1 +1,3 @@
MD5 67330d27e3f5c9127413bd6f35aa664b spectemu-0.99.3.tar.gz 269524
+RMD160 000c87e3a126d32ba9bd0829ba2f5184b360af1c spectemu-0.99.3.tar.gz 269524
+SHA256 a3f51176fdbcdbd1cdf8e0bab6b668a548c79b8fc699d5a7199ecfde79c79bc1 spectemu-0.99.3.tar.gz 269524
diff --git a/app-emulation/spectemu/files/spectemu-0.99.3-qa.patch b/app-emulation/spectemu/files/spectemu-0.99.3-qa.patch
new file mode 100644
index 000000000000..00d136305819
--- /dev/null
+++ b/app-emulation/spectemu/files/spectemu-0.99.3-qa.patch
@@ -0,0 +1,23 @@
+--- spectemu-0.99.3/Makefile.in
++++ spectemu-0.99.3/Makefile.in
+@@ -45,9 +45,9 @@
+
+ install_prog: $(progs)
+ if test -f xspect; then \
+- $(INSTALL_PROGRAM) -s -m 755 xspect $(i_bindir); fi
++ $(INSTALL_PROGRAM) -m 755 xspect $(i_bindir); fi
+ if test -f vgaspect; then \
+- $(INSTALL_PROGRAM) -s -m 4755 vgaspect $(i_bindir); fi
++ $(INSTALL_PROGRAM) -m 4755 vgaspect $(i_bindir); fi
+
+ install_man:
+ $(INSTALL_DATA) ./xspect.1 $(i_mandir)
+@@ -88,7 +88,7 @@
+ ./sp_to_s < i386emul.sp > i386emul.s
+
+ i386emul.o: i386emul.s
+- $(CC) -c $(CFLAGS) i386emul.s
++ $(CC) -c $(ASFLAGS) -Xassembler --noexecstack i386emul.s
+
+ sp_to_s: sp_to_s.o
+ $(CC) -o sp_to_s $(LDFLAGS) sp_to_s.o
diff --git a/app-emulation/spectemu/spectemu-0.99.3.ebuild b/app-emulation/spectemu/spectemu-0.99.3.ebuild
index 99158a8940ac..3dc7fd46b3ff 100644
--- a/app-emulation/spectemu/spectemu-0.99.3.ebuild
+++ b/app-emulation/spectemu/spectemu-0.99.3.ebuild
@@ -1,23 +1,23 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spectemu/spectemu-0.99.3.ebuild,v 1.5 2006/01/24 23:55:49 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spectemu/spectemu-0.99.3.ebuild,v 1.6 2006/07/17 05:58:39 truedfx Exp $
### Several versions of specemu exist, xspect & vgaspect, utilising X11
### and/or svgalib. libreadline provides optional runtime features.
### The ./configure script automagically figures out which binaries to build
### so the run/compiletime dependancies here are use dependant
+inherit eutils
+
DESCRIPTION="48k ZX Spectrum Emulator"
HOMEPAGE="http://kempelen.iit.bme.hu/~mszeredi/spectemu/spectemu.html"
SRC_URI="http://www.inf.bme.hu/~mszeredi/spectemu/${P}.tar.gz"
-LICENSE="|| ( GPL-2 LGPL-2 )"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~amd64"
IUSE="X readline svga"
-#X? ( virtual/x11 )
-
DEPEND="X? ( || (
( >=x11-proto/xf86vidmodeproto-2.2.2
>=x11-proto/xextproto-7.0.2
@@ -30,18 +30,21 @@ DEPEND="X? ( || (
readline? ( sys-libs/readline )"
RDEPEND="svga? ( media-libs/svgalib )"
-src_compile() {
- local myflags
- use X || myflags="${myflags} --with-x=no"
- use readline || myflags="${myflags} --without-readline"
-
- myflags="${myflags} --mandir=${D}/usr/share/man/"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-qa.patch
+}
- econf ${myflags} || die "Spectemu ./configure failed"
+src_compile() {
+ econf \
+ $(use_with readline) \
+ $(use_with X x) \
+ || die "Spectemu ./configure failed"
emake || die "Spectemu make failed"
}
src_install() {
- einstall || die
+ make install_root="${D}" install || die
}