summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-08-15 00:42:13 +0000
committerJeroen Roovers <jer@gentoo.org>2011-08-15 00:42:13 +0000
commit9ef9d250feaa75ab06d5e551901f401b17db14c4 (patch)
tree7947527666514254dacbdb47fa3e1d09a7947fd2 /app-emulation/spice-vdagent
parentRemove old (diff)
downloadgentoo-2-9ef9d250feaa75ab06d5e551901f401b17db14c4.tar.gz
gentoo-2-9ef9d250feaa75ab06d5e551901f401b17db14c4.tar.bz2
gentoo-2-9ef9d250feaa75ab06d5e551901f401b17db14c4.zip
Fix init.d script thanks to Chris Mayo (bug #378833).
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/spice-vdagent')
-rw-r--r--app-emulation/spice-vdagent/ChangeLog8
-rw-r--r--app-emulation/spice-vdagent/files/spice-vdagent.initd6
-rw-r--r--app-emulation/spice-vdagent/spice-vdagent-0.8.1-r1.ebuild50
3 files changed, 60 insertions, 4 deletions
diff --git a/app-emulation/spice-vdagent/ChangeLog b/app-emulation/spice-vdagent/ChangeLog
index 2b03163229a8..20d1e351234c 100644
--- a/app-emulation/spice-vdagent/ChangeLog
+++ b/app-emulation/spice-vdagent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/spice-vdagent
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice-vdagent/ChangeLog,v 1.2 2011/07/25 09:24:52 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice-vdagent/ChangeLog,v 1.3 2011/08/15 00:42:13 jer Exp $
+
+*spice-vdagent-0.8.1-r1 (15 Aug 2011)
+
+ 15 Aug 2011; Jeroen Roovers <jer@gentoo.org> +spice-vdagent-0.8.1-r1.ebuild,
+ files/spice-vdagent.initd:
+ Fix init.d script thanks to Chris Mayo (bug #378833).
*spice-vdagent-0.8.1 (25 Jul 2011)
diff --git a/app-emulation/spice-vdagent/files/spice-vdagent.initd b/app-emulation/spice-vdagent/files/spice-vdagent.initd
index 08b685c98251..fb5bd89ff0cd 100644
--- a/app-emulation/spice-vdagent/files/spice-vdagent.initd
+++ b/app-emulation/spice-vdagent/files/spice-vdagent.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice-vdagent/files/spice-vdagent.initd,v 1.2 2011/07/25 09:24:52 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice-vdagent/files/spice-vdagent.initd,v 1.3 2011/08/15 00:42:13 jer Exp $
depend() {
after dbus
@@ -33,7 +33,7 @@ start() {
rm -f /var/run/spice-vdagentd/spice-vdagent-sock
ebegin "Starting spice VD agent daemon"
- start-stop-daemon
+ start-stop-daemon \
--start \
--pidfile "${PIDFILE}" \
--exec /usr/sbin/spice-vdagentd \
@@ -43,7 +43,7 @@ start() {
stop() {
ebegin "Stopping spice VD agent daemon"
- start-stop-daemon
+ start-stop-daemon \
--stop \
--pidfile "${PIDFILE}"
eend $?
diff --git a/app-emulation/spice-vdagent/spice-vdagent-0.8.1-r1.ebuild b/app-emulation/spice-vdagent/spice-vdagent-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..87b9811a7136
--- /dev/null
+++ b/app-emulation/spice-vdagent/spice-vdagent-0.8.1-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice-vdagent/spice-vdagent-0.8.1-r1.ebuild,v 1.1 2011/08/15 00:42:13 jer Exp $
+
+EAPI=4
+
+inherit linux-info
+
+DESCRIPTION="SPICE VD Linux Guest Agent."
+HOMEPAGE="http://spice-space.org/"
+SRC_URI="http://spice-space.org/download/releases/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+consolekit"
+
+RDEPEND="x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libX11
+ >=app-emulation/spice-protocol-0.8.1
+ consolekit? ( sys-auth/consolekit sys-apps/dbus )"
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+CONFIG_CHECK="INPUT_UINPUT"
+ERROR_INPUT_UINPUT="User level driver support is required to run the spice-vdagent daemon"
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ $(use_enable consolekit console-kit)
+}
+
+src_install() {
+ default
+
+ rm -rf "${D}"/etc/{rc,tmpfiles}.d
+
+ keepdir /var/run/spice-vdagentd
+ keepdir /var/log/spice-vdagentd
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+}
+
+pkg_postinst() {
+ elog "Make sure that the User level driver support kernel module 'uinput' is loaded"
+ elog "if built as a module before starting the vdagent daemon."
+}