summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2007-04-13 18:27:07 +0000
committerMichael Januszewski <spock@gentoo.org>2007-04-13 18:27:07 +0000
commitdee4ab967ca07fa8daa0ca497f7533a217896ff6 (patch)
tree3aa9d893ef4bef2a4816e1cc1ee5dc86af8ac970 /app-emulation/uade
parentVersion bump and closing bug #172282. (diff)
downloadgentoo-2-dee4ab967ca07fa8daa0ca497f7533a217896ff6.tar.gz
gentoo-2-dee4ab967ca07fa8daa0ca497f7533a217896ff6.tar.bz2
gentoo-2-dee4ab967ca07fa8daa0ca497f7533a217896ff6.zip
Version bump.
(Portage version: 2.1.2.3)
Diffstat (limited to 'app-emulation/uade')
-rw-r--r--app-emulation/uade/ChangeLog7
-rw-r--r--app-emulation/uade/files/digest-uade-2.063
-rw-r--r--app-emulation/uade/uade-2.06.ebuild36
3 files changed, 45 insertions, 1 deletions
diff --git a/app-emulation/uade/ChangeLog b/app-emulation/uade/ChangeLog
index 576a24b87475..33d0ea9a722c 100644
--- a/app-emulation/uade/ChangeLog
+++ b/app-emulation/uade/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/uade
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/ChangeLog,v 1.43 2007/03/16 20:03:01 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/ChangeLog,v 1.44 2007/04/13 18:27:07 spock Exp $
+
+*uade-2.06 (13 Apr 2007)
+
+ 13 Apr 2007; Michał Januszewski <spock@gentoo.org> +uade-2.06.ebuild:
+ Version bump.
16 Mar 2007; Michał Januszewski <spock@gentoo.org>
+files/uade-2.05-audacious-1.3api.patch, uade-2.05.ebuild:
diff --git a/app-emulation/uade/files/digest-uade-2.06 b/app-emulation/uade/files/digest-uade-2.06
new file mode 100644
index 000000000000..278bc281b9d4
--- /dev/null
+++ b/app-emulation/uade/files/digest-uade-2.06
@@ -0,0 +1,3 @@
+MD5 a19bb1014678b3f23926a4241c57e303 uade-2.06.tar.bz2 2563385
+RMD160 d74154dfd4ca549428caf1338acbc46f846320c7 uade-2.06.tar.bz2 2563385
+SHA256 4665fdddc4dc554d5ea65c505ce6f4438f5877be37289e9cba2f5914099bf050 uade-2.06.tar.bz2 2563385
diff --git a/app-emulation/uade/uade-2.06.ebuild b/app-emulation/uade/uade-2.06.ebuild
new file mode 100644
index 000000000000..0f32819e7399
--- /dev/null
+++ b/app-emulation/uade/uade-2.06.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/uade-2.06.ebuild,v 1.1 2007/04/13 18:27:07 spock Exp $
+
+inherit eutils
+
+DESCRIPTION="Unix Amiga Delitracker Emulator - plays old Amiga tunes through UAE emulation and cloned m68k-assembler Eagleplayer API"
+HOMEPAGE="http://zakalwe.fi/uade"
+SRC_URI="http://zakalwe.fi/uade/uade2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="audacious"
+
+RDEPEND="media-libs/libao
+ audacious? ( >=media-sound/audacious-0.2 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --package-prefix="${D}" \
+ $(use_with audacious) \
+ --without-xmms \
+ || die "configure failed"
+ emake || die 'emake failed'
+}
+
+src_install() {
+ make install || die 'make install failed'
+ dodoc AUTHORS ChangeLog doc/BUGS doc/PLANS
+ doman doc/uade123.1
+}