summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-03-04 21:04:15 +0000
committerDavid Holm <dholm@gentoo.org>2004-03-04 21:04:15 +0000
commitab16032acd0e8f3c5c07116cef6a74869f65d7b3 (patch)
tree264c8606404c06f5b932f47db4305cf700df5c8b /app-emulation/uae/uae-0.8.25_pre20040302.ebuild
parentfixing fftw depend. (Manifest recommit) (diff)
downloadgentoo-2-ab16032acd0e8f3c5c07116cef6a74869f65d7b3.tar.gz
gentoo-2-ab16032acd0e8f3c5c07116cef6a74869f65d7b3.tar.bz2
gentoo-2-ab16032acd0e8f3c5c07116cef6a74869f65d7b3.zip
Cleanup submitted by Jonathan Heaney
Diffstat (limited to 'app-emulation/uae/uae-0.8.25_pre20040302.ebuild')
-rw-r--r--app-emulation/uae/uae-0.8.25_pre20040302.ebuild14
1 files changed, 4 insertions, 10 deletions
diff --git a/app-emulation/uae/uae-0.8.25_pre20040302.ebuild b/app-emulation/uae/uae-0.8.25_pre20040302.ebuild
index c4db6b94b086..0ef924c0e572 100644
--- a/app-emulation/uae/uae-0.8.25_pre20040302.ebuild
+++ b/app-emulation/uae/uae-0.8.25_pre20040302.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.25_pre20040302.ebuild,v 1.1 2004/03/04 20:05:05 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.25_pre20040302.ebuild,v 1.2 2004/03/04 21:04:12 dholm Exp $
inherit flag-o-matic
@@ -18,26 +18,20 @@ IUSE="X gtk sdl"
DEPEND="X? ( virtual/x11 gtk? x11-libs/gtk+ ) :
( ncurses? sys-libs/ncurses svga? media-libs/svgalib )
sdl? media-libs/libsdl
- games-emulation/caps
- app-cdr/cdrtools"
+ app-cdr/cdrtools
+ games-emulation/caps"
src_compile() {
ewarn "Compiling the CPU-core requires a substantial amount of RAM."
ewarn "Make sure that you have at least 512MB of RAM+SWAP available."
- # copy over dirty scsi copy script
- cp ${FILESDIR}/install_libscg_gentoo ${S}/src
- # and run
- /bin/sh ${S}/src/install_libscg_gentoo
-
replace-flags "-O3" "-O2"
use sdl && myconf="--with-sdl-sound --with-sdl-gfx"
econf ${myconf} \
--enable-threads \
--enable-scsi-device \
- --enable-cdtv \
- --enable-cd32 \
+ --with-libscg-includedir=/usr/include/scsilib \
|| die "./configure failed"
emake -j1 || die "emake failed"