summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-05-10 04:53:42 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-05-10 04:53:42 +0000
commit950f061760c4e56dd2f46b0976e3bc1fa1243d71 (patch)
tree21d92aea3ee6baaa86a270cee8965c295ce28754 /app-emulation/vice
parentVersion bump. (diff)
downloadgentoo-2-950f061760c4e56dd2f46b0976e3bc1fa1243d71.tar.gz
gentoo-2-950f061760c4e56dd2f46b0976e3bc1fa1243d71.tar.bz2
gentoo-2-950f061760c4e56dd2f46b0976e3bc1fa1243d71.zip
fix building with new automake (bug #467562)
(Portage version: 2.1.11.62/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-emulation/vice')
-rw-r--r--app-emulation/vice/ChangeLog8
-rw-r--r--app-emulation/vice/files/vice-2.4-autotools.patch11
-rw-r--r--app-emulation/vice/vice-2.4.ebuild9
3 files changed, 23 insertions, 5 deletions
diff --git a/app-emulation/vice/ChangeLog b/app-emulation/vice/ChangeLog
index e9cf399fd9c1..6b5092fd54d4 100644
--- a/app-emulation/vice/ChangeLog
+++ b/app-emulation/vice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/vice
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.90 2013/04/05 21:45:45 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.91 2013/05/10 04:53:42 mr_bones_ Exp $
+
+ 10 May 2013; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/vice-2.4-autotools.patch, files/vice-2.3-libav.patch,
+ files/vice-2.3-notexi.patch, files/vice-2.4-arm.patch,
+ files/vice-2.4-buffer.patch, files/vice-2.4-ffmpeg-1.patch, vice-2.4.ebuild:
+ fix building with new automake (bug #467562)
05 Apr 2013; Agostino Sarubbo <ago@gentoo.org> vice-2.4.ebuild:
Stable for x86, wrt bug #464624
diff --git a/app-emulation/vice/files/vice-2.4-autotools.patch b/app-emulation/vice/files/vice-2.4-autotools.patch
new file mode 100644
index 000000000000..f67113f0b45e
--- /dev/null
+++ b/app-emulation/vice/files/vice-2.4-autotools.patch
@@ -0,0 +1,11 @@
+--- vice-2.4.orig/configure.in
++++ vice-2.4/configure.in
+@@ -105,7 +105,7 @@
+ AC_SUBST(VICE_VERSION)
+
+ AM_INIT_AUTOMAKE(vice, $VICE_VERSION)
+-AM_CONFIG_HEADER(src/config.h)
++AC_CONFIG_HEADERS(src/config.h)
+
+ if test x"$VICE_VERSION_BUILD" = "x" -o x"$VICE_VERSION_BUILD" = "x0" ; then
+ VERSION_RC=$VICE_VERSION_MAJOR","$VICE_VERSION_MINOR",0,0"
diff --git a/app-emulation/vice/vice-2.4.ebuild b/app-emulation/vice/vice-2.4.ebuild
index c6585a727356..91b7f44157ec 100644
--- a/app-emulation/vice/vice-2.4.ebuild
+++ b/app-emulation/vice/vice-2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-2.4.ebuild,v 1.7 2013/04/05 21:45:45 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-2.4.ebuild,v 1.8 2013/05/10 04:53:42 mr_bones_ Exp $
EAPI=5
inherit autotools eutils toolchain-funcs games
@@ -61,7 +61,8 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-arm.patch \
"${FILESDIR}"/${P}-ffmpeg-1.patch \
- "${FILESDIR}"/${P}-buffer.patch
+ "${FILESDIR}"/${P}-buffer.patch \
+ "${FILESDIR}"/${P}-autotools.patch
sed -i \
-e "s:/usr/local/lib/VICE:${GAMES_DATADIR}/${PN}:" \
man/vice.1 \
@@ -69,13 +70,13 @@ src_prepare() {
|| die
sed -i \
-e "/VICEDIR=/s:=.*:=\"${GAMES_DATADIR}/${PN}\";:" \
- configure.in \
- || die
+ configure.in || die
sed -i \
-e "s:\(#define LIBDIR \).*:\1\"${GAMES_DATADIR}/${PN}\":" \
-e "s:\(#define DOCDIR \).*:\1\"/usr/share/doc/${PF}\":" \
src/arch/unix/archdep.h \
src/arch/sdl/archdep_unix.h
+ mv configure.in configure.ac || die
AT_NO_RECURSIVE=1 eautoreconf
}