summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-05-06 13:55:37 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-05-06 13:55:37 +0000
commit75f17e7ca73859aa6e2436770ec969439de8389a (patch)
tree10ba863185617d088f4cb090cf3328f84bbb0433 /app-emulation/virt-viewer
parentold (diff)
downloadgentoo-2-75f17e7ca73859aa6e2436770ec969439de8389a.tar.gz
gentoo-2-75f17e7ca73859aa6e2436770ec969439de8389a.tar.bz2
gentoo-2-75f17e7ca73859aa6e2436770ec969439de8389a.zip
Version bump. Switch exclusively to GTK3+ since the plugin is now gone.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key D7DFA8D318FA9AEF!)
Diffstat (limited to 'app-emulation/virt-viewer')
-rw-r--r--app-emulation/virt-viewer/ChangeLog7
-rw-r--r--app-emulation/virt-viewer/virt-viewer-0.5.6.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/app-emulation/virt-viewer/ChangeLog b/app-emulation/virt-viewer/ChangeLog
index 9dff306e3e83..6aa5e5fd1800 100644
--- a/app-emulation/virt-viewer/ChangeLog
+++ b/app-emulation/virt-viewer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/virt-viewer
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-viewer/ChangeLog,v 1.22 2013/02/17 19:13:10 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-viewer/ChangeLog,v 1.23 2013/05/06 13:55:37 cardoe Exp $
+
+*virt-viewer-0.5.6 (06 May 2013)
+
+ 06 May 2013; Doug Goldstein <cardoe@gentoo.org> +virt-viewer-0.5.6.ebuild:
+ Version bump. Switch exclusively to GTK3+ since the plugin is now gone.
*virt-viewer-0.5.5 (17 Feb 2013)
diff --git a/app-emulation/virt-viewer/virt-viewer-0.5.6.ebuild b/app-emulation/virt-viewer/virt-viewer-0.5.6.ebuild
new file mode 100644
index 000000000000..2237b71c8495
--- /dev/null
+++ b/app-emulation/virt-viewer/virt-viewer-0.5.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-viewer/virt-viewer-0.5.6.ebuild,v 1.1 2013/05/06 13:55:37 cardoe Exp $
+
+EAPI=5
+inherit eutils gnome2 toolchain-funcs
+
+DESCRIPTION="Graphical console client for connecting to virtual machines"
+HOMEPAGE="http://virt-manager.org/"
+SRC_URI="http://virt-manager.org/download/sources/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sasl +spice +vnc"
+
+RDEPEND=">=app-emulation/libvirt-0.10.0[sasl?]
+ >=dev-libs/libxml2-2.6
+ x11-libs/gtk+:3
+ spice? ( >=net-misc/spice-gtk-0.18[sasl?,gtk3] )
+ vnc? ( >=net-libs/gtk-vnc-0.5.0[sasl?,gtk3] )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ spice? ( >=app-emulation/spice-protocol-0.10.1 )"
+
+REQUIRED_USE="|| ( spice vnc )"
+
+pkg_setup() {
+ G2CONF="$(use_with vnc gtk-vnc) $(use_with spice spice-gtk)"
+ G2CONF="${G2CONF} --with-gtk=3.0"
+}
+
+src_prepare() {
+ epatch_user
+}
+
+src_test() {
+ default
+}
+
+src_install() {
+ default
+}