summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-18 04:26:28 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-18 04:26:28 +0000
commitc740bdb14494d2686060817ccf57e5239f362845 (patch)
tree5481243b565d4cb0d8c48a7aece713e33a67acd6 /app-emulation/vm-arm/vm-arm-1.0.2.ebuild
parentStablized 1.0.5 and added testing keyword to 1.9.13-r1 for SPARC. (diff)
downloadgentoo-2-c740bdb14494d2686060817ccf57e5239f362845.tar.gz
gentoo-2-c740bdb14494d2686060817ccf57e5239f362845.tar.bz2
gentoo-2-c740bdb14494d2686060817ccf57e5239f362845.zip
Version bump #93488 by Yuri Vasilevski.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-emulation/vm-arm/vm-arm-1.0.2.ebuild')
-rw-r--r--app-emulation/vm-arm/vm-arm-1.0.2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-emulation/vm-arm/vm-arm-1.0.2.ebuild b/app-emulation/vm-arm/vm-arm-1.0.2.ebuild
new file mode 100644
index 000000000000..a52f765e8000
--- /dev/null
+++ b/app-emulation/vm-arm/vm-arm-1.0.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vm-arm/vm-arm-1.0.2.ebuild,v 1.1 2005/08/18 04:26:28 vapier Exp $
+
+inherit eutils rpm
+
+# - Debian version is very old
+# - Redhat/Fedora ones link against funky ssl
+# - SuSe or MDK rpm's are the only ones that will really work
+RPM_VER="70.suse9_2"
+DESCRIPTION="highly optimized and accurate simulation of the ARM architecture"
+HOMEPAGE="http://www.virtera.com/"
+SRC_URI="vm-arm-se-${PV}-${RPM_VER}.i386.rpm"
+
+LICENSE="VIRTERA"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="fetch nostrip"
+
+DEPEND="=dev-libs/openssl-0.9.7*
+ =x11-libs/wxGTK-2.4*"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ if ! built_with_use x11-libs/wxGTK wxgtk1 ; then
+ eerror "Please emerge x11-libs/wxGTK-2.4 with wxgtk1 in USE flags."
+ die "GTK1 support in 11-libs/wxGTK-2.4 needed to run ${P}."
+ fi
+}
+
+pkg_nofetch() {
+ einfo "You need to perform the following steps to install this package:"
+ einfo " - Sign up at ${HOMEPAGE}"
+ einfo " - Check your email and visit the download location"
+ einfo " - Download ${A} and place it in ${DISTDIR}"
+ einfo " - emerge this package"
+ einfo " - Put your license in ~/.virtera/"
+}
+
+src_install() {
+ mv opt "${D}"/ || die
+ dodir /opt/bin
+ cd "${D}"
+ for x in opt/virtera/vm-arm-se-${PV}/bin/i686/* ; do
+ dosym /${x} /opt/bin/${x##*/}
+ done
+ find "${D}" -type d -exec chmod a+rx {} \;
+}
+
+pkg_postinst() {
+ einfo "Please remember to put your license in ~/.virtera/"
+}