summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-08-07 08:06:43 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-08-07 08:06:43 +0000
commit7515d888c246748d030a5d700bf5a2f8e183e26c (patch)
tree6fdcf003f3b3aaee2babf3120898a35c11a6afca /app-emulation/wine/files
parentMove compiler and linker flags to the front so that they actually work. Reall... (diff)
downloadgentoo-2-7515d888c246748d030a5d700bf5a2f8e183e26c.tar.gz
gentoo-2-7515d888c246748d030a5d700bf5a2f8e183e26c.tar.bz2
gentoo-2-7515d888c246748d030a5d700bf5a2f8e183e26c.zip
Bump, see http://www.winehq.org/announce/1.5.10 for the announcement, thanks to Rafał Mużyło (bug #429386). Note that on amd64, osmesa support is for now win64-only.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/wine/files')
-rw-r--r--app-emulation/wine/files/wine-1.5.10-osmesa-check.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emulation/wine/files/wine-1.5.10-osmesa-check.patch b/app-emulation/wine/files/wine-1.5.10-osmesa-check.patch
new file mode 100644
index 000000000000..86d90ca5bc4c
--- /dev/null
+++ b/app-emulation/wine/files/wine-1.5.10-osmesa-check.patch
@@ -0,0 +1,33 @@
+From a233e35ca650db2758de0fd31450b8ce2d86d5e3 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Tue, 7 Aug 2012 01:29:01 -0400
+Subject: [PATCH] Do not check for libGL symbols when checking libOSMesa
+
+If mesa had been built with shared glapi, glAccum is not available in
+libOSMesa without explicitly linking to libGL. In addition, in
+mesa-8.0.x and earlier, libOSMesa needs to be explicitly linked to
+libglapi if mesa was built with shared glapi, see
+https://bugs.gentoo.org/show_bug.cgi?id=399813
+---
+ configure.ac | 5 ++++-
+ 1 files changed, 4 insertions(+), 1 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 4bd43d1..c7a718f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1132,7 +1132,10 @@ This probably prevents linking to OpenGL. Try deleting the file and restarting c
+
+ if test "$ac_cv_header_GL_osmesa_h" = "yes"
+ then
+- WINE_CHECK_SONAME(OSMesa,glAccum,,,[$X_LIBS $X_PRE_LIBS $XLIB -lm $X_EXTRA_LIBS])
++ WINE_CHECK_SONAME(OSMesa,OSMesaCreateContext,,,[$X_LIBS $X_PRE_LIBS $XLIB -lm $X_EXTRA_LIBS])
++ if test "x$ac_cv_lib_soname_OSMesa" = "x"; then
++ WINE_CHECK_SONAME(OSMesa,OSMesaCreateContext,,,[-lglapi $X_LIBS $X_PRE_LIBS $XLIB -lm $X_EXTRA_LIBS])
++ fi
+ fi
+ WINE_NOTICE_WITH(osmesa,[test "x$ac_cv_lib_soname_OSMesa" = "x"],
+ [libOSMesa ${notice_platform}development files not found (or too old), OpenGL rendering in bitmaps won't be supported.])
+--
+1.7.8.6
+