summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-11-19 09:03:23 +0000
committerMike Frysinger <vapier@gentoo.org>2010-11-19 09:03:23 +0000
commit9404503fc5433720b229e06f2f419f3e5529cfed (patch)
tree98b7b43034cc06ad2b305790a8ad3bb05bc09589 /app-emulation/wine/wine-9999.ebuild
parentCleaned DESCRIPTION to fit ebuild writing guide lines (diff)
downloadgentoo-2-9404503fc5433720b229e06f2f419f3e5529cfed.tar.gz
gentoo-2-9404503fc5433720b229e06f2f419f3e5529cfed.tar.bz2
gentoo-2-9404503fc5433720b229e06f2f419f3e5529cfed.zip
Add support for USE=gstreamer #345917 by Zorzo Luca.
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/wine/wine-9999.ebuild')
-rw-r--r--app-emulation/wine/wine-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index 4482208716c8..57cd67f59b9d 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.65 2010/11/07 21:57:52 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.66 2010/11/19 09:03:23 vapier Exp $
EAPI="2"
@@ -33,7 +33,7 @@ SRC_URI="${SRC_URI}
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="alsa capi cups custom-cflags dbus esd fontconfig +gecko gnutls gphoto2 gsm hal jack jpeg lcms ldap mp3 nas ncurses openal +opengl +oss +perl png pulseaudio samba scanner ssl test +threads +truetype +win32 +win64 +X xcomposite xinerama xml"
+IUSE="alsa capi cups custom-cflags dbus esd fontconfig +gecko gnutls gphoto2 gsm gstreamer hal jack jpeg lcms ldap mp3 nas ncurses openal +opengl +oss +perl png pulseaudio samba scanner ssl test +threads +truetype +win32 +win64 +X xcomposite xinerama xml"
RESTRICT="test" #72375
MLIB_DEPS="amd64? (
@@ -57,6 +57,7 @@ RDEPEND="truetype? ( >=media-libs/freetype-2.0.0 media-fonts/corefonts )
openal? ( media-libs/openal )
dbus? ( sys-apps/dbus )
gnutls? ( net-libs/gnutls )
+ gstreamer? ( media-libs/gstreamer media-libs/gst-plugins-base )
hal? ( sys-apps/hal )
X? (
x11-libs/libXcursor
@@ -138,6 +139,7 @@ do_configure() {
$(use_with gnutls) \
$(use_with gphoto2 gphoto) \
$(use_with gsm) \
+ $(use_with gstreamer) \
$(! use dbus && echo --without-hal || use_with hal) \
$(use_with jack) \
$(use_with jpeg) \