summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-25 00:03:11 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-25 00:03:11 +0000
commit56d3198651ed51513885af28269db0a65bc9404a (patch)
tree3d6905cbff52fc6d3802b040b8dd35ce0a626936 /app-emulation/wine
parentcleanup ebuild (diff)
downloadgentoo-2-56d3198651ed51513885af28269db0a65bc9404a.tar.gz
gentoo-2-56d3198651ed51513885af28269db0a65bc9404a.tar.bz2
gentoo-2-56d3198651ed51513885af28269db0a65bc9404a.zip
Add patch to fix DirectDrawGammaControl errors #119931 by David.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'app-emulation/wine')
-rw-r--r--app-emulation/wine/ChangeLog6
-rw-r--r--app-emulation/wine/files/wine-0.9.6-force-ddraw-gamma.patch27
-rw-r--r--app-emulation/wine/wine-0.9.6.ebuild3
3 files changed, 34 insertions, 2 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index a6b18610b82a..ab4ced10e192 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/wine
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.122 2006/01/20 11:56:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.123 2006/01/25 00:03:11 vapier Exp $
+
+ 25 Jan 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/wine-0.9.6-force-ddraw-gamma.patch, wine-0.9.6.ebuild:
+ Add patch to fix DirectDrawGammaControl errors #119931 by David.
*wine-0.9.6 (20 Jan 2006)
diff --git a/app-emulation/wine/files/wine-0.9.6-force-ddraw-gamma.patch b/app-emulation/wine/files/wine-0.9.6-force-ddraw-gamma.patch
new file mode 100644
index 000000000000..120a38f210ef
--- /dev/null
+++ b/app-emulation/wine/files/wine-0.9.6-force-ddraw-gamma.patch
@@ -0,0 +1,27 @@
+Always return DD_OK instead of actual result
+
+http://bugs.winehq.org/show_bug.cgi?id=3192
+http://bugs.gentoo.org/119931
+
+--- dlls/ddraw/surface_gamma.c
++++ dlls/ddraw/surface_gamma.c
+@@ -58,7 +58,8 @@
+ {
+ ICOM_THIS_FROM(IDirectDrawSurfaceImpl, IDirectDrawGammaControl, iface);
+ TRACE("(%p)->(%08lx,%p)\n", iface,dwFlags,lpGammaRamp);
+- return This->get_gamma_ramp(This, dwFlags, lpGammaRamp);
++ This->get_gamma_ramp(This, dwFlags, lpGammaRamp);
++ return DD_OK;
+ }
+
+ static HRESULT WINAPI
+@@ -66,7 +67,8 @@
+ {
+ ICOM_THIS_FROM(IDirectDrawSurfaceImpl, IDirectDrawGammaControl, iface);
+ TRACE("(%p)->(%08lx,%p)\n", iface,dwFlags,lpGammaRamp);
+- return This->set_gamma_ramp(This, dwFlags, lpGammaRamp);
++ This->set_gamma_ramp(This, dwFlags, lpGammaRamp);
++ return DD_OK;
+ }
+
+ const IDirectDrawGammaControlVtbl DDRAW_IDDGC_VTable =
diff --git a/app-emulation/wine/wine-0.9.6.ebuild b/app-emulation/wine/wine-0.9.6.ebuild
index a10b3b964af0..ba1209d0981b 100644
--- a/app-emulation/wine/wine-0.9.6.ebuild
+++ b/app-emulation/wine/wine-0.9.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.6.ebuild,v 1.2 2006/01/20 13:34:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.6.ebuild,v 1.3 2006/01/25 00:03:11 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -80,6 +80,7 @@ src_unpack() {
unpack wine-${PV}.tar.bz2
cd "${S}"
+ epatch "${FILESDIR}"/wine-0.9.6-force-ddraw-gamma.patch #119931
epatch "${FILESDIR}"/wine-20050524-alsa-headers.patch
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in