summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-06-15 17:54:59 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-06-15 17:54:59 +0000
commit8b77c431d7f208d8fecd315b7ac6db4737cfbe57 (patch)
tree5f7e94aef91c451636687ce30b01456fe10ca247 /app-emulation/wine
parent Typo in pkg_postinst() (diff)
downloadgentoo-2-8b77c431d7f208d8fecd315b7ac6db4737cfbe57.tar.gz
gentoo-2-8b77c431d7f208d8fecd315b7ac6db4737cfbe57.tar.bz2
gentoo-2-8b77c431d7f208d8fecd315b7ac6db4737cfbe57.zip
fixed an install of stuff into /etc/wine so it works
Diffstat (limited to 'app-emulation/wine')
-rw-r--r--app-emulation/wine/ChangeLog9
-rw-r--r--app-emulation/wine/files/digest-wine-20020605-r21
-rw-r--r--app-emulation/wine/wine-20020605-r2.ebuild97
3 files changed, 106 insertions, 1 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index f0ecec5455f9..0958a582bcde 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,7 +1,14 @@
# ChangeLog for app-emulation/wine
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.10 2002/06/14 13:43:28 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.11 2002/06/15 17:54:59 spider Exp $
+
+*wine-20020605-r2 (15 Jun 2002)
+ 15 Jun 2002 ;Spider <spider@gentoo.org> wine-20020605-r2.ebuild :
+ the /etc/wine stuff wasn't installed so I fixed that (seems the source had moved into documentation/samples )
+
+
+
*wine-20020605-r1 (14 Jun 2002)
14 Jun 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
diff --git a/app-emulation/wine/files/digest-wine-20020605-r2 b/app-emulation/wine/files/digest-wine-20020605-r2
new file mode 100644
index 000000000000..70e8f9b2efd3
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20020605-r2
@@ -0,0 +1 @@
+MD5 416ca5a002a3286953afc77bee20a9da Wine-20020605.tar.gz 7242801
diff --git a/app-emulation/wine/wine-20020605-r2.ebuild b/app-emulation/wine/wine-20020605-r2.ebuild
new file mode 100644
index 000000000000..605b149d5349
--- /dev/null
+++ b/app-emulation/wine/wine-20020605-r2.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20020605-r2.ebuild,v 1.1 2002/06/15 17:54:59 spider Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Wine is a free implementation of Windows on Unix."
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-${PV}.tar.gz"
+HOMEPAGE="http://www.winehq.com/"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ sys-devel/gcc
+ sys-devel/flex
+ dev-util/yacc
+ opengl? ( virtual/opengl )
+ >=sys-libs/ncurses-5.2
+ cups? ( net-print/cups )
+ >=media-libs/freetype-2.0.0
+ dev-lang/tcl dev-lang/tk"
+
+src_compile() {
+
+ cd ${S}
+ local myconf
+
+ use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
+ [ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
+ # there's no configure flag for cups, it's supposed to be autodetected
+
+ # the folks at #winehq were really angry about custom optimization
+ export CFLAGS=""
+ export CXXFLAGS=""
+
+ ./configure --prefix=/usr \
+ --exec_prefix=/usr/wine \
+ --sysconfdir=/etc/wine \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --enable-curses \
+ ${myconf} || die
+
+ cd ${S}/programs/winetest
+ cp Makefile 1
+ sed -e 's:wine.pm:include/wine.pm:' 1 > Makefile
+
+ cd ${S}
+ make depend all || die
+ cd programs && emake || die
+
+}
+
+src_install () {
+
+ local WINEMAKEOPTS="prefix=${D}/usr \
+ mandir=${D}/usr/wine/man \
+ includedir=${D}/usr/wine/include \
+ exec_prefix=${D}/usr/wine"
+
+ cd ${S}
+ make ${WINEMAKEOPTS} install || die
+ cd ${S}/programs
+ make ${WINEMAKEOPTS} install || die
+
+ # these .so's are strange. they are from the make in programs/ above,
+ # and are for apps built with winelib (windows sources built directly
+ # against wine). Apparently the sources go into a <program name>.so file
+ # and you run it via a symlink <program name> -> wine. Unfortunately both
+ # the symlink and the .so apparently must reside in /usr/bin.
+ cd ${D}/usr/wine/bin
+ chmod a-x *.so
+
+ cd ${S}
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
+
+ insinto /etc/wine
+ doins documentation/samples/*
+ doins ${S}/winedefault.reg
+
+ dodir /etc/skel/.wine
+ dosym /etc/wine/config /etc/skel/.wine/config
+
+ insinto /etc/env.d
+ doins ${FILESDIR}/80wine
+}
+
+pkg_postinst() {
+
+ einfo "If you are installing wine for the first time,
+copy /etc/wine/config (global configuration) to ~/.wine/config
+and edit that for per-user configuration. Otherwise, wine will
+not run.
+Also, run \"regapi setValue < /etc/wine/winedefault.reg\" to setup
+per-user registry for using wine. More info in /usr/share/doc/wine-${PV}."
+
+}
+