summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-17 02:06:09 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-17 02:06:09 +0000
commit9656ba16e427b538389f07ed87fe7f2edc29b8e3 (patch)
treee9aca9f547994ee70ce8651ea5b6fedd65e23ac3 /app-emulation/wine
parentStable on x86 per security bug #91785 (diff)
downloadgentoo-2-9656ba16e427b538389f07ed87fe7f2edc29b8e3.tar.gz
gentoo-2-9656ba16e427b538389f07ed87fe7f2edc29b8e3.tar.bz2
gentoo-2-9656ba16e427b538389f07ed87fe7f2edc29b8e3.zip
add -m32 to CFLAGS with 2004.3 amd64 #96132
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-emulation/wine')
-rw-r--r--app-emulation/wine/wine-20050211.ebuild26
-rw-r--r--app-emulation/wine/wine-20050310-r1.ebuild26
-rw-r--r--app-emulation/wine/wine-20050419.ebuild24
-rw-r--r--app-emulation/wine/wine-20050524.ebuild24
4 files changed, 54 insertions, 46 deletions
diff --git a/app-emulation/wine/wine-20050211.ebuild b/app-emulation/wine/wine-20050211.ebuild
index 84a70f7bda36..6a46940df069 100644
--- a/app-emulation/wine/wine-20050211.ebuild
+++ b/app-emulation/wine/wine-20050211.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050211.ebuild,v 1.10 2005/05/29 03:48:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050211.ebuild,v 1.11 2005/06/17 02:06:08 vapier Exp $
inherit eutils flag-o-matic
@@ -39,16 +39,12 @@ DEPEND="${RDEPEND}
sys-devel/flex"
pkg_setup() {
- if use amd64 ; then
- if ! has_m32; then
- eerror "Your compiler seems to be unable to compile 32bit code."
- eerror "Make sure you compile gcc with:"
- echo
- eerror " USE=multilib FEATURES=-sandbox"
- die "Cannot produce 32bit code"
- else
- export ABI=x86
- fi
+ if use amd64 && ! has_m32 ; then
+ eerror "Your compiler seems to be unable to compile 32bit code."
+ eerror "Make sure you compile gcc with:"
+ echo
+ eerror " USE=multilib FEATURES=-sandbox"
+ die "Cannot produce 32bit code"
fi
}
@@ -87,7 +83,13 @@ src_compile() {
config_cache lcms header_lcms_h
strip-flags
- use lcms && append-flags -I${ROOT}/usr/include/lcms
+ use lcms && append-flags -I"${ROOT}"/usr/include/lcms
+
+ if use amd64 ; then
+ [[ -n $(get_abi_var) ]] \
+ && export ABI=x86 \
+ || append-flags -m32
+ fi
if ! built_with_use app-text/docbook-sgml-utils tetex ; then
export DB2PDF=true
diff --git a/app-emulation/wine/wine-20050310-r1.ebuild b/app-emulation/wine/wine-20050310-r1.ebuild
index 95c1bd74d3f9..ed9ca21e0297 100644
--- a/app-emulation/wine/wine-20050310-r1.ebuild
+++ b/app-emulation/wine/wine-20050310-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050310-r1.ebuild,v 1.3 2005/05/29 03:48:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050310-r1.ebuild,v 1.4 2005/06/17 02:06:08 vapier Exp $
inherit eutils flag-o-matic
@@ -39,16 +39,12 @@ DEPEND="${RDEPEND}
sys-devel/flex"
pkg_setup() {
- if use amd64 ; then
- if ! has_m32; then
- eerror "Your compiler seems to be unable to compile 32bit code."
- eerror "Make sure you compile gcc with:"
- echo
- eerror " USE=multilib FEATURES=-sandbox"
- die "Cannot produce 32bit code"
- else
- export ABI=x86
- fi
+ if use amd64 && ! has_m32 ; then
+ eerror "Your compiler seems to be unable to compile 32bit code."
+ eerror "Make sure you compile gcc with:"
+ echo
+ eerror " USE=multilib FEATURES=-sandbox"
+ die "Cannot produce 32bit code"
fi
}
@@ -86,7 +82,13 @@ src_compile() {
config_cache lcms header_lcms_h
strip-flags
- use lcms && append-flags -I${ROOT}/usr/include/lcms
+ use lcms && append-flags -I"${ROOT}"/usr/include/lcms
+
+ if use amd64 ; then
+ [[ -n $(get_abi_var) ]] \
+ && export ABI=x86 \
+ || append-flags -m32
+ fi
if ! built_with_use app-text/docbook-sgml-utils tetex ; then
export DB2PDF=true
diff --git a/app-emulation/wine/wine-20050419.ebuild b/app-emulation/wine/wine-20050419.ebuild
index 7334b142a4a0..7b626b023325 100644
--- a/app-emulation/wine/wine-20050419.ebuild
+++ b/app-emulation/wine/wine-20050419.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050419.ebuild,v 1.5 2005/05/29 03:48:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050419.ebuild,v 1.6 2005/06/17 02:06:09 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -39,16 +39,12 @@ DEPEND="${RDEPEND}
sys-devel/flex"
pkg_setup() {
- if use amd64 ; then
- if ! has_m32; then
- eerror "Your compiler seems to be unable to compile 32bit code."
- eerror "Make sure you compile gcc with:"
- echo
- eerror " USE=multilib FEATURES=-sandbox"
- die "Cannot produce 32bit code"
- else
- export ABI=x86
- fi
+ if use amd64 && ! has_m32 ; then
+ eerror "Your compiler seems to be unable to compile 32bit code."
+ eerror "Make sure you compile gcc with:"
+ echo
+ eerror " USE=multilib FEATURES=-sandbox"
+ die "Cannot produce 32bit code"
fi
}
@@ -87,6 +83,12 @@ src_compile() {
strip-flags
use lcms && append-flags -I"${ROOT}"/usr/include/lcms
+ if use amd64 ; then
+ [[ -n $(get_abi_var) ]] \
+ && export ABI=x86 \
+ || append-flags -m32
+ fi
+
if ! built_with_use app-text/docbook-sgml-utils tetex ; then
export DB2PDF=true
export DB2PS=true
diff --git a/app-emulation/wine/wine-20050524.ebuild b/app-emulation/wine/wine-20050524.ebuild
index ac8f757ee3df..fd7e50819084 100644
--- a/app-emulation/wine/wine-20050524.ebuild
+++ b/app-emulation/wine/wine-20050524.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050524.ebuild,v 1.3 2005/05/29 03:48:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050524.ebuild,v 1.4 2005/06/17 02:06:09 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -39,16 +39,12 @@ DEPEND="${RDEPEND}
# doc? ( app-text/docbook-sgml-utils app-text/jadetex )
pkg_setup() {
- if use amd64 ; then
- if ! has_m32; then
- eerror "Your compiler seems to be unable to compile 32bit code."
- eerror "Make sure you compile gcc with:"
- echo
- eerror " USE=multilib FEATURES=-sandbox"
- die "Cannot produce 32bit code"
- else
- export ABI=x86
- fi
+ if use amd64 && ! has_m32 ; then
+ eerror "Your compiler seems to be unable to compile 32bit code."
+ eerror "Make sure you compile gcc with:"
+ echo
+ eerror " USE=multilib FEATURES=-sandbox"
+ die "Cannot produce 32bit code"
fi
}
@@ -87,6 +83,12 @@ src_compile() {
strip-flags
use lcms && append-flags -I"${ROOT}"/usr/include/lcms
+ if use amd64 ; then
+ [[ -n $(get_abi_var) ]] \
+ && export ABI=x86 \
+ || append-flags -m32
+ fi
+
# if ! built_with_use app-text/docbook-sgml-utils tetex ; then
# export DB2PDF=true
# export DB2PS=true