summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2013-12-17 12:33:14 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2013-12-17 12:33:14 +0000
commitab3593d9ed5cd1b7cb55c4af35c3a2b4698950ed (patch)
tree6e8ae856bd44b8508ac878cb87f1775d35d200e9 /app-emulation/wine
parentVersion bump. (diff)
downloadgentoo-2-ab3593d9ed5cd1b7cb55c4af35c3a2b4698950ed.tar.gz
gentoo-2-ab3593d9ed5cd1b7cb55c4af35c3a2b4698950ed.tar.bz2
gentoo-2-ab3593d9ed5cd1b7cb55c4af35c3a2b4698950ed.zip
Fix dependencies and ensure NATIVE_DEPEND is always considered in DEPEND (bug #492986, thanks to Jeffrey Thomas Piercy and Nikos Chantziaras).
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'app-emulation/wine')
-rw-r--r--app-emulation/wine/ChangeLog8
-rw-r--r--app-emulation/wine/wine-1.6.1.ebuild19
-rw-r--r--app-emulation/wine/wine-1.6.ebuild28
-rw-r--r--app-emulation/wine/wine-1.7.0.ebuild28
-rw-r--r--app-emulation/wine/wine-1.7.3.ebuild28
-rw-r--r--app-emulation/wine/wine-1.7.4.ebuild33
-rw-r--r--app-emulation/wine/wine-1.7.8.ebuild19
-rw-r--r--app-emulation/wine/wine-9999.ebuild19
8 files changed, 87 insertions, 95 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index d5fe7b2bf0d1..47ff6ba5f90c 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/wine
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.488 2013/12/16 14:31:56 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.489 2013/12/17 12:33:14 tetromino Exp $
+
+ 17 Dec 2013; Alexandre Rostovtsev <tetromino@gentoo.org> wine-1.6.ebuild,
+ wine-1.6.1.ebuild, wine-1.7.0.ebuild, wine-1.7.3.ebuild, wine-1.7.4.ebuild,
+ wine-1.7.8.ebuild, wine-9999.ebuild:
+ Fix dependencies and ensure NATIVE_DEPEND is always considered in DEPEND (bug
+ #492986, thanks to Jeffrey Thomas Piercy and Nikos Chantziaras).
16 Dec 2013; Alexandre Rostovtsev <tetromino@gentoo.org> wine-1.7.8.ebuild,
wine-9999.ebuild:
diff --git a/app-emulation/wine/wine-1.6.1.ebuild b/app-emulation/wine/wine-1.6.1.ebuild
index ab4849778278..734602ac6a36 100644
--- a/app-emulation/wine/wine-1.6.1.ebuild
+++ b/app-emulation/wine/wine-1.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.6.1.ebuild,v 1.1 2013/12/16 00:28:21 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.6.1.ebuild,v 1.2 2013/12/17 12:33:14 tetromino Exp $
EAPI="5"
@@ -34,7 +34,7 @@ SRC_URI="${SRC_URI}
abi_x86_64? ( mirror://sourceforge/${PN}/Wine%20Gecko/${GV}/wine_gecko-${GV}-x86_64.msi )
)
mono? ( mirror://sourceforge/${PN}/Wine%20Mono/${MV}/wine-mono-${MV}.msi )
- http://dev.gentoo.org/~tetromino/distfiles/${PN}/${PULSE_PATCHES}.tar.bz2
+ pulseaudio? ( http://dev.gentoo.org/~tetromino/distfiles/${PN}/${PULSE_PATCHES}.tar.bz2 )
http://dev.gentoo.org/~tetromino/distfiles/${PN}/${WINE_GENTOO}.tar.bz2"
LICENSE="LGPL-2.1"
@@ -172,6 +172,10 @@ COMMON_DEPEND="
>=app-emulation/emul-linux-x86-opengl-20121028[development]
media-libs/mesa[osmesa,abi_x86_32]
) )
+ pulseaudio? ( || (
+ app-emulation/emul-linux-x86-soundlibs[development]
+ >=media-sound/pulseaudio-4.0-r1[abi_x86_32]
+ ) )
xml? ( >=app-emulation/emul-linux-x86-baselibs-20130224[development] )
scanner? ( app-emulation/emul-linux-x86-medialibs[development] )
ssl? ( app-emulation/emul-linux-x86-baselibs[development] )
@@ -189,24 +193,17 @@ COMMON_DEPEND="
) )
)
)"
-[[ ${PV} == "9999" ]] || COMMON_DEPEND="${COMMON_DEPEND}
- amd64? ( abi_x86_32? ( pulseaudio? (
- || (
- app-emulation/emul-linux-x86-soundlibs[development]
- >=media-sound/pulseaudio-4.0-r1[abi_x86_32]
- )
- ) ) )"
RDEPEND="${COMMON_DEPEND}
dos? ( games-emulation/dosbox )
perl? ( dev-lang/perl dev-perl/XML-Simple )
samba? ( >=net-fs/samba-3.0.25 )
selinux? ( sec-policy/selinux-wine )
- udisks? ( sys-fs/udisks:2 )"
-[[ ${PV} == "9999" ]] || RDEPEND="${RDEPEND}
+ udisks? ( sys-fs/udisks:2 )
pulseaudio? ( realtime? ( sys-auth/rtkit ) )"
DEPEND="${COMMON_DEPEND}
+ amd64? ( abi_x86_32? ( !abi_x86_64? ( ${NATIVE_DEPEND} ) ) )
X? (
x11-proto/inputproto
x11-proto/xextproto
diff --git a/app-emulation/wine/wine-1.6.ebuild b/app-emulation/wine/wine-1.6.ebuild
index 68553906c0b6..148277fe9668 100644
--- a/app-emulation/wine/wine-1.6.ebuild
+++ b/app-emulation/wine/wine-1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.6.ebuild,v 1.10 2013/10/15 17:53:38 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.6.ebuild,v 1.11 2013/12/17 12:33:14 tetromino Exp $
EAPI="5"
@@ -39,8 +39,7 @@ SRC_URI="${SRC_URI}
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags dos elibc_glibc +fontconfig +gecko gphoto2 gsm gstreamer +jpeg lcms ldap +mono mp3 ncurses nls odbc openal opencl +opengl osmesa oss +perl +png +prelink +run-exes samba scanner selinux +ssl test +threads +truetype +udisks v4l +X xcomposite xinerama +xml"
-[[ ${PV} == "9999" ]] || IUSE="${IUSE} pulseaudio"
+IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags dos elibc_glibc +fontconfig +gecko gphoto2 gsm gstreamer +jpeg lcms ldap +mono mp3 ncurses nls odbc openal opencl +opengl osmesa oss +perl +png +prelink pulseaudio +run-exes samba scanner selinux +ssl test +threads +truetype +udisks v4l +X xcomposite xinerama +xml"
REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
test? ( abi_x86_32 )
elibc_glibc? ( threads )
@@ -85,14 +84,13 @@ NATIVE_DEPEND="
nls? ( sys-devel/gettext )
odbc? ( dev-db/unixODBC:= )
osmesa? ( media-libs/mesa[osmesa] )
+ pulseaudio? ( media-sound/pulseaudio )
xml? ( dev-libs/libxml2 dev-libs/libxslt )
scanner? ( media-gfx/sane-backends:= )
ssl? ( net-libs/gnutls:= )
png? ( media-libs/libpng:0= )
v4l? ( media-libs/libv4l )
xcomposite? ( x11-libs/libXcomposite )"
-[[ ${PV} == "9999" ]] || NATIVE_DEPEND="${NATIVE_DEPEND}
- pulseaudio? ( media-sound/pulseaudio )"
COMMON_DEPEND="
!amd64? ( ${NATIVE_DEPEND} )
@@ -107,7 +105,10 @@ COMMON_DEPEND="
app-emulation/emul-linux-x86-baselibs[development]
sys-libs/ncurses[abi_x86_32]
) )
- udisks? ( >=app-emulation/emul-linux-x86-baselibs-20130224[development] )
+ udisks? ( || (
+ >=app-emulation/emul-linux-x86-baselibs-20130224[development]
+ sys-apps/dbus[abi_x86_32]
+ ) )
fontconfig? ( || (
app-emulation/emul-linux-x86-xlibs[development]
media-libs/fontconfig[abi_x86_32]
@@ -175,6 +176,10 @@ COMMON_DEPEND="
>=app-emulation/emul-linux-x86-opengl-20121028[development]
media-libs/mesa[osmesa,abi_x86_32]
) )
+ pulseaudio? ( || (
+ app-emulation/emul-linux-x86-soundlibs[development]
+ >=media-sound/pulseaudio-4.0-r1[abi_x86_32]
+ ) )
xml? ( >=app-emulation/emul-linux-x86-baselibs-20130224[development] )
scanner? ( app-emulation/emul-linux-x86-medialibs[development] )
ssl? ( app-emulation/emul-linux-x86-baselibs[development] )
@@ -192,19 +197,17 @@ COMMON_DEPEND="
) )
)
)"
-[[ ${PV} == "9999" ]] || COMMON_DEPEND="${COMMON_DEPEND}
- amd64? ( abi_x86_32? ( pulseaudio? ( app-emulation/emul-linux-x86-soundlibs[development] ) ) )"
RDEPEND="${COMMON_DEPEND}
dos? ( games-emulation/dosbox )
perl? ( dev-lang/perl dev-perl/XML-Simple )
samba? ( >=net-fs/samba-3.0.25 )
selinux? ( sec-policy/selinux-wine )
- udisks? ( sys-fs/udisks:2 )"
-[[ ${PV} == "9999" ]] || RDEPEND="${RDEPEND}
+ udisks? ( sys-fs/udisks:2 )
pulseaudio? ( sys-auth/rtkit )"
DEPEND="${COMMON_DEPEND}
+ amd64? ( abi_x86_32? ( !abi_x86_64? ( ${NATIVE_DEPEND} ) ) )
X? (
x11-proto/inputproto
x11-proto/xextproto
@@ -269,8 +272,6 @@ src_prepare() {
"${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
"${FILESDIR}"/${PN}-1.5.17-osmesa-check.patch #429386
"${FILESDIR}"/${PN}-1.6-memset-O3.patch #480508
- )
- [[ ${PV} == "9999" ]] || PATCHES+=(
"../${PULSE_PATCHES}"/*.patch #421365
)
@@ -336,6 +337,7 @@ src_configure() {
$(use_with osmesa)
$(use_with oss)
$(use_with png)
+ $(use_with pulseaudio pulse)
$(use_with threads pthread)
$(use_with scanner sane)
$(use_enable test tests)
@@ -348,8 +350,6 @@ src_configure() {
$(use_with xml xslt)
)
- [[ ${PV} == "9999" ]] || myeconfargs+=( $(use_with pulseaudio pulse) )
-
if use amd64 && use abi_x86_32; then
# Avoid crossdev's i686-pc-linux-gnu-pkg-config if building wine32 on amd64; #472038
# set AR and RANLIB to make QA scripts happy; #483342
diff --git a/app-emulation/wine/wine-1.7.0.ebuild b/app-emulation/wine/wine-1.7.0.ebuild
index 7d3523cf7575..3156e464e032 100644
--- a/app-emulation/wine/wine-1.7.0.ebuild
+++ b/app-emulation/wine/wine-1.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.7.0.ebuild,v 1.6 2013/10/15 17:53:38 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.7.0.ebuild,v 1.7 2013/12/17 12:33:14 tetromino Exp $
EAPI="5"
@@ -39,8 +39,7 @@ SRC_URI="${SRC_URI}
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags dos elibc_glibc +fontconfig +gecko gphoto2 gsm gstreamer +jpeg lcms ldap +mono mp3 ncurses nls odbc openal opencl +opengl osmesa oss +perl +png +prelink +run-exes samba scanner selinux +ssl test +threads +truetype +udisks v4l +X xcomposite xinerama +xml"
-[[ ${PV} == "9999" ]] || IUSE="${IUSE} pulseaudio"
+IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags dos elibc_glibc +fontconfig +gecko gphoto2 gsm gstreamer +jpeg lcms ldap +mono mp3 ncurses nls odbc openal opencl +opengl osmesa oss +perl +png +prelink pulseaudio +run-exes samba scanner selinux +ssl test +threads +truetype +udisks v4l +X xcomposite xinerama +xml"
REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
test? ( abi_x86_32 )
elibc_glibc? ( threads )
@@ -85,14 +84,13 @@ NATIVE_DEPEND="
nls? ( sys-devel/gettext )
odbc? ( dev-db/unixODBC:= )
osmesa? ( media-libs/mesa[osmesa] )
+ pulseaudio? ( media-sound/pulseaudio )
xml? ( dev-libs/libxml2 dev-libs/libxslt )
scanner? ( media-gfx/sane-backends:= )
ssl? ( net-libs/gnutls:= )
png? ( media-libs/libpng:0= )
v4l? ( media-libs/libv4l )
xcomposite? ( x11-libs/libXcomposite )"
-[[ ${PV} == "9999" ]] || NATIVE_DEPEND="${NATIVE_DEPEND}
- pulseaudio? ( media-sound/pulseaudio )"
COMMON_DEPEND="
!amd64? ( ${NATIVE_DEPEND} )
@@ -107,7 +105,10 @@ COMMON_DEPEND="
app-emulation/emul-linux-x86-baselibs[development]
sys-libs/ncurses[abi_x86_32]
) )
- udisks? ( >=app-emulation/emul-linux-x86-baselibs-20130224[development] )
+ udisks? ( || (
+ >=app-emulation/emul-linux-x86-baselibs-20130224[development]
+ sys-apps/dbus[abi_x86_32]
+ ) )
fontconfig? ( || (
app-emulation/emul-linux-x86-xlibs[development]
media-libs/fontconfig[abi_x86_32]
@@ -175,6 +176,10 @@ COMMON_DEPEND="
>=app-emulation/emul-linux-x86-opengl-20121028[development]
media-libs/mesa[osmesa,abi_x86_32]
) )
+ pulseaudio? ( || (
+ app-emulation/emul-linux-x86-soundlibs[development]
+ >=media-sound/pulseaudio-4.0-r1[abi_x86_32]
+ ) )
xml? ( >=app-emulation/emul-linux-x86-baselibs-20130224[development] )
scanner? ( app-emulation/emul-linux-x86-medialibs[development] )
ssl? ( app-emulation/emul-linux-x86-baselibs[development] )
@@ -192,19 +197,17 @@ COMMON_DEPEND="
) )
)
)"
-[[ ${PV} == "9999" ]] || COMMON_DEPEND="${COMMON_DEPEND}
- amd64? ( abi_x86_32? ( pulseaudio? ( app-emulation/emul-linux-x86-soundlibs[development] ) ) )"
RDEPEND="${COMMON_DEPEND}
dos? ( games-emulation/dosbox )
perl? ( dev-lang/perl dev-perl/XML-Simple )
samba? ( >=net-fs/samba-3.0.25 )
selinux? ( sec-policy/selinux-wine )
- udisks? ( sys-fs/udisks:2 )"
-[[ ${PV} == "9999" ]] || RDEPEND="${RDEPEND}
+ udisks? ( sys-fs/udisks:2 )
pulseaudio? ( sys-auth/rtkit )"
DEPEND="${COMMON_DEPEND}
+ amd64? ( abi_x86_32? ( !abi_x86_64? ( ${NATIVE_DEPEND} ) ) )
X? (
x11-proto/inputproto
x11-proto/xextproto
@@ -269,8 +272,6 @@ src_prepare() {
"${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
"${FILESDIR}"/${PN}-1.5.17-osmesa-check.patch #429386
"${FILESDIR}"/${PN}-1.6-memset-O3.patch #480508
- )
- [[ ${PV} == "9999" ]] || PATCHES+=(
"../${PULSE_PATCHES}"/*.patch #421365
)
@@ -336,6 +337,7 @@ src_configure() {
$(use_with osmesa)
$(use_with oss)
$(use_with png)
+ $(use_with pulseaudio pulse)
$(use_with threads pthread)
$(use_with scanner sane)
$(use_enable test tests)
@@ -348,8 +350,6 @@ src_configure() {
$(use_with xml xslt)
)
- [[ ${PV} == "9999" ]] || myeconfargs+=( $(use_with pulseaudio pulse) )
-
# Avoid crossdev's i686-pc-linux-gnu-pkg-config if building wine32 on amd64; #472038
use amd64 && use abi_x86_32 && tc-export PKG_CONFIG
diff --git a/app-emulation/wine/wine-1.7.3.ebuild b/app-emulation/wine/wine-1.7.3.ebuild
index d2d4475d227a..da2f2bcb71a5 100644
--- a/app-emulation/wine/wine-1.7.3.ebuild
+++ b/app-emulation/wine/wine-1.7.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.7.3.ebuild,v 1.3 2013/10/15 17:53:38 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.7.3.ebuild,v 1.4 2013/12/17 12:33:14 tetromino Exp $
EAPI="5"
@@ -39,8 +39,7 @@ SRC_URI="${SRC_URI}
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags dos elibc_glibc +fontconfig +gecko gphoto2 gsm gstreamer +jpeg lcms ldap +mono mp3 ncurses nls odbc openal opencl +opengl osmesa oss +perl +png +prelink +realtime +run-exes samba scanner selinux +ssl test +threads +truetype +udisks v4l +X xcomposite xinerama +xml"
-[[ ${PV} == "9999" ]] || IUSE="${IUSE} pulseaudio"
+IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags dos elibc_glibc +fontconfig +gecko gphoto2 gsm gstreamer +jpeg lcms ldap +mono mp3 ncurses nls odbc openal opencl +opengl osmesa oss +perl +png +prelink pulseaudio +realtime +run-exes samba scanner selinux +ssl test +threads +truetype +udisks v4l +X xcomposite xinerama +xml"
REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
test? ( abi_x86_32 )
elibc_glibc? ( threads )
@@ -83,14 +82,13 @@ NATIVE_DEPEND="
nls? ( sys-devel/gettext )
odbc? ( dev-db/unixODBC:= )
osmesa? ( media-libs/mesa[osmesa] )
+ pulseaudio? ( media-sound/pulseaudio )
xml? ( dev-libs/libxml2 dev-libs/libxslt )
scanner? ( media-gfx/sane-backends:= )
ssl? ( net-libs/gnutls:= )
png? ( media-libs/libpng:0= )
v4l? ( media-libs/libv4l )
xcomposite? ( x11-libs/libXcomposite )"
-[[ ${PV} == "9999" ]] || NATIVE_DEPEND="${NATIVE_DEPEND}
- pulseaudio? ( media-sound/pulseaudio )"
COMMON_DEPEND="
!amd64? ( ${NATIVE_DEPEND} )
@@ -105,7 +103,10 @@ COMMON_DEPEND="
app-emulation/emul-linux-x86-baselibs[development]
sys-libs/ncurses[abi_x86_32]
) )
- udisks? ( >=app-emulation/emul-linux-x86-baselibs-20130224[development] )
+ udisks? ( || (
+ >=app-emulation/emul-linux-x86-baselibs-20130224[development]
+ sys-apps/dbus[abi_x86_32]
+ ) )
fontconfig? ( || (
app-emulation/emul-linux-x86-xlibs[development]
media-libs/fontconfig[abi_x86_32]
@@ -171,6 +172,10 @@ COMMON_DEPEND="
>=app-emulation/emul-linux-x86-opengl-20121028[development]
media-libs/mesa[osmesa,abi_x86_32]
) )
+ pulseaudio? ( || (
+ app-emulation/emul-linux-x86-soundlibs[development]
+ >=media-sound/pulseaudio-4.0-r1[abi_x86_32]
+ ) )
xml? ( >=app-emulation/emul-linux-x86-baselibs-20131008[development] )
scanner? ( app-emulation/emul-linux-x86-medialibs[development] )
ssl? ( app-emulation/emul-linux-x86-baselibs[development] )
@@ -188,19 +193,17 @@ COMMON_DEPEND="
) )
)
)"
-[[ ${PV} == "9999" ]] || COMMON_DEPEND="${COMMON_DEPEND}
- amd64? ( abi_x86_32? ( pulseaudio? ( app-emulation/emul-linux-x86-soundlibs[development] ) ) )"
RDEPEND="${COMMON_DEPEND}
dos? ( games-emulation/dosbox )
perl? ( dev-lang/perl dev-perl/XML-Simple )
samba? ( >=net-fs/samba-3.0.25 )
selinux? ( sec-policy/selinux-wine )
- udisks? ( sys-fs/udisks:2 )"
-[[ ${PV} == "9999" ]] || RDEPEND="${RDEPEND}
+ udisks? ( sys-fs/udisks:2 )
pulseaudio? ( realtime? ( sys-auth/rtkit ) )"
DEPEND="${COMMON_DEPEND}
+ amd64? ( abi_x86_32? ( !abi_x86_64? ( ${NATIVE_DEPEND} ) ) )
X? (
x11-proto/inputproto
x11-proto/xextproto
@@ -265,8 +268,6 @@ src_prepare() {
"${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
"${FILESDIR}"/${PN}-1.7.2-osmesa-check.patch #429386
"${FILESDIR}"/${PN}-1.6-memset-O3.patch #480508
- )
- [[ ${PV} == "9999" ]] || PATCHES+=(
"../${PULSE_PATCHES}"/*.patch #421365
)
@@ -332,6 +333,7 @@ src_configure() {
$(use_with osmesa)
$(use_with oss)
$(use_with png)
+ $(use_with pulseaudio pulse)
$(use_with threads pthread)
$(use_with scanner sane)
$(use_enable test tests)
@@ -344,8 +346,6 @@ src_configure() {
$(use_with xml xslt)
)
- [[ ${PV} == "9999" ]] || myeconfargs+=( $(use_with pulseaudio pulse) )
-
if use amd64 && use abi_x86_32; then
# Avoid crossdev's i686-pc-linux-gnu-pkg-config if building wine32 on amd64; #472038
# set AR and RANLIB to make QA scripts happy; #483342
diff --git a/app-emulation/wine/wine-1.7.4.ebuild b/app-emulation/wine/wine-1.7.4.ebuild
index 21444eedd679..0d89b1002a5a 100644
--- a/app-emulation/wine/wine-1.7.4.ebuild
+++ b/app-emulation/wine/wine-1.7.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.7.4.ebuild,v 1.4 2013/12/01 09:45:09 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.7.4.ebuild,v 1.5 2013/12/17 12:33:14 tetromino Exp $
EAPI="5"
@@ -39,8 +39,7 @@ SRC_URI="${SRC_URI}
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags dos elibc_glibc +fontconfig +gecko gphoto2 gsm gstreamer +jpeg lcms ldap +mono mp3 ncurses nls odbc openal opencl +opengl osmesa oss +perl +png +prelink +realtime +run-exes samba scanner selinux +ssl test +threads +truetype +udisks v4l +X xcomposite xinerama +xml"
-[[ ${PV} == "9999" ]] || IUSE="${IUSE} pulseaudio"
+IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags dos elibc_glibc +fontconfig +gecko gphoto2 gsm gstreamer +jpeg lcms ldap +mono mp3 ncurses nls odbc openal opencl +opengl osmesa oss +perl +png +prelink pulseaudio +realtime +run-exes samba scanner selinux +ssl test +threads +truetype +udisks v4l +X xcomposite xinerama +xml"
REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
test? ( abi_x86_32 )
elibc_glibc? ( threads )
@@ -83,14 +82,13 @@ NATIVE_DEPEND="
nls? ( sys-devel/gettext )
odbc? ( dev-db/unixODBC:= )
osmesa? ( media-libs/mesa[osmesa] )
+ pulseaudio? ( media-sound/pulseaudio )
xml? ( dev-libs/libxml2 dev-libs/libxslt )
scanner? ( media-gfx/sane-backends:= )
ssl? ( net-libs/gnutls:= )
png? ( media-libs/libpng:0= )
v4l? ( media-libs/libv4l )
xcomposite? ( x11-libs/libXcomposite )"
-[[ ${PV} == "9999" ]] || NATIVE_DEPEND="${NATIVE_DEPEND}
- pulseaudio? ( media-sound/pulseaudio )"
COMMON_DEPEND="
!amd64? ( ${NATIVE_DEPEND} )
@@ -105,7 +103,10 @@ COMMON_DEPEND="
app-emulation/emul-linux-x86-baselibs[development]
sys-libs/ncurses[abi_x86_32]
) )
- udisks? ( >=app-emulation/emul-linux-x86-baselibs-20130224[development] )
+ udisks? ( || (
+ >=app-emulation/emul-linux-x86-baselibs-20130224[development]
+ sys-apps/dbus[abi_x86_32]
+ ) )
fontconfig? ( || (
app-emulation/emul-linux-x86-xlibs[development]
media-libs/fontconfig[abi_x86_32]
@@ -171,6 +172,10 @@ COMMON_DEPEND="
>=app-emulation/emul-linux-x86-opengl-20121028[development]
media-libs/mesa[osmesa,abi_x86_32]
) )
+ pulseaudio? ( || (
+ app-emulation/emul-linux-x86-soundlibs[development]
+ >=media-sound/pulseaudio-4.0-r1[abi_x86_32]
+ ) )
xml? ( >=app-emulation/emul-linux-x86-baselibs-20131008[development] )
scanner? ( app-emulation/emul-linux-x86-medialibs[development] )
ssl? ( app-emulation/emul-linux-x86-baselibs[development] )
@@ -188,24 +193,17 @@ COMMON_DEPEND="
) )
)
)"
-[[ ${PV} == "9999" ]] || COMMON_DEPEND="${COMMON_DEPEND}
- amd64? ( abi_x86_32? ( pulseaudio? (
- || (
- app-emulation/emul-linux-x86-soundlibs[development]
- >=media-sound/pulseaudio-4.0-r1[abi_x86_32]
- )
- ) ) )"
RDEPEND="${COMMON_DEPEND}
dos? ( games-emulation/dosbox )
perl? ( dev-lang/perl dev-perl/XML-Simple )
samba? ( >=net-fs/samba-3.0.25 )
selinux? ( sec-policy/selinux-wine )
- udisks? ( sys-fs/udisks:2 )"
-[[ ${PV} == "9999" ]] || RDEPEND="${RDEPEND}
+ udisks? ( sys-fs/udisks:2 )
pulseaudio? ( realtime? ( sys-auth/rtkit ) )"
DEPEND="${COMMON_DEPEND}
+ amd64? ( abi_x86_32? ( !abi_x86_64? ( ${NATIVE_DEPEND} ) ) )
X? (
x11-proto/inputproto
x11-proto/xextproto
@@ -270,8 +268,6 @@ src_prepare() {
"${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
"${FILESDIR}"/${PN}-1.7.2-osmesa-check.patch #429386
"${FILESDIR}"/${PN}-1.6-memset-O3.patch #480508
- )
- [[ ${PV} == "9999" ]] || PATCHES+=(
"../${PULSE_PATCHES}"/*.patch #421365
)
@@ -337,6 +333,7 @@ src_configure() {
$(use_with osmesa)
$(use_with oss)
$(use_with png)
+ $(use_with pulseaudio pulse)
$(use_with threads pthread)
$(use_with scanner sane)
$(use_enable test tests)
@@ -349,8 +346,6 @@ src_configure() {
$(use_with xml xslt)
)
- [[ ${PV} == "9999" ]] || myeconfargs+=( $(use_with pulseaudio pulse) )
-
if use amd64 && use abi_x86_32; then
# Avoid crossdev's i686-pc-linux-gnu-pkg-config if building wine32 on amd64; #472038
# set AR and RANLIB to make QA scripts happy; #483342
diff --git a/app-emulation/wine/wine-1.7.8.ebuild b/app-emulation/wine/wine-1.7.8.ebuild
index 47c27c5621bf..ec129f3779fa 100644
--- a/app-emulation/wine/wine-1.7.8.ebuild
+++ b/app-emulation/wine/wine-1.7.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.7.8.ebuild,v 1.2 2013/12/16 14:31:56 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.7.8.ebuild,v 1.3 2013/12/17 12:33:14 tetromino Exp $
EAPI="5"
@@ -34,7 +34,7 @@ SRC_URI="${SRC_URI}
abi_x86_64? ( mirror://sourceforge/${PN}/Wine%20Gecko/${GV}/wine_gecko-${GV}-x86_64.msi )
)
mono? ( mirror://sourceforge/${PN}/Wine%20Mono/${MV}/wine-mono-${MV}.msi )
- http://dev.gentoo.org/~tetromino/distfiles/${PN}/${PULSE_PATCHES}.tar.bz2
+ pulseaudio? ( http://dev.gentoo.org/~tetromino/distfiles/${PN}/${PULSE_PATCHES}.tar.bz2 )
http://dev.gentoo.org/~tetromino/distfiles/${PN}/${WINE_GENTOO}.tar.bz2"
LICENSE="LGPL-2.1"
@@ -173,6 +173,10 @@ COMMON_DEPEND="
>=app-emulation/emul-linux-x86-opengl-20121028[development]
media-libs/mesa[osmesa,abi_x86_32]
) )
+ pulseaudio? ( || (
+ app-emulation/emul-linux-x86-soundlibs[development]
+ >=media-sound/pulseaudio-4.0-r1[abi_x86_32]
+ ) )
xml? ( >=app-emulation/emul-linux-x86-baselibs-20131008[development] )
scanner? ( app-emulation/emul-linux-x86-medialibs[development] )
ssl? ( app-emulation/emul-linux-x86-baselibs[development] )
@@ -190,24 +194,17 @@ COMMON_DEPEND="
) )
)
)"
-[[ ${PV} == "9999" ]] || COMMON_DEPEND="${COMMON_DEPEND}
- amd64? ( abi_x86_32? ( pulseaudio? (
- || (
- app-emulation/emul-linux-x86-soundlibs[development]
- >=media-sound/pulseaudio-4.0-r1[abi_x86_32]
- )
- ) ) )"
RDEPEND="${COMMON_DEPEND}
dos? ( games-emulation/dosbox )
perl? ( dev-lang/perl dev-perl/XML-Simple )
samba? ( >=net-fs/samba-3.0.25 )
selinux? ( sec-policy/selinux-wine )
- udisks? ( sys-fs/udisks:2 )"
-[[ ${PV} == "9999" ]] || RDEPEND="${RDEPEND}
+ udisks? ( sys-fs/udisks:2 )
pulseaudio? ( realtime? ( sys-auth/rtkit ) )"
DEPEND="${COMMON_DEPEND}
+ amd64? ( abi_x86_32? ( !abi_x86_64? ( ${NATIVE_DEPEND} ) ) )
X? (
x11-proto/inputproto
x11-proto/xextproto
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index aa5e6316b341..dacdaf5b5743 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.160 2013/12/16 14:31:56 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.161 2013/12/17 12:33:14 tetromino Exp $
EAPI="5"
@@ -34,7 +34,7 @@ SRC_URI="${SRC_URI}
abi_x86_64? ( mirror://sourceforge/${PN}/Wine%20Gecko/${GV}/wine_gecko-${GV}-x86_64.msi )
)
mono? ( mirror://sourceforge/${PN}/Wine%20Mono/${MV}/wine-mono-${MV}.msi )
- http://dev.gentoo.org/~tetromino/distfiles/${PN}/${PULSE_PATCHES}.tar.bz2
+ pulseaudio? ( http://dev.gentoo.org/~tetromino/distfiles/${PN}/${PULSE_PATCHES}.tar.bz2 )
http://dev.gentoo.org/~tetromino/distfiles/${PN}/${WINE_GENTOO}.tar.bz2"
LICENSE="LGPL-2.1"
@@ -173,6 +173,10 @@ COMMON_DEPEND="
>=app-emulation/emul-linux-x86-opengl-20121028[development]
media-libs/mesa[osmesa,abi_x86_32]
) )
+ pulseaudio? ( || (
+ app-emulation/emul-linux-x86-soundlibs[development]
+ >=media-sound/pulseaudio-4.0-r1[abi_x86_32]
+ ) )
xml? ( >=app-emulation/emul-linux-x86-baselibs-20131008[development] )
scanner? ( app-emulation/emul-linux-x86-medialibs[development] )
ssl? ( app-emulation/emul-linux-x86-baselibs[development] )
@@ -190,24 +194,17 @@ COMMON_DEPEND="
) )
)
)"
-[[ ${PV} == "9999" ]] || COMMON_DEPEND="${COMMON_DEPEND}
- amd64? ( abi_x86_32? ( pulseaudio? (
- || (
- app-emulation/emul-linux-x86-soundlibs[development]
- >=media-sound/pulseaudio-4.0-r1[abi_x86_32]
- )
- ) ) )"
RDEPEND="${COMMON_DEPEND}
dos? ( games-emulation/dosbox )
perl? ( dev-lang/perl dev-perl/XML-Simple )
samba? ( >=net-fs/samba-3.0.25 )
selinux? ( sec-policy/selinux-wine )
- udisks? ( sys-fs/udisks:2 )"
-[[ ${PV} == "9999" ]] || RDEPEND="${RDEPEND}
+ udisks? ( sys-fs/udisks:2 )
pulseaudio? ( realtime? ( sys-auth/rtkit ) )"
DEPEND="${COMMON_DEPEND}
+ amd64? ( abi_x86_32? ( !abi_x86_64? ( ${NATIVE_DEPEND} ) ) )
X? (
x11-proto/inputproto
x11-proto/xextproto