summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-20 05:33:27 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-20 05:33:27 +0000
commit5fa76e69e2bc4c95723e8a4c55759fcc702c38ec (patch)
tree8d3e30c96b2c609fba52b5effd1fdcc9e8f9b6b3 /app-emulation/winex-transgaming/winex-transgaming-3.3.ebuild
parentFix annoying python2.3 paths which broke emerge on python2.2 systems. Closes ... (diff)
downloadgentoo-2-5fa76e69e2bc4c95723e8a4c55759fcc702c38ec.tar.gz
gentoo-2-5fa76e69e2bc4c95723e8a4c55759fcc702c38ec.tar.bz2
gentoo-2-5fa76e69e2bc4c95723e8a4c55759fcc702c38ec.zip
ver bump #41929
Diffstat (limited to 'app-emulation/winex-transgaming/winex-transgaming-3.3.ebuild')
-rw-r--r--app-emulation/winex-transgaming/winex-transgaming-3.3.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-emulation/winex-transgaming/winex-transgaming-3.3.ebuild b/app-emulation/winex-transgaming/winex-transgaming-3.3.ebuild
new file mode 100644
index 000000000000..689060b7ec1c
--- /dev/null
+++ b/app-emulation/winex-transgaming/winex-transgaming-3.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-transgaming/winex-transgaming-3.3.ebuild,v 1.1 2004/02/20 05:33:27 vapier Exp $
+
+MY_P="winex3_${PV}-1.i386"
+DESCRIPTION="WineX is a distribution of Wine with enhanced DirectX for gaming"
+HOMEPAGE="http://www.transgaming.com/"
+SRC_URI="${MY_P}.tgz"
+
+LICENSE="Aladdin"
+SLOT="3"
+KEYWORDS="x86"
+IUSE="cups opengl"
+RESTRICT="fetch"
+
+RDEPEND="virtual/x11
+ opengl? ( virtual/opengl )
+ >=sys-libs/ncurses-5.2
+ cups? ( net-print/cups )
+ >=media-libs/freetype-2.0.0
+ !app-emulation/winex"
+
+pkg_nofetch() {
+ einfo "Please download the appropriate WineX archive (${MY_P}.tgz)"
+ einfo "from ${HOMEPAGE} (requires a Transgaming subscription)"
+ einfo ""
+ einfo "Then put the file in ${DISTDIR}"
+}
+
+src_install () {
+ mv ${WORKDIR}/usr ${D}
+}
+
+pkg_postinst() {
+ einfo "Run /usr/bin/winex3 to start winex as any non-root user."
+ einfo "This is a wrapper-script which will take care of creating"
+ einfo "an initial environment and do everything else."
+ einfo ""
+ einfo "Optionally, if you have binfmt_misc compiled into your kernel,"
+ einfo "you can add the following to /etc/sysctl.conf to allow direct"
+ einfo "excecution of Windows binaries through the winex wrapper:"
+ einfo ""
+ einfo " fs.binfmt_misc.register = :WINEXE:M::MZ::/usr/bin/winex:"
+ einfo ""
+ einfo "You will also need to mount the /proc/sys/fs/binfmt_misc"
+ einfo "file system in order for this to work. You can add the following"
+ einfo "line into your /etc/fstab file:"
+ einfo ""
+ einfo " none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0"
+ einfo ""
+ einfo "Note: Binaries will still need excecutable permissions to run."
+ einfo "Note: If binfmt_misc is compiled as a module, make sure you"
+ einfo "have it loaded on startup by adding it to /etc/modules.autoload."
+}