summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-16 20:41:04 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-16 20:41:04 +0000
commite3825e28a615eda9fddc9a7ff3b4b8e5ed55f052 (patch)
treea7e4c9200b4c5f51fe2f58abc499b55a91d033ff /app-emulation/winex-transgaming
parentadded s390 keywords (Manifest recommit) (diff)
downloadgentoo-2-e3825e28a615eda9fddc9a7ff3b4b8e5ed55f052.tar.gz
gentoo-2-e3825e28a615eda9fddc9a7ff3b4b8e5ed55f052.tar.bz2
gentoo-2-e3825e28a615eda9fddc9a7ff3b4b8e5ed55f052.zip
ver bump
Diffstat (limited to 'app-emulation/winex-transgaming')
-rw-r--r--app-emulation/winex-transgaming/ChangeLog7
-rw-r--r--app-emulation/winex-transgaming/files/digest-winex-transgaming-3.3.11
-rw-r--r--app-emulation/winex-transgaming/winex-transgaming-3.3.1.ebuild54
3 files changed, 61 insertions, 1 deletions
diff --git a/app-emulation/winex-transgaming/ChangeLog b/app-emulation/winex-transgaming/ChangeLog
index fffaa4c7145f..0b3f6076f3af 100644
--- a/app-emulation/winex-transgaming/ChangeLog
+++ b/app-emulation/winex-transgaming/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/winex-transgaming
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-transgaming/ChangeLog,v 1.10 2004/02/20 05:33:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-transgaming/ChangeLog,v 1.11 2004/04/16 20:41:04 vapier Exp $
+
+*winex-transgaming-3.3.1 (16 Apr 2004)
+
+ 16 Apr 2004; Mike Frysinger <vapier@gentoo.org> :
+ Version bump.
*winex-transgaming-3.3 (20 Feb 2004)
diff --git a/app-emulation/winex-transgaming/files/digest-winex-transgaming-3.3.1 b/app-emulation/winex-transgaming/files/digest-winex-transgaming-3.3.1
new file mode 100644
index 000000000000..31abbd03b97d
--- /dev/null
+++ b/app-emulation/winex-transgaming/files/digest-winex-transgaming-3.3.1
@@ -0,0 +1 @@
+MD5 eb9e30be55a065e73330c62b989f07c6 winex3_3.3.1-1.i386.tgz 7206253
diff --git a/app-emulation/winex-transgaming/winex-transgaming-3.3.1.ebuild b/app-emulation/winex-transgaming/winex-transgaming-3.3.1.ebuild
new file mode 100644
index 000000000000..e39fdbb5e22c
--- /dev/null
+++ b/app-emulation/winex-transgaming/winex-transgaming-3.3.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-transgaming/winex-transgaming-3.3.1.ebuild,v 1.1 2004/04/16 20:41:04 vapier Exp $
+
+MY_P="winex3_${PV}-1.i386"
+DESCRIPTION="WineX is a distribution of Wine with enhanced DirectX for gaming"
+HOMEPAGE="http://www.transgaming.com/"
+SRC_URI="${MY_P}.tgz"
+
+LICENSE="Aladdin"
+SLOT="3"
+KEYWORDS="x86"
+IUSE="cups opengl"
+RESTRICT="fetch"
+
+RDEPEND="virtual/x11
+ opengl? ( virtual/opengl )
+ >=sys-libs/ncurses-5.2
+ cups? ( net-print/cups )
+ >=media-libs/freetype-2.0.0
+ !app-emulation/winex"
+
+pkg_nofetch() {
+ einfo "Please download the appropriate WineX archive (${MY_P}.tgz)"
+ einfo "from ${HOMEPAGE} (requires a Transgaming subscription)"
+ einfo ""
+ einfo "Then put the file in ${DISTDIR}"
+}
+
+src_install () {
+ mv ${WORKDIR}/usr ${D}
+}
+
+pkg_postinst() {
+ einfo "Run /usr/bin/winex3 to start winex as any non-root user."
+ einfo "This is a wrapper-script which will take care of creating"
+ einfo "an initial environment and do everything else."
+ einfo ""
+ einfo "Optionally, if you have binfmt_misc compiled into your kernel,"
+ einfo "you can add the following to /etc/sysctl.conf to allow direct"
+ einfo "excecution of Windows binaries through the winex wrapper:"
+ einfo ""
+ einfo " fs.binfmt_misc.register = :WINEXE:M::MZ::/usr/bin/winex:"
+ einfo ""
+ einfo "You will also need to mount the /proc/sys/fs/binfmt_misc"
+ einfo "file system in order for this to work. You can add the following"
+ einfo "line into your /etc/fstab file:"
+ einfo ""
+ einfo " none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0"
+ einfo ""
+ einfo "Note: Binaries will still need excecutable permissions to run."
+ einfo "Note: If binfmt_misc is compiled as a module, make sure you"
+ einfo "have it loaded on startup by adding it to /etc/modules.autoload."
+}