summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-07-26 16:03:53 +0000
committerIan Delaney <idella4@gentoo.org>2013-07-26 16:03:53 +0000
commite041da8d2b9eae11b5bca431f0e596166fbeffe3 (patch)
tree569798079e49385b6056bbb2e4f99206d3ad524c /app-emulation/xen-tools
parentNew pkg: pecl-redis (diff)
downloadgentoo-2-e041da8d2b9eae11b5bca431f0e596166fbeffe3.tar.gz
gentoo-2-e041da8d2b9eae11b5bca431f0e596166fbeffe3.tar.bz2
gentoo-2-e041da8d2b9eae11b5bca431f0e596166fbeffe3.zip
Alternate fix of file collision with qemu-bridge-helper with corresponding patch wrt Bug #478064
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'app-emulation/xen-tools')
-rw-r--r--app-emulation/xen-tools/ChangeLog7
-rw-r--r--app-emulation/xen-tools/files/qemu-bridge.patch87
-rw-r--r--app-emulation/xen-tools/xen-tools-4.3.0.ebuild22
3 files changed, 109 insertions, 7 deletions
diff --git a/app-emulation/xen-tools/ChangeLog b/app-emulation/xen-tools/ChangeLog
index fdf739554304..42e3fe0f0d17 100644
--- a/app-emulation/xen-tools/ChangeLog
+++ b/app-emulation/xen-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/xen-tools
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.179 2013/07/25 15:09:55 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.180 2013/07/26 16:03:53 idella4 Exp $
+
+ 26 Jul 2013; Ian Delaney <idella4@gentoo.org> +files/qemu-bridge.patch,
+ xen-tools-4.3.0.ebuild:
+ Alternate fix of file collision with qemu-bridge-helper with corresponding
+ patch wrt Bug #478064
25 Jul 2013; Ian Delaney <idella4@gentoo.org> files/xenstored.initd,
xen-tools-4.3.0.ebuild:
diff --git a/app-emulation/xen-tools/files/qemu-bridge.patch b/app-emulation/xen-tools/files/qemu-bridge.patch
new file mode 100644
index 000000000000..a63f081e8734
--- /dev/null
+++ b/app-emulation/xen-tools/files/qemu-bridge.patch
@@ -0,0 +1,87 @@
+diff -ur xen-4.3.0.orig/tools/qemu-xen/.gitignore xen-4.3.0/tools/qemu-xen/.gitignore
+--- tools/qemu-xen/.gitignore 2013-06-28 19:23:16.000000000 +0800
++++ tools/qemu-xen/.gitignore 2013-07-26 23:05:24.487998947 +0800
+@@ -37,7 +37,7 @@
+ qemu-img-cmds.h
+ qemu-io
+ qemu-ga
+-qemu-bridge-helper
++xen-bridge-helper
+ qemu-monitor.texi
+ vscclient
+ QMP/qmp-commands.txt
+diff -ur xen-4.3.0.orig/tools/qemu-xen/Makefile xen-4.3.0/tools/qemu-xen/Makefile
+--- tools/qemu-xen/Makefile 2013-06-28 19:23:16.000000000 +0800
++++ tools/qemu-xen/Makefile 2013-07-26 23:03:35.800991899 +0800
+@@ -50,7 +50,7 @@
+
+ LIBS+=-lz $(LIBS_TOOLS)
+
+-HELPERS-$(CONFIG_LINUX) = qemu-bridge-helper$(EXESUF)
++HELPERS-$(CONFIG_LINUX) = xen-bridge-helper$(EXESUF)
+
+ ifdef BUILD_DOCS
+ DOCS=qemu-doc.html qemu-tech.html qemu.1 qemu-img.1 qemu-nbd.8 QMP/qmp-commands.txt
+@@ -195,7 +195,7 @@
+ qemu-nbd$(EXESUF): qemu-nbd.o $(tools-obj-y) $(block-obj-y) libqemustub.a
+ qemu-io$(EXESUF): qemu-io.o cmd.o $(tools-obj-y) $(block-obj-y) libqemustub.a
+
+-qemu-bridge-helper$(EXESUF): qemu-bridge-helper.o
++xen-bridge-helper$(EXESUF): xen-bridge-helper.o
+
+ vscclient$(EXESUF): $(libcacard-y) $(oslib-obj-y) $(trace-obj-y) libcacard/vscclient.o libqemustub.a
+ $(call quiet-command,$(CC) $(LDFLAGS) -o $@ $^ $(libcacard_libs) $(LIBS)," LINK $@")
+diff -ur xen-4.3.0.orig/tools/qemu-xen/net.h xen-4.3.0/tools/qemu-xen/net.h
+--- tools/qemu-xen/net.h 2013-06-28 19:23:16.000000000 +0800
++++ tools/qemu-xen/net.h 2013-07-26 23:05:01.823997477 +0800
+@@ -163,7 +163,7 @@
+
+ #define DEFAULT_NETWORK_SCRIPT "/etc/qemu-ifup"
+ #define DEFAULT_NETWORK_DOWN_SCRIPT "/etc/qemu-ifdown"
+-#define DEFAULT_BRIDGE_HELPER CONFIG_QEMU_HELPERDIR "/qemu-bridge-helper"
++#define DEFAULT_BRIDGE_HELPER CONFIG_QEMU_HELPERDIR "/xen-bridge-helper"
+ #define DEFAULT_BRIDGE_INTERFACE "br0"
+
+ void qdev_set_nic_properties(DeviceState *dev, NICInfo *nd);
+diff -ur xen-4.3.0.orig/tools/qemu-xen/qemu-bridge-helper.c xen-4.3.0/tools/qemu-xen/qemu-bridge-helper.c
+--- tools/qemu-xen/qemu-bridge-helper.c 2013-06-28 19:23:16.000000000 +0800
++++ tools/qemu-xen/qemu-bridge-helper.c 2013-07-26 23:04:11.880994239 +0800
+@@ -67,7 +67,7 @@
+ static void usage(void)
+ {
+ fprintf(stderr,
+- "Usage: qemu-bridge-helper [--use-vnet] --br=bridge --fd=unixfd\n");
++ "Usage: xen-bridge-helper [--use-vnet] --br=bridge --fd=unixfd\n");
+ }
+
+ static int parse_acl_file(const char *filename, ACLList *acl_list)
+diff -ur xen-4.3.0.orig/tools/qemu-xen/qemu-options.hx xen-4.3.0/tools/qemu-xen/qemu-options.hx
+--- tools/qemu-xen/qemu-options.hx 2013-06-28 19:23:16.000000000 +0800
++++ tools/qemu-xen/qemu-options.hx 2013-07-26 23:05:17.239998477 +0800
+@@ -1560,7 +1560,7 @@
+
+ If running QEMU as an unprivileged user, use the network helper
+ @var{helper} to configure the TAP interface. The default network
+-helper executable is @file{/usr/local/libexec/qemu-bridge-helper}.
++helper executable is @file{/usr/local/libexec/xen-bridge-helper}.
+
+ @option{fd}=@var{h} can be used to specify the handle of an already
+ opened host TAP interface.
+@@ -1584,7 +1584,7 @@
+ #launch a QEMU instance with the default network helper to
+ #connect a TAP device to bridge br0
+ qemu-system-i386 linux.img \
+- -net nic -net tap,"helper=/usr/local/libexec/qemu-bridge-helper"
++ -net nic -net tap,"helper=/usr/local/libexec/xen-bridge-helper"
+ @end example
+
+ @item -netdev bridge,id=@var{id}[,br=@var{bridge}][,helper=@var{helper}]
+@@ -1593,7 +1593,7 @@
+
+ Use the network helper @var{helper} to configure the TAP interface and
+ attach it to the bridge. The default network helper executable is
+-@file{/usr/local/libexec/qemu-bridge-helper} and the default bridge
++@file{/usr/local/libexec/xen-bridge-helper} and the default bridge
+ device is @file{br0}.
+
+ Examples:
diff --git a/app-emulation/xen-tools/xen-tools-4.3.0.ebuild b/app-emulation/xen-tools/xen-tools-4.3.0.ebuild
index 88b022b35e90..edf07742e3b2 100644
--- a/app-emulation/xen-tools/xen-tools-4.3.0.ebuild
+++ b/app-emulation/xen-tools/xen-tools-4.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-4.3.0.ebuild,v 1.11 2013/07/25 15:09:55 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-4.3.0.ebuild,v 1.12 2013/07/26 16:03:53 idella4 Exp $
EAPI=5
@@ -68,9 +68,7 @@ DEPEND="${CDEPEND}
)
hvm? ( x11-proto/xproto
!net-libs/libiscsi )
- qemu? ( x11-libs/pixman
- !app-emulation/qemu )"
-
+ qemu? ( x11-libs/pixman )"
RDEPEND="${CDEPEND}
sys-apps/iproute2
net-misc/bridge-utils
@@ -217,6 +215,12 @@ src_prepare() {
# Bug 477676
epatch "${FILESDIR}"/${PN}-4.3-ar-cc.patch
+ # Prevent file collision with qemu package Bug 478064
+ if use qemu; then
+ epatch "${FILESDIR}"/qemu-bridge.patch
+ mv tools/qemu-xen/qemu-bridge-helper.c tools/qemu-xen/xen-bridge-helper.c || die
+ fi
+
epatch_user
}
@@ -357,8 +361,14 @@ pkg_postinst() {
fi
if use xend; then
- echo
- elog "xend capability has been enabled and installed"
+ elog"";elog "xend capability has been enabled and installed"
+ fi
+
+ if use qemu; then
+ elog "The qemu-bridge-helper is renamed to the xen-bridge-helper in the in source"
+ elog "build of qemu. This allows for app-emulation/qemu to be emerged concurrently"
+ elog "with the qemu capable xen. It is up to the user to distinguish between and utilise"
+ elog "the qemu-bridge-helper and the xen-bridge-helper. File bugs of any issues that arise"
fi
if grep -qsF XENSV= "${ROOT}/etc/conf.d/xend"; then