summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2014-06-13 13:29:48 +0000
committerTiziano Müller <dev-zero@gentoo.org>2014-06-13 13:29:48 +0000
commit0dea9196f13bfc8dfc4ee2c9594a635c1758d7ab (patch)
tree46e0641186f6aaa50a12ff88465e105119042511 /app-emulation
parentVersion bump, remove old. (diff)
downloadgentoo-2-0dea9196f13bfc8dfc4ee2c9594a635c1758d7ab.tar.gz
gentoo-2-0dea9196f13bfc8dfc4ee2c9594a635c1758d7ab.tar.bz2
gentoo-2-0dea9196f13bfc8dfc4ee2c9594a635c1758d7ab.zip
Version bump (bug #503834).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x1A5D023975B0583D!)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/virt-viewer/ChangeLog10
-rw-r--r--app-emulation/virt-viewer/files/virt-viewer-0.6.0-require-C99.patch13
-rw-r--r--app-emulation/virt-viewer/virt-viewer-0.6.0.ebuild47
3 files changed, 68 insertions, 2 deletions
diff --git a/app-emulation/virt-viewer/ChangeLog b/app-emulation/virt-viewer/ChangeLog
index bad1856217c9..df4a75ea6607 100644
--- a/app-emulation/virt-viewer/ChangeLog
+++ b/app-emulation/virt-viewer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/virt-viewer
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-viewer/ChangeLog,v 1.26 2013/08/18 13:27:04 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-viewer/ChangeLog,v 1.27 2014/06/13 13:29:48 dev-zero Exp $
+
+*virt-viewer-0.6.0 (13 Jun 2014)
+
+ 13 Jun 2014; Tiziano Müller <dev-zero@gentoo.org>
+ +files/virt-viewer-0.6.0-require-C99.patch, +virt-viewer-0.6.0.ebuild:
+ Version bump (bug #503834).
18 Aug 2013; Agostino Sarubbo <ago@gentoo.org> virt-viewer-0.5.6.ebuild:
Stable for x86, wrt bug #479682
diff --git a/app-emulation/virt-viewer/files/virt-viewer-0.6.0-require-C99.patch b/app-emulation/virt-viewer/files/virt-viewer-0.6.0-require-C99.patch
new file mode 100644
index 000000000000..b5fe09c28ee8
--- /dev/null
+++ b/app-emulation/virt-viewer/files/virt-viewer-0.6.0-require-C99.patch
@@ -0,0 +1,13 @@
+diff --git a/configure.ac b/configure.ac
+index 067c918..fb9e0ce 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -55,7 +55,7 @@ esac
+ AC_MSG_RESULT([$os_win32])
+ AM_CONDITIONAL([OS_WIN32],[test "$os_win32" = "yes"])
+
+-AC_PROG_CC
++AC_PROG_CC_C99
+ AM_PROG_CC_C_O
+ LT_INIT
+
diff --git a/app-emulation/virt-viewer/virt-viewer-0.6.0.ebuild b/app-emulation/virt-viewer/virt-viewer-0.6.0.ebuild
new file mode 100644
index 000000000000..218bc48e5d31
--- /dev/null
+++ b/app-emulation/virt-viewer/virt-viewer-0.6.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-viewer/virt-viewer-0.6.0.ebuild,v 1.1 2014/06/13 13:29:48 dev-zero Exp $
+
+EAPI=5
+inherit eutils gnome2 autotools
+
+DESCRIPTION="Graphical console client for connecting to virtual machines"
+HOMEPAGE="http://virt-manager.org/"
+SRC_URI="http://virt-manager.org/download/sources/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="sasl +spice +vnc"
+
+RDEPEND=">=app-emulation/libvirt-0.10.0[sasl?]
+ >=dev-libs/libxml2-2.6
+ x11-libs/gtk+:3
+ spice? ( >=net-misc/spice-gtk-0.22[sasl?,gtk3] )
+ vnc? ( >=net-libs/gtk-vnc-0.5.0[sasl?,gtk3] )"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ spice? ( >=app-emulation/spice-protocol-0.10.1 )"
+
+REQUIRED_USE="|| ( spice vnc )"
+
+pkg_setup() {
+ G2CONF="$(use_with vnc gtk-vnc) $(use_with spice spice-gtk)"
+ G2CONF="${G2CONF} --with-gtk=3.0 --without-ovirt"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-require-C99.patch"
+ epatch_user
+ eautoreconf
+}
+
+src_test() {
+ default
+}
+
+src_install() {
+ default
+}