summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-08-05 06:08:53 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-08-05 06:08:53 +0000
commit0f0f3b004ff33228f7f0932e98750085a261fd8b (patch)
tree60ef3c75ebebcd61a9351c52e3588cf7ad0ddde6 /app-emulation
parentVersion bump (diff)
downloadgentoo-2-0f0f3b004ff33228f7f0932e98750085a261fd8b.tar.gz
gentoo-2-0f0f3b004ff33228f7f0932e98750085a261fd8b.tar.bz2
gentoo-2-0f0f3b004ff33228f7f0932e98750085a261fd8b.zip
Picked FluidR3_GM.sf2 from media-sound/fluid-soundfont as a default soundfont (bug #479534 by Michelangelo Scopelliti)
(Portage version: 2.2.0_alpha191_p33/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/dosemu/ChangeLog9
-rw-r--r--app-emulation/dosemu/dosemu-1.4.1_pre20130107-r1.ebuild69
2 files changed, 77 insertions, 1 deletions
diff --git a/app-emulation/dosemu/ChangeLog b/app-emulation/dosemu/ChangeLog
index 28cdf55f6f55..1fb475298fd1 100644
--- a/app-emulation/dosemu/ChangeLog
+++ b/app-emulation/dosemu/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/dosemu
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/ChangeLog,v 1.55 2013/07/17 20:56:54 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/ChangeLog,v 1.56 2013/08/05 06:08:53 slyfox Exp $
+
+*dosemu-1.4.1_pre20130107-r1 (05 Aug 2013)
+
+ 05 Aug 2013; Sergei Trofimovich <slyfox@gentoo.org>
+ +dosemu-1.4.1_pre20130107-r1.ebuild:
+ Picked FluidR3_GM.sf2 from media-sound/fluid-soundfont as a default soundfont
+ (bug #479534 by Michelangelo Scopelliti)
*dosemu-1.4.1_pre20130107 (17 Jul 2013)
diff --git a/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r1.ebuild b/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r1.ebuild
new file mode 100644
index 000000000000..01ae17417d78
--- /dev/null
+++ b/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r1.ebuild,v 1.1 2013/08/05 06:08:53 slyfox Exp $
+
+EAPI=5
+
+inherit flag-o-matic
+
+P_FD="dosemu-freedos-1.0-bin"
+COMMIT="15cfb41ff20a052769d753c3262c57ecb050ad71"
+
+DESCRIPTION="DOS Emulator"
+HOMEPAGE="http://www.dosemu.org/"
+SRC_URI="mirror://sourceforge/dosemu/${P_FD}.tgz
+ http://sourceforge.net/code-snapshots/git/d/do/dosemu/code.git/dosemu-code-${COMMIT}.zip -> ${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="X svga gpm debug alsa sndfile fluidsynth"
+
+RDEPEND="X? ( x11-libs/libX11
+ x11-libs/libXxf86vm
+ x11-libs/libXau
+ x11-libs/libXext
+ x11-libs/libXdmcp
+ x11-apps/xset
+ x11-apps/xlsfonts
+ x11-apps/bdftopcf
+ x11-apps/mkfontdir )
+ svga? ( media-libs/svgalib )
+ gpm? ( sys-libs/gpm )
+ alsa? ( media-libs/alsa-lib )
+ sndfile? ( media-libs/libsndfile )
+ fluidsynth? ( media-sound/fluidsynth
+ media-sound/fluid-soundfont )
+ media-libs/libsdl
+ >=sys-libs/slang-1.4"
+
+DEPEND="${RDEPEND}
+ X? ( x11-proto/xf86dgaproto )
+ >=sys-devel/autoconf-2.57"
+
+S="${WORKDIR}/${PN}-code-${COMMIT}"
+
+src_prepare() {
+ # Has problems with -O3 on some systems
+ replace-flags -O[3-9] -O2
+
+ # Fix compilation on hardened
+ append-flags -fno-pic
+
+ # This one is from media-sound/fluid-soundfont (bug #479534)
+ sed "s,/usr/share/soundfonts/default.sf2,${EPREFIX}/usr/share/sounds/sf2/FluidR3_GM.sf2,"\
+ -i src/plugin/fluidsynth/mid_o_flus.c || die
+}
+
+src_configure() {
+ econf $(use_with X x) \
+ $(use_with svga svgalib) \
+ $(use_enable debug) \
+ $(use_with gpm) \
+ $(use_with alsa) \
+ $(use_with sndfile) \
+ $(use_with fluidsynth) \
+ --with-fdtarball="${DISTDIR}"/${P_FD}.tgz \
+ --sysconfdir="${EPREFIX}"/etc/dosemu/ \
+ --with-docdir="${EPREFIX}"/usr/share/doc/${PF}
+}