summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Rothe <corsair@gentoo.org>2008-02-21 20:30:04 +0000
committerMarkus Rothe <corsair@gentoo.org>2008-02-21 20:30:04 +0000
commit1140193a00812013123e02e7c3750e41a0c52808 (patch)
treecf0c7fc059ad56e5f3ebb337143529b55f98607d /app-emulation
parentStable for HPPA (bug #210642). (diff)
downloadgentoo-2-1140193a00812013123e02e7c3750e41a0c52808.tar.gz
gentoo-2-1140193a00812013123e02e7c3750e41a0c52808.tar.bz2
gentoo-2-1140193a00812013123e02e7c3750e41a0c52808.zip
Drop the cowdiskname patch, because using 'systemsim -g' *just works*. Executing run_gui directly is bad.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/systemsim-cell/ChangeLog10
-rw-r--r--app-emulation/systemsim-cell/files/systemsim-cell-3.0-cowdiskname.patch24
-rw-r--r--app-emulation/systemsim-cell/systemsim-cell-3.0-r1.ebuild (renamed from app-emulation/systemsim-cell/systemsim-cell-3.0.ebuild)9
3 files changed, 11 insertions, 32 deletions
diff --git a/app-emulation/systemsim-cell/ChangeLog b/app-emulation/systemsim-cell/ChangeLog
index 26dd0f81d511..881ea9156e1d 100644
--- a/app-emulation/systemsim-cell/ChangeLog
+++ b/app-emulation/systemsim-cell/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/systemsim-cell
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/systemsim-cell/ChangeLog,v 1.2 2008/02/12 18:21:53 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/systemsim-cell/ChangeLog,v 1.3 2008/02/21 20:30:03 corsair Exp $
+
+*systemsim-cell-3.0-r1 (21 Feb 2008)
+
+ 21 Feb 2008; Markus Rothe <corsair@gentoo.org>
+ -files/systemsim-cell-3.0-cowdiskname.patch, -systemsim-cell-3.0.ebuild,
+ +systemsim-cell-3.0-r1.ebuild:
+ Drop the cowdiskname patch, because using 'systemsim -g' *just works*.
+ Executing run_gui directly is bad.
12 Feb 2008; Markus Rothe <corsair@gentoo.org> +metadata.xml:
Add metadata.xml
diff --git a/app-emulation/systemsim-cell/files/systemsim-cell-3.0-cowdiskname.patch b/app-emulation/systemsim-cell/files/systemsim-cell-3.0-cowdiskname.patch
deleted file mode 100644
index 7d6dcdb1b95a..000000000000
--- a/app-emulation/systemsim-cell/files/systemsim-cell-3.0-cowdiskname.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- opt/ibm/systemsim-cell/lib/cell/systemsim.tcl.orig 2008-02-12 17:45:10.000000000 +0100
-+++ opt/ibm/systemsim-cell/lib/cell/systemsim.tcl 2008-02-12 17:52:09.000000000 +0100
-@@ -17,6 +17,12 @@
-
- set IMAGES $env(IMAGES_DIR)/cell
-
-+if { [info exists ::env(COWDISKNAME) ] } {
-+ set cowdiskname $env(COWDISKNAME)
-+} else {
-+ set cowdiskname $env(HOME)/sysroot_disk.cow
-+}
-+
- # Initialize the systemsim tcl environment
- source $env(LIB_DIR)/cell/mambo_init.tcl
-
-@@ -78,7 +84,7 @@
- mysim mcm 0 load vmlinux $imagefile 0x1000000
-
- # Setup the bogus disk that Linux will use
--if {[catch {mysim bogus disk init 0 $sysrootfile newcow sysroot_disk.cow 1024}]} {
-+if {[catch {mysim bogus disk init 0 $sysrootfile newcow $cowdiskname 1024}]} {
- puts "bogus disk init for $sysrootfile failed"
- exit
- }
diff --git a/app-emulation/systemsim-cell/systemsim-cell-3.0.ebuild b/app-emulation/systemsim-cell/systemsim-cell-3.0-r1.ebuild
index 49174234394c..99d9dd0bf6d2 100644
--- a/app-emulation/systemsim-cell/systemsim-cell-3.0.ebuild
+++ b/app-emulation/systemsim-cell/systemsim-cell-3.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/systemsim-cell/systemsim-cell-3.0.ebuild,v 1.1 2008/02/12 18:19:40 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/systemsim-cell/systemsim-cell-3.0-r1.ebuild,v 1.1 2008/02/21 20:30:03 corsair Exp $
inherit rpm eutils
@@ -31,14 +31,11 @@ pkg_nofetch() {
}
src_unpack() {
- rpm_unpack $DISTDIR/${A}
+ rpm_unpack "$DISTDIR"/${A}
# fix the path to the images. we don't want them in /opt
sed -i -e "s:\${SYSTEMSIM_TOP}/images:${IMAGE_PATH}:" \
"${WORKDIR}"/"${SYSTEMSIM_DIR}"/bin/systemsim || die "sed error"
-
- # fix the path to the file that 'overlaps' the image
- epatch "${FILESDIR}/${P}-cowdiskname.patch"
}
src_compile() {
@@ -60,6 +57,4 @@ src_install() {
pkg_postinst() {
elog "The provided systemsim doesn't have kernel and system images, please"
elog "install them in ${IMAGE_PATH}/cell"
- elog "Use the COWDISKNAME environment variable to change the file"
- elog "'overlapping' the image. Default (not set) is \$HOME/sysroot_disk.cow"
}