summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-06-22 01:36:38 +0000
committerMike Frysinger <vapier@gentoo.org>2007-06-22 01:36:38 +0000
commit120e6d036729c6de3e305d3de746fdee76e1aa4d (patch)
treee2a9b9f07b23f8594311f48051c6b10f71d94982 /app-emulation
parentfixes from upstream for #179554 and #182374 (diff)
downloadgentoo-2-120e6d036729c6de3e305d3de746fdee76e1aa4d.tar.gz
gentoo-2-120e6d036729c6de3e305d3de746fdee76e1aa4d.tar.bz2
gentoo-2-120e6d036729c6de3e305d3de746fdee76e1aa4d.zip
Version bump #182757 by Jukka Palko.
(Portage version: 2.1.3_rc3)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/cedega/ChangeLog7
-rw-r--r--app-emulation/cedega/cedega-6.0.2.ebuild63
-rw-r--r--app-emulation/cedega/files/digest-cedega-6.0.23
3 files changed, 72 insertions, 1 deletions
diff --git a/app-emulation/cedega/ChangeLog b/app-emulation/cedega/ChangeLog
index 2322e8a64c6a..86f25ce5e2f7 100644
--- a/app-emulation/cedega/ChangeLog
+++ b/app-emulation/cedega/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/cedega
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/ChangeLog,v 1.27 2007/04/19 00:31:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/ChangeLog,v 1.28 2007/06/22 01:36:38 vapier Exp $
+
+*cedega-6.0.2 (22 Jun 2007)
+
+ 22 Jun 2007; Mike Frysinger <vapier@gentoo.org> +cedega-6.0.2.ebuild:
+ Version bump #182757 by Jukka Palko.
*cedega-6.0 (19 Apr 2007)
diff --git a/app-emulation/cedega/cedega-6.0.2.ebuild b/app-emulation/cedega/cedega-6.0.2.ebuild
new file mode 100644
index 000000000000..8fadee6a689d
--- /dev/null
+++ b/app-emulation/cedega/cedega-6.0.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/cedega-6.0.2.ebuild,v 1.1 2007/06/22 01:36:38 vapier Exp $
+
+MY_P="cedega-small-${PV}"
+DESCRIPTION="Cedega replaces WineX, a distribution of Wine with enhanced DirectX for gaming"
+HOMEPAGE="http://www.transgaming.com/"
+SRC_URI="${MY_P}.tgz"
+
+LICENSE="cedega"
+SLOT="3"
+KEYWORDS="-* amd64 x86"
+IUSE="cups dbus opengl"
+RESTRICT="fetch strip multilib-strict"
+
+RDEPEND="|| ( ( x11-libs/libX11 ) virtual/x11 )
+ opengl? ( virtual/opengl )
+ dbus? ( sys-apps/dbus )
+ >=sys-libs/ncurses-5.2
+ cups? ( net-print/cups )
+ >=media-libs/freetype-2.0.0
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.6
+ >=dev-util/glade-2.6
+ !app-emulation/point2play
+ amd64? ( app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-soundlibs )"
+
+pkg_nofetch() {
+ einfo "Please download the appropriate Cedega archive (${MY_P}.tgz)"
+ einfo "from ${HOMEPAGE} (requires a Transgaming subscription)"
+ einfo
+ einfo "Then put the file in ${DISTDIR}"
+}
+
+src_install() {
+ rm -r "${WORKDIR}"/usr/share/gnome
+ rmdir "${WORKDIR}"/usr/share/* >& /dev/null
+ mv "${WORKDIR}"/usr "${D}"/ || die "mv usr"
+}
+
+pkg_postinst() {
+ einfo "Run /usr/bin/cedega to start cedega as any non-root user."
+ einfo "This is a wrapper-script which will take care of creating"
+ einfo "an initial environment and do everything else."
+ einfo ""
+ einfo "Optionally, if you have binfmt_misc compiled into your kernel,"
+ einfo "you can add the following to /etc/sysctl.conf to allow direct"
+ einfo "execution of Windows binaries through the cedega wrapper:"
+ einfo ""
+ einfo " fs.binfmt_misc.register = :WINEXE:M::MZ::/usr/bin/cedega:"
+ einfo ""
+ einfo "You will also need to mount the /proc/sys/fs/binfmt_misc"
+ einfo "file system in order for this to work. You can add the following"
+ einfo "line into your /etc/fstab file:"
+ einfo ""
+ einfo " none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0"
+ einfo ""
+ einfo "Note: Binaries will still need executable permissions to run."
+ einfo "Note: If binfmt_misc is compiled as a module, make sure you"
+ einfo "have it loaded on startup by adding it to"
+ einfo "/etc/modules.autoload.d/<your kernel version>"
+}
diff --git a/app-emulation/cedega/files/digest-cedega-6.0.2 b/app-emulation/cedega/files/digest-cedega-6.0.2
new file mode 100644
index 000000000000..14e1d6f8717b
--- /dev/null
+++ b/app-emulation/cedega/files/digest-cedega-6.0.2
@@ -0,0 +1,3 @@
+MD5 6cf58b18dde42ea292ac79eb68a24cda cedega-small-6.0.2.tgz 1826449
+RMD160 7268764b8d6e33c49b5f7a8d8668d9a2ae50fbe8 cedega-small-6.0.2.tgz 1826449
+SHA256 4cce1790692c60c1a3018222922393439ab7a0944fde8a3d9c22ca0f354f040d cedega-small-6.0.2.tgz 1826449